fog 1.2 vs 1.4



  • Hi ,
    I noted that when starts a winpe iso image from fog 1.4 after the load process show the message " Press any key to boot from CD "; with Fog 1.2 the same iso image with the same command start sintax " kernel, memdisk etc … " , after loaded the iso image the O.S starts without show the same message " press any key … ".
    Where are the difference ?
    i tried different syntax ( sanboot, chain etc … ) , but with fog 1.4 the results are the sames !

    regards


  • Senior Developer

    @Sebastian-Roth I still think you’re correct.

    The CD SHOULD be asking you to “press any key to boot from CD”. Is there some reason this is a big concern? Sure it adds another step, but I think the reasoning is something in 1.2 iPXE code wasn’t sending the HDD, where in newer versions it’s releasing the system allowing the ISO to actually see the HDD prompting it to run a scan.

    I don’t understand what problem it working as if this was a CD being booting this brings to the table.


  • Developer

    @zingaro Alright then, proofed me wrong. So my guess is the newer version of iPXE is doing things differently. Can you please post the startup syntax code you are using in the advanced FOG menu? Maybe I am able to find what changed in the iPXE code…



  • i tried identical machine with hdd installed:
    with fog 1.2 ( server on vm machine ) winpe.iso does not shows the message
    with fog 1.4 ( phisical server machine ) winpe.iso shows the message.

    the startup sintax command into advanced fog menu is the same…


  • Developer

    @zingaro As far as I know the message “Press any key to boot from CD” appears only if the CD detects a system on disk. So from my point of view this has nothing to do with FOG 1.2 vs. 1.4. Please boot this same ISO from your 1.4.x server on a PC with no hard disk or a completely empty (new) hard drive. See if it makes a difference.


Log in to reply
 

361
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.