SOLVED Host management page show red exclamation for all hosts


  • Server
    • FOG Version: 1.40
    • OS: Ubuntu 16
    Client
    • Service Version: latest
    • OS: win 10 and 7
    Description

    I have a working FOG setup. I can ip boot and everything, the problem I am having is with the server(Linux) being able to ping and talk to the windows PCs in my domain. From the server, I can ping any IP address but if I try and ping a host name I get: unknown host
    From Windows machines, I can ping the server by IP and Hostname(added a dns entry to ping by hostname)
    I have dug around looking at the resolvconf files and if I open my /etc/resolv.conf file, It is:
    nameserver 127.0.0.1
    Search my-domain
    Nameserver my main DNS server

    If I delete the first line, I am then able to ping all of the windows machines. But of course this file is overwritten every few hours so that won’t work.

    I am using dnsmasq since our voip phone system uses option 66 and 67.

    I am only assuming that the hosts show up as red with an exclamation because the server can’t ping the clients hostname. Is this correct? Is there something I missed? Anything I can try?

  • Moderator

    @chris.dees If it works for you, then it was the right fix. Run with it.


  • @george1421 I think I fixed my issue. I wasn’t able to delete the nameserver 127.0.0.1 line but by modifying the resolv.conf.d/ head file, I was able to insert our local DNS nameserver to the top of the file. Hosts came up green after that. Now, After a whole 24hours and a reboot, all my hosts are still showing green. I have tried to boot to ip yet, is this a good fix or would this mess up dnsmasq at all?


  • @Tom-Elliott I am using Ubuntu 14.04 so, systemctl isn’t used… however, Service FOGPingHosts status shows it is running


  • @oldirtdog, @chris-dees Can you check the status of the FOG Ping service?

    systemctl -l status FOGPingHosts
    

    Can you provide the logs for the PingHosts service?


  • I am getting this same thing… however, when I ping the hostname of a windows machine on my network, it replies just fine… my resolve.conf shows both of my local DNS servers and my default domain. I can ping google.com just fine as well. What’s strange is it was working just fine before I rebooted the FOG server. After the reboot, now I have red !'s on all of my hosts. Is there something I need to do to refresh them?

  • Moderator

    @chris.dees said in Host management page show red exclamation for all hosts:

    nameserver 127.0.0.1

    Dnsmasq is doing this to you. Or more precisely the ubuntu startup script for dnsmasq is doing this to you. @Quazz posted about this a while ago. The dnsmasq startup script is not honoring the flag in the config file to not have dnsmasq act as a dns server.

    ref: https://forums.fogproject.org/topic/7193/ubuntu-14-04-lts-with-dnsmasq-no-external-dns

  • Moderator

    @chris-dees Ever since Ubuntu 12.04 the DNS configuration is managed by resolveconf, NetworkManager and dnsmasq. More details see here, here and here

345
Online

9.9k
Users

16.2k
Topics

148.9k
Posts