not syncing: VFS



  • Server
    • FOG Version: 1.4

    Hello,
    I have often encountered this problem with Fog.

    Here is my solution:

    In the / tftpboot directory

    Renamed the pxelinux.0 file to pxelinux.0.backup

    Then I make a symbolic link like this

    ln -s undionly.kpxe pxelinux.0

    I think this problem is also related to my config in my dhcp server

    Regards,
    Jacky


  • Moderator

    I think you are fixing a problem the wrong way. The pxelinux.0 is an old boot kernel that should never be used now. If you do use it you WILL get the error you mentioned.

    For FOG 1.3.x and beyond you should either use undionly.kpxe for legacy (bios) mode and ipxe.efi for uefi mode. For your setup you need to modify your dhcp server and change dhcp option 67 {boot-file} to undionly.kpxe. While what you did will work its a non-standard setup that may break on the next update to FOG.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.