Fog 1.4.2 Unable to locate Image Store (/bin/fog.download)



  • Server
    • FOG Version: 1.4.0 & 1.4.2
    • OS: Ubuntu 16.04
    Client
    • Service Version:
    • OS: Windows 7 Ent 64bit
    Description

    I recently installed a new server at one of our sites and have run into a problem after trying to deploy our image from the new server. When choosing a host and selecting deploy after reaching the PXE screen it displays the error “Unable to locate image store (/bin/fog.download)” The process I use is I create a “Master” image on a VM at my main office then using a flash drive to copy the image to all of our fog servers at our remote sites. I know the image is good because it worked at both my office and another site running Fog 1.4.0.
    I have done this process for a few years now so I am unclear as to what is causing the problem. As stated, one server that the image DID work on is running Fog 1.4.0 but the server giving me issues I have tried using Fog 1.3.5, 1.4.0 and 1.4.2. All rights to the “/images/” directory are set to 777 and ownership is fog:root of the image. I have looked through the Forums but I was unable to find anything that has helped so far. Any assistance would be welcome!

    Thanks,


  • Senior Developer

    @FlareImp It looks like the TVNE-Fog server didn’t have the whole image. The pic on the left is larger (at least the d1p2.img is) than the one on the right.



  • Okay, still have no idea what caused the issue but I deleted the image on the server under the GUI and recreated it. Now my server is deploying the image just fine. Any ideas as to why? I did not change anything so I am at a loss.



  • @Tom-Elliott here is what I see after comparing the two. The left is the nonworking server and the right is the one it works on. The only thing I noticed is the size difference. Which is do to the fact that I tried recreating the “Master” image.

    0_1496850182585_compare.PNG


  • Senior Developer

    @FlareImp and they both contain the same files?

    HINT: (ls -lhart /images/Win7MasterNoIEV3 will help, compare from both points – working and non-working)



  • @Tom-Elliott I compared it to the directory on the fog server that the image works on and everything matches up. I even tried copying the image from the remote site that the image is working at rather than my office where I build the images and it does the same thing.



  • Yes, the name of the image is “Win7MasterNoIEV3” under “Image Name” and Image Path" under the image management GUI and under the image directory. I just copied pasted the name once the image directory was copied over. I have even tried hand typing it out and all upper and lower case matches perfectly.


  • Senior Developer

    Does the /images/<imagename> directory exist as expected from the database -> imagePath setting?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.