PXE Boot Problem - bzImage Connection Reset



  • Server
    • FOG Version: 1.4.0
    • OS: Linux Mint
    Client
    • Service Version:
    • OS:
    Description

    Hi. Hey. I have a problem with the Fog server ( I’m sorry for my English but I’m from Poland. ) Trying to implement a server into an existing school network. The FOG server has been installed correctly and does not have direct access to the DHCP server, so the way was used with DHCPProxy ( DNSMASQ ). Everything worked fine and the menu to register the host is displayed.
    Nothing was changed in the configuration except of course files from DNSMASQ (ltsp.conf). Everything worked as it should, but only on the menu began to run problems.

    Everything works fine when you start up from the network. The menu appears, but when you choose the option of full host registration or any other, you get some error. ( As you can see in the picture )
    0_1496167671109_18789871_993343070768485_883504482_o.jpg

    I know there are specialists here, so I hope they will help me solve the problem.
    Thank you for your effort and help.


  • Developer

    @sanman Well done. Thanks for letting us know. Might be helpful for other users as well. Marking this solved.



  • So I think I figured it out in my case. We have a MX64 Firewall (Meraki) and after getting off of tech support with them they recommended I turn off AMP (Malware Protection). After doing this everything started working perfect. Hope this helps!



  • @george1421 Since I think I’m having the same issue and don’t want to create a new thread, here is my pcap. This capture is during registration. bzimage gets to 99% and then times out with a connection reset error. If you think this a different problem, I’ll create a new thread. The pcap is too large to upload so here is a link to download it (7.6mb).

    Download PCAP



  • This post is deleted!

  • Moderator

    @george1421 Next steps: https://forums.fogproject.org/topic/9673/when-dhcp-pxe-booting-process-goes-bad-and-you-have-no-clue

    But for you I want you to use this filter: tcpdump -w output.pcap port 67 or port 68 or port 69 or port 4011 or port 80

    capture the pcap file and upload it here. I want to find out exactly what the client is being told to do. I feel you have something in your business environment that is causing strange reactions from the client.


  • Moderator

    @george1421 Never mind we already did this down below in the thread.


  • Moderator

    @maciej12203 Sorry i read too many threads to remember where we are in each one.

    I remember this now your FOG server is rejecting the http request.

    two things come to mind

    1. Your http server is not running.
    2. You have your linux firewall still running.
    3. (I guess) someone forgot to switch selinux to permissive.

    I would test from a windows browser see if you can connect to http://192.168.4.70/fog/service/ipxe/boot.php
    I’m interested in if anything is returned.



  • @george1421 So I know how it all works and what is DNSMASQ.
    I tested this at home and everything was fine. When I tried to move it to the existing network at school, problems began to appear, which until now have not resolved. At first, after configuring FOG and DNSMASQ, clients could call the menu where they had options to choose , what I wrote about before.
    Unfortunately today I checked the effect without any previous changes and I got the error as in the picture.
    0_1496678805213_18946921_998533130249479_1391211520_o.jpg


  • Moderator

    @maciej12203 OK now we have something we can work with.

    Since your have an existing dhcp server you do not want to run a FOG dhcp server because you will get conflicts.

    If you can not modify the dhcp server configuration or request that the configuration can be changed we still have a way to make this work. On your fog server DO NOT enable the dhcp server, that will only cause you a head ache with the clients.

    Since your FOG server and pxe booting clients are on the same subnet we will use dnsmasq to provide ProxyDHCP information for your location. The ProxyDHCP will supply the missing information that your main dhcp server can not provide. This ProxyDHCP server will supply the boot file and pxe booting server information to your clients.

    Understand that running a ProxyDHCP server is a last choice option. The best solution is to get your dhcp server configured properly. I understand there are conditions where you can not do this, that is why FOG supports ProxyDHCP (dnsmasq) configurations.



  • @george1421

    1. The network is running a DHCP server and assigns IP addresses.
    2. I have no rights or access to modify this server.
    3. The FOG server is on the same subnet as the PXE boot clients

  • Moderator

    @maciej12203 Lets take a step back here.

    Does your network have an existing dhcp server?
    If so are you allowed to make adjustments to this dhcp server?
    Is your FOG server on a different subnet than your pxe booting client computers?



  • I checked everything and was configured correctly. The server still did not work as it should, so I decided to install FOG server again. Maybe I made some mistake when installing the server. I have one more question as to its installation to be 100 percent sure.
    I did not want to set up a separate topic so I’m asking a question here. I found on the Wiki page information about how to install for the type of network. Which is not too much access to change anything because it is in the school server to which it does not have access.
    All the computers in the room are connected to the switch, the switch itself on the router in the server room.
    The network already exists for a year and is fully operational.

    What type of installation would you like to do? [N] n
    
    What is the IP address to be used by this FOG Server? [current address]192.168.4. 70 ( Static Address )
    
    Would you like to setup a router address for the DHCP server? [Y/n] n
    
    Would you like to setup a DNS address for the DHCP server and client boot image? [Y/n] n
    
    Would you like to change the default network interface from eth0?
    If you are not sure, select No. [y/N] n
    
    Would you like to use the FOG server for dhcp service? [Y/n] Y
    
    

    Thank you for your help.



  • @Tom-Elliott
    In configuration after installing FOG server there was nothing to change. I’m pretty sure that FOG_WEB_ROOT is set to / fog / . Is it possible that the server itself has some options?
    I have installed many times a server in my environment either virtual or physical, and somehow there was no problem with different options for FOG server side setting .

    Probably you are right, because I noticed that it gets access to the GUI just as I enter - http://192.168.4.70/fog/
    When I enter http://192.168.4.70 or http://192.168.4.70/ unfortunately, the GUI will not trigger.
    Of course I do not know myself so well and I will check this option when I have access to the server.


  • Senior Developer

    Please check FOG Configuration Page->FOG Settings->General Settings-FOG_WEB_ROOT

    Set to /fog/ and this should be corrected for. I’m guessing the connection reset came from the 401/403 error being presented to something missed in the Schema settings. This would typically happen on “fresh” installs and shouldn’t have impacted already working systems.



  • @sanman
    I see we have a similar problem. I also reinstalled the server, but the problem is still the same.
    However, there may be someone who has an idea how to solve the problem. I recently used FOG server, installed it on my home network and everything worked as it should. When I moved my idea to the school network came the problem.



  • I would like to add that I just did a fresh install of fog 1.4 on Ubuntu 16.04 and this same issue is happening. I made a static bond interface then installed fog. The register didn’t work so left it over night and the next day it was working. Now today (a week later) it is giving the same error. My apache error log is also blank. My bzimage gets to 99% then I receive error that the connection reset. I will be happy to provide any info you need.

    I have used fog for years and this is the first time I have an issue I can’t fix.



  • @Sebastian-Roth
    Thank you for your hint. I will definitely check.
    And when logs do not show anything.
    @george1421 Are there any other suggestions that could still be checked on the server side?


  • Developer

    @maciej12203 As the kernel (bzImage) is being downloaded via HTTP by iPXE could you please check the apache error logs. See my signature on where to find the log on your FOG server.



  • @george1421 Yes, this is a statically set address


Log in to reply
 

361
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.