Virtualbox PXE Boot - No configuration methods succeeded



  • Server
    • FOG Version: 1.4.0
    • OS: Ubuntu 17.04
    Client
    • Service Version:
    • OS:
    Description

    I have Virtualbox 5.1.22 with the extension pack installed. Host OS is Windows 10 Pro 64-bit. Trying to register a Guest OS image with Windows 7 Pro 64-bit.
    I’m new to FOG and haven’t had PXE booting working correctly yet.

    The network is 10.1.10.0/24 and has an unmanaged netgear switch, with only the router, FOG server, and Virtualbox Host machine on it.
    The FOG server is on 10.1.10.9 and configured to serve DHCP. Virtualbox is 10.1.10.100. Guest OS is using a bridged network interface, and gets an IP from FOG when it boots from the HD.

    I originally had FOG 1.3.5 stable, and it had this error: No configuration methods succeeded.
    I upgraded to FOG 1.4.0 stable today, and it appears to have the same problem.

    0_1495840787778_virtualbox-net-config.png
    0_1495840799082_virtualbox-pxe.png

    I’m unsure what to try next. Thanks in advance.


  • Senior Developer

    @george1421 I’m using ipxe.pxe as the boot file. Not replacing the version VB’s NIC’s are set too. (Though I imagine that would work well too.)


  • Moderator

    @Tom-Elliott said in Virtualbox PXE Boot - No configuration methods succeeded:

    I’ve seen this too though the fix for me was to use ipxe.pxe

    Just for clarity, you are using ipxe.pxe from the fog /tftpboot directory replacing the VBox version/file? This resolves the issue?


  • Senior Developer

    @george1421 I’ve seen this too though the fix for me was to use ipxe.pxe with VB and no more issues with warm boot failing.


  • Moderator

    @sandervg said in Virtualbox PXE Boot - No configuration methods succeeded:

    PXE boot is working perfect on a cold boot. But when I restart my vm I get the error that no configuration method succeeded.

    FWIW: I also see this in my dev environment. Its an issue with virtual box and not your environment. When this happens I just have to power off the vm to do a cold boot. It not the answer you were looking for, but I just wanted you to know its not a unique issue.



  • I am facing the same issue as mentioned here. With a small difference. PXE boot is working perfect on a cold boot. But when I restart my vm I get the error that no configuration method succeeded. Using ipxe.kpxe is a solution for my virtualbox vm’s but causes physical computers to stop working. I guess the best option would be to match the UUID of my vm’s in my dnsmasq.conf and send the right PXE file. But in the syslog i can only see part of my client-machine-id. Any ideas on a good solution for my problem? vendor class: PXEClient:Arch:00000:UNDI:002001 this is the same for all my machines so I can’t switch on thath.



  • @austin_g IPXE.kpxe is needed now for VMs as this wasn’t always the case. I’ve found that recently i have run into this more frequently as of late. That (I can confirm) is the only change necessary for sure pxe boot with Virtualbox VM. Probably on Virtualbox’s end I’d imagine given the timing.



  • Setting it explicitly and removing the class matches did the trick, I got into the boot rom. After that, I coped back the old config, and replaced the Legacy class match filename with ipxe.pxe, and that worked also.

    Thanks!



  • I’m fuzzy about that part. I see class definitions in the dhcpd.conf that FOG installs that matches against vendor-class-identifier. I’m not sure what the vendor class identifier for virtualbox would return, but looking at the dhcpd.conf, there is no default option that it would select? I’ll try setting ipxe.pxe explicitly without the class matching.


  • Senior Developer

    @austin_g just because it’s booting to ipxe does not mean it should work. What boot file are you using? In the past I had to use ipxe.pxe for virtual box to work consistently. Of course other factors could cause the problem I suppose.



  • It’s configured as Bridged, as shown in the first screenshot.
    The FOG server is handling DHCP. It appears to be assigning IPs correctly, and the next-server is set to the FOG server ip. There aren’t any other DHCP servers on that subnet.


  • Senior Developer

    @austin_g Is the VM setup with a “NAT” nic or “Bridged” nic?

    What’s providing DHCP to the VM?



  • It is booting into iPXE as shown in the second screenshot, unless you mean something else?

    I have tried powering off the VM and powering it on a few times (not reboot) and it always has that error.


  • Senior Developer

    Either change the VirtualBox boot rom to use ipxe, or you have to power off, and power on.


Log in to reply
 

341
Online

6.1k
Users

13.4k
Topics

126.4k
Posts