Virtualbox PXE Boot - No configuration methods succeeded



  • Server
    • FOG Version: 1.4.0
    • OS: Ubuntu 17.04
    Client
    • Service Version:
    • OS:
    Description

    I have Virtualbox 5.1.22 with the extension pack installed. Host OS is Windows 10 Pro 64-bit. Trying to register a Guest OS image with Windows 7 Pro 64-bit.
    I’m new to FOG and haven’t had PXE booting working correctly yet.

    The network is 10.1.10.0/24 and has an unmanaged netgear switch, with only the router, FOG server, and Virtualbox Host machine on it.
    The FOG server is on 10.1.10.9 and configured to serve DHCP. Virtualbox is 10.1.10.100. Guest OS is using a bridged network interface, and gets an IP from FOG when it boots from the HD.

    I originally had FOG 1.3.5 stable, and it had this error: No configuration methods succeeded.
    I upgraded to FOG 1.4.0 stable today, and it appears to have the same problem.

    0_1495840787778_virtualbox-net-config.png
    0_1495840799082_virtualbox-pxe.png

    I’m unsure what to try next. Thanks in advance.



  • @austin_g IPXE.kpxe is needed now for VMs as this wasn’t always the case. I’ve found that recently i have run into this more frequently as of late. That (I can confirm) is the only change necessary for sure pxe boot with Virtualbox VM. Probably on Virtualbox’s end I’d imagine given the timing.



  • Setting it explicitly and removing the class matches did the trick, I got into the boot rom. After that, I coped back the old config, and replaced the Legacy class match filename with ipxe.pxe, and that worked also.

    Thanks!



  • I’m fuzzy about that part. I see class definitions in the dhcpd.conf that FOG installs that matches against vendor-class-identifier. I’m not sure what the vendor class identifier for virtualbox would return, but looking at the dhcpd.conf, there is no default option that it would select? I’ll try setting ipxe.pxe explicitly without the class matching.


  • Senior Developer

    @austin_g just because it’s booting to ipxe does not mean it should work. What boot file are you using? In the past I had to use ipxe.pxe for virtual box to work consistently. Of course other factors could cause the problem I suppose.



  • It’s configured as Bridged, as shown in the first screenshot.
    The FOG server is handling DHCP. It appears to be assigning IPs correctly, and the next-server is set to the FOG server ip. There aren’t any other DHCP servers on that subnet.


  • Senior Developer

    @austin_g Is the VM setup with a “NAT” nic or “Bridged” nic?

    What’s providing DHCP to the VM?



  • It is booting into iPXE as shown in the second screenshot, unless you mean something else?

    I have tried powering off the VM and powering it on a few times (not reboot) and it always has that error.


  • Senior Developer

    Either change the VirtualBox boot rom to use ipxe, or you have to power off, and power on.


Log in to reply
 

777
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.