Not Joining to Domain after imaging



  • Running Version 1.4.0
    SVN Revision: 6069

    After deploying an image (Windows 10), the PC is not joining the domain even though I have it set to at the group and I can see the settings on the individual device as well.

    I have tried the troubleshooting here: https://wiki.fogproject.org/wiki/index.php/Active_Directory_-_FOG_Setting

    Is gives me that netdom does not exist.

    Any ideas? Any other troubleshooting I can try?



  • @quinniedid There is a .msi version of the client that you could use to install the newer client with the correct address. Unsure if old client would need uninstalled first.

    If you have a way to push out a PowerShell script, something like this might help.

    $FOG = Get-WmiObject -Class Win32_Product | Where-Object -Property Name -EQ 'FOG Service'
    $FOG.Uninstall()
    
    $url = "http://<ip address>/fog/client/download.php?newclient"
    $outfile = "FOGService.msi"
    (New-Object System.Net.WebClient).DownloadFile($url, $outfile)
    
    $ArgumentList = "/i $outfile /quiet USETRAY=""0"" WEBADDRESS=""<ip address>"" WEBROOT=""/fog"" /norestart"
    Start-Process -FilePath MSIEXEC.exe -ArgumentList $ArgumentList -Wait
    
    Start-Service -Name FOGService
    Start-Sleep -Seconds 2
    Restart-Computer -Force
    


  • I have figured this out. The client that is on the image is pointing to an old FOG server. Is there a way to change the settings on the machine somewhere to the new IP address? Also do I have to use an IP address or can I use an FQDN?


  • Moderator

    That article is aged, it should probably be taken down.

    Look at the fog log - normally it explicitly tells you what the issue is on one of the error lines. This log is located on the target machine you’re working with usually at C:\fog.log Feel free to copy/paste it here - use the code-wrap tool if you do.


Log in to reply
 

434
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.