problem with ./installfog (no repository)



  • Server
    • FOG Version: 1.4.0
    • OS: ubuntu server 16.04
    Client
    • Service Version: not installed yet
    • OS:
    Description

    Hello everybody,
    i’m trying to install fog on a ubuntu server at work. We are behind firewall and we use a proxy (http://xxx:3128)
    First step : install ubuntu server : no problem, apt-get update and upgrade worked without file modification

    second step : download fog
    i added to /etc/profile export_http_proxy="http://xxx:3128"
    export_https_profile="https://xxx:3128"
    wget http://link to fog didn’t work
    with wget -e use_proxy=yes _e https_proxy=xxx:3128 https://linkto fog it works.

    Third step : installfog.sh
    When i launch installfog.sh, it blocks at the end when adding needed repository
    I tried with ./install.sh -S to force https, the same issue.
    I tried php_ver=‘7.0’ php_verAdds=’-7.0’ ./installfog.sh -y (same issue)
    I tried https_proxy=https://xxx:3128 ./installfog.sh -S (same issue)
    Any help would be very appreciate :)



  • in /etc/environment, i marked
    http_proxy="http://xxx:3128"
    https_proxy="https://xxx:3128"
    ftp_proxy="ftp://xxx:3128"
    np_proxy=“localhost,127.0.0.1,@IPfog”

    and ./installfog.sh works

    thanks a lot !


  • Moderator

    I don’t use ubuntu, but on centos we setup in bashrc the following

    export http_proxy=http://<proxy_ip>:<proxy_port>
    export https_proxy=http://<proxy_ip>:<proxy_port>
    export ftp_proxy=http://<proxy_ip>:<proxy_port>
    export no_proxy=<fog_server_ip>
    

    Then log out and back in
    Allso once fog is installed there is proxy settings in the fog configuration too.

    Also please be aware of this article: https://forums.fogproject.org/topic/10006/ubuntu-is-fog-s-enemy



  • the software package is already installed (software-properties-common)

    Here the fog/bin/errors_logs
    0_1495617213246_errors_logs.PNG


  • Moderator

    You may need to install a software package first

    apt-get install software-properties-common
    

    Installer error log would be helpful too. (fog_error_1.4.0.log in your fog folder/bin/error_logs most likely)


Log in to reply
 

357
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.