UNSOLVED No Network Boot Option in BIOS

  • Server
    • FOG Version: 1.4.0
    • OS: Ubuntu 16.04 LTS
    • Service Version: 0.11.12
    • OS: Windows 10

    Linux novice here, trying to implement Fog at our institution. I believe there may be multiple issues going on, and will try to list them systematically.

    The problem is that Fog appears to be set up correctly, but when I try to capture an image, the host PC doesn’t have an option to network boot, and I don’t see any indication of Fog during startup.

    • Fog is installed successfully on Ubuntu, not as a DHCP server. We are running SonicWall Firewall, so I followed this guide for setting up Fog without a DHCP server, since I couldn’t find the equivalent 066/067 configs in SonicWall. The steps seemed to work fine.
    • I’m attempting to capture an image of a Dell Latitude 3560. I have installed the default Fog client on this Windows 10 machine. The wired network adapter is a Realtek PCIe GBE Family Controller. I understand that this may not work with “undionly.kpxe”, and may need to be switched to “ipxe.pxe”, but I don’t know for sure if that’s the problem.
    • The Dell doesn’t have an option in boot for “network adapter” or equivalent, and I confirmed that PXE is enabled in “integrated NIC” in BIOS.

    Let me know if you need any more info/logs/etc. Appreciate any help.

  • I think Quazz is right. I was trying “sudo dnsmasq” to troubleshoot. Sorry - am very new to Linux. I think this issue is resolved, though PXE is not working, but I’ll ask about that in a new thread. For anyone reading about this issue, the steps in here will help set up dnsmasq, and answered my question.

  • Moderator

    @srnairn You shouldn’t start dnsmasq by doing “sudo dnsmasq”


    sudo service dnsmasq restart

    Although that may not be sufficient if you started processes manually, you may have to kill it first.

  • Moderator

    @srnairn Interesting it should not be throwing that error.

    One last place to check is in /etc there is probably a dnsmasq.conf file you shouldn’t have anything enabled in that file except for the line that says to look in /etc/dnsmasq.d for more files.

    The very first line of the ltsp.conf file says “don’t act as a DNS server” which uses port 53 what its complaining about.

  • stew@stew-Satellite-C600:~$ ls -la /etc/dnsmasq.d
    total 24
    drwxr-xr-x   2 root root  4096 May 19 10:30 .
    drwxr-xr-x 144 root root 12288 May 19 09:39 ..
    -rw-r--r--   1 root root  1419 May 19 10:27 ltsp.conf
    -rw-r--r--   1 root root   211 Mar 27 20:22 README
    # Don't function as a DNS server:
    # Log lots of extra information about DHCP transactions.
    # Set the root directory for files available via FTP.
    # The boot filename, Server name, Server Ip Address
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    # inspect the vendor class string and match the text to set the tag
    # Set the boot file name based on the matching tag from the vendor class (above)
    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Booting FOG Client", 1
    # The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    # Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    # This option is first and will be the default if there is no input from the user.
    pxe-service=X86PC, "Boot to FOG", undionly.kpxe
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe.efi
    pxe-service=BC_EFI, "Boot to FOG UEFI PXE-BC", ipxe.efi
  • Moderator

    @srnairn please post what you have in your ltsp.conf file.

    Also post the output of this command ls -la /etc/dnsmasq.d

  • Thanks George. dnsmasq now active. However I still get the error “dnsmasq: failed to create listening socket for port 53: Address already in use” when I try “sudo dnsmasq”. I have already removed the line “dns=dnsmasq” from NetworkManager.conf. Is this a problem?

  • Moderator

    @srnairn make sure your /etc/dnsmasq.d directly is empty except for the ltsp.conf file. Then be sure to use my ltsp.conf file from the fortigate thread I posted below.

  • Thanks George. You were right about the network stack, I found that easily and enabled it. Now I have options to boot in Onboard NIC!

    I updated dnsmasq to 2.76 by following this guide. The problem I have now is that I get this error message on dnsmasq restart:

    “Job for dnsmasq.service failed because the control process exited with error code. See “systemctl status dnsmasq.service” and “journalctl -xe” for details.”

    I looked up this error message online and in the forum, but couldn’t find a resolution. I followed the advice here, and have added/removed the dns=dnsmasq multiple times, but same error. Any ideas?

    “journalctl -xe” is very long, but I can post here if needed. “systemctl status dnsmasq.service” returns:

    ~/dnsmasq-2.76$ systemctl status dnsmasq.service
    ● dnsmasq.service - dnsmasq - A lightweight DHCP and caching DNS server
       Loaded: loaded (/lib/systemd/system/dnsmasq.service; enabled; vendor preset: enabled)
      Drop-In: /run/systemd/generator/dnsmasq.service.d
               └─50-dnsmasq-$named.conf, 50-insserv.conf-$named.conf
       Active: failed (Result: exit-code) since Wed 2017-05-17 16:27:52 EDT; 15min ago
      Process: 15049 ExecStart=/etc/init.d/dnsmasq systemd-exec (code=exited, status=1/FAILURE)
      Process: 15047 ExecStartPre=/usr/sbin/dnsmasq --test (code=exited, status=0/SUCCESS)
    May 17 16:27:51 stew-Satellite-C600 systemd[1]: Starting dnsmasq - A lightweight DHCP and caching DNS server...
    May 17 16:27:51 stew-Satellite-C600 dnsmasq[15047]: dnsmasq: syntax check OK.
    May 17 16:27:52 stew-Satellite-C600 dnsmasq[15049]: dnsmasq: bad option at line 1 of /etc/dnsmasq.d/issue.pcap
    May 17 16:27:52 stew-Satellite-C600 systemd[1]: dnsmasq.service: Control process exited, code=exited status=1
    May 17 16:27:52 stew-Satellite-C600 systemd[1]: Failed to start dnsmasq - A lightweight DHCP and caching DNS server.
    May 17 16:27:52 stew-Satellite-C600 systemd[1]: dnsmasq.service: Unit entered failed state.
    May 17 16:27:52 stew-Satellite-C600 systemd[1]: dnsmasq.service: Failed with result 'exit-code'.
  • Moderator

    First of all welcome to the FOG Forums.

    Second from the linux command prompt key in the following command sudo dnsmasq -v If the returned version is less than 2.76 you will need to compile an updated version to dynamically support both bios (legacy) and uefi systems. This isn’t an issue I have a document for that. We’ll cross that bridge when we come to it.

    As for the dell, I don’t know the 3560 model specially, but the other in uefi mode you need to enable the network stack in addition to pxe booting. Most have the check box at the very top of the panel for managing the network interface. If this is not on, when you boot into the boot menu (F12) you won’t have an option to boot ipv4 or ipv6.

    You also might want to just browse through this thread since this IT Admin had a similar question that was resolved: https://forums.fogproject.org/topic/10068/pxe-boot-under-fortigate-40c