Fog 1.4.0 - Isolated Setup on Fedora 25



    • Install Fedora 25 (Use partition video below)
      https://wiki.fogproject.org/wiki/index.php?title=CentOS_7
      Install Updates
      Create and add a Network Profile for isolated setup - Name it Fog
      Manual no DHCP
      IP - 192.168.1.1
      Subnet - 255.255.255.0
      Gateway - 192.168.1.1
      Troubleshooting after install *Mostly firewall issues
      Change Firewall Settings
      Disable/stop Firewall
      systemctl disable firewalld.service
      systemctl stop firewalld.service
      Change SElinux Settings
      su -
      sudo vi /etc/selinux/config
      There’s a field saying SELinux=Enforcing
      change it to permissive
      to do this lookup using vi for editing (getting into edit mode and command mode, then save and quit)
      Save changes and quit
      reboot
      launch terminal and run getenforce, it should say permissive
      Prep up Install
      Download from Github, unpack folder
      Open Terminal
      cd to Downloads
      cd to fogproject_1.4.0
      cd to bin
      sudo ./installfog.sh
      It will check install and ask questions
      (Isolated Setup)
      Choice - 1 (Fedora)
      What type of Setup?
      Normal
      IP Address - 192.168.1.1
      Would you like to use a default network adapter?Yes
      I typed in - eno1
      Would you like to setup router address for the DHCP server - No
      Would you like DHCP to handle DNS? - No
      Would you like to use Fog server for DHCP Service - Yes
      Other languages - No
      Are you sure you wish to continue? - Yes
      Is the MySQL password blank - Yes
      It will ask to goto http://192.168.1.1/fog/management
      Unplug Ethernet cable that is giving internet from switch
      Make sure to change network profile to the 192.168.1.1
      Open browser and type in web address, hit update
      Once it finishes go back to terminal hit Enter
      It will apply final changes
      Your Set :-)

    Thanks guys again for fog
    Wayne your input worked for the selinux, still getting prompts up top but will disable the prompts on the selinux gui, had tftp issues again with the firewall disabled it and it started to work again.



  • Hi Wayne,

    Just tried it but still getting TFTP… then it times out,

    TFTP Picture

    Timeout Picture

    thanks a lot though for jumping in and helping out Wayne

    it’s ok, this thing will never touch the internet, but I might jump into the issue if I make another fog server on a vm at home


  • Moderator



  • Hi Wayne,

    Thanks for helping out man, so far I used the two commands listed but I can turn it back on again, this is on an isolated setup so it won’t touch the internet but the two commands that worked are these

    systemctl disable firewalld.service
    systemctl stop firewalld.service

    I did however find this post and followed through with the commands listed

    https://forums.fogproject.org/topic/6162/firewall-configuration

    Both commands listed on Joe Schmitt under firewalld worked but not the iptables commands, it gave an error message I can’t remember specifically what it said but I think it was like the iptables did not exist or couldn’t make changes.

    So the firewalld commands listed with success after asking for credentials several times, so that worked but maybe something on that post is what I’m missing.

    Thanks again Wayne for helping out man


  • Moderator

    What firewalld config are you using? Also, messages from SELinux in permissive mode is OK - permissive mode gives you all the messages it would if it were enabled, but it actually takes zero actions to block or stop anything - permissive mode is intended for building SELinux policies without halting production.


Log in to reply
 

465
Online

38960
Users

10706
Topics

101584
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.