Acer Laptop UEFI PXE works in general (WDS), but I tried it with FOG and it runs through code and boots from hard drive.

  • Then I did more research and someone said "If you’re into doing this stuff repetitively, look into FOG.
    It was a bit of a hassle to install - I was expecting an ISO, but a manual for my OS was available.
    Copy and paste.

    I tried it with a VM and BAM, FOG Project pops right up.
    BEAUTIFUL! I will definitely keep this…

    The only problem I’m having is with my laptop. UEFI is enabled, secure boot is off, and network boot works… I believe it sees the FOG thing, but quickly just runs through code and exits.

  • @george1421 Yeah, if I didn’t mention I already set them so I wont have to deal with it later, and yeah 8-core 8GB RAM, that is until I get a nice Mini-PC with some NVME storage later.

  • Moderator

    @JzJad If you run pfsense then you can have it supply the right boot file. There is a boot file field for legacy as well as uefi. pfsense is sweet.

  • @george1421 Yeah as for work we have it done, I run a way to beefy pfsense at home and just never bothered to set the options untill working on a laptop last week lol

  • Moderator

    @JzJad Right almost all systems being produced today are uefi. Some still allow bios mode, some are only uefi. If you have a mixed fleet (some old and some new) you need to setup Win2012+ dhcp, isc-dhcp, or dnsmasq to dynamic send the right file. This make life a bit easier than having to change dhcp option 67 every time you need to boot something different.

  • @george1421 seem’s newer laptops are just about the only thing i have ran into with this problem, across the few thousand devices I use FOG with.

  • Moderator

    There are options if you need to dynamically shift between bios (legacy) and uefi mode. If you need this you will need to explain your network design a bit more.

    But @JzJad is correct. You must use the proper boot kernel for the mode of computer you are booting.

  • Make sure to check DHCP has the right settings, I had this problem as well a week or two ago with a newer laptop having UEFI.

    Default BIOS file name
    UEFI 32 bit file name
    UEFI 64 bit file name

Log in to reply

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.