Cannot deploy HP ZBook 15 G3



  • Hi,

    when i try to deploy an image (Windows 10) to an HP ZBook 15 G3 in legacy mode i get a inaccessible boot device after windows was finishing setup (sysprepped win 10) i think this is related to the internal drives.

    The Notebook has a 256GB M2 SSD and a 1TB HDD, when both connected the HDD will be first device and the SSD the second. So i deploey with the primary disk option /dev/sdb, this is working so far but after Windows 10 has finished the setup process and trys to boot the first time it get inaccessible boot device.

    When i disconnect the hdd and deploy to ssd system will boot fine until i connect the hdd again (inaccessible boot device).

    Then i tried to deploy by UEFI (i have all my images twice, legacy and uefi) but then the system has boot problems:

    alt text

    Any idea howto deploy my image to this device?
    With the legacy deployment i tried the repair options from windows but it couldn’t fix it.

    Regards X23



  • @george1421 Windows was telling me after the second boot (inaccessible boot device) this was after the bootloader.

    Regards X23


  • Moderator

    @x23piracy Well then, this is not a fog issue, but a windows issue. Yes (at least for Dells) the m.2 or nvme disks are detected first then sata. I’m not aware of a way to change this order.

    On the target OS (or your reference image) look at the hidden boot.ini file. In there you will see where windows thinks the hard drive is located.

    I guess I have to ask the question, does windows try to boot at all or does the bios/firmware report no boot device available?

    (edit) OK, I must be remembering an OS from yesteryear. There is no boot.ini on my Win7 box. That information must be in the boot sector that is not visible.



  • @george1421 no i capture from a vm with just one drive, this notebook is a special case, in normal our notebook only have one drive. I think the main issue is that this system prefers m2 before sata.

    tom-elliott i will try the different kernels and report back.

    Regards X23


  • Moderator

    @x23piracy This is an interesting error/issue.

    Just to restate the final system will have the hard drive as /dev/sda and the ssd will be /dev/sdb. The ssd will have the OS loaded on it. I assume when you captured the image this was the disk configuration?

    For bios mode, if I remember correctly you can only “boot” off the first hard drive. I use boot in air quotes because you can install the OS on a second disk, but the boot sector must be on the first disk. The OS must be aware of this setup otherwise it will think the boot sector and the OS are on the same disk in the same position.

    With uefi mode the firmware should support booting off any installed disk because the firmware boot loader identifies the disk and partition to boot. But again the OS must be aware that its not being installed on the first disk (/dev/sda) otherwise the boot disk references in boot.ini will be incorrect.

    Understand this is only speculation based and is based on only have one small cup of coffee so far to day.


  • Senior Developer

    What boot file are you using? I’ve seen this before and the fix for me was to use ipxe.efi but maybe you could try ipxe7156.efi?



  • Hi,

    i tried to deploy again in legacy, let windows do all its stuff. Then i reconnected the 1tb hdd and tried to boot again… and wow this time it works no more (inaccessible boot device).

    But i still cannot deploy in uefi, what can i do to find out what exactly is the problem with booting the kernel?
    Can i try a different kernel?

    Regards X23


Log in to reply
 

379
Online

38981
Users

10712
Topics

101676
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.