Snapins Issue : Hash does not match



  • Server
    • FOG Version: 1.3.5 svn 6067
    • OS: CentOs 7
    Client
    • Service Version: 0.11.11
    • OS: Windows 10
    Description

    Here I come again to sollicitate your help :(

    I have a new server fog in 1.35, the only things i took from the older are the /opt/snapins/ssl files and DB for images files (I exported the .csv file)
    My hosts (around 250) are pending slowly this tuesday morning and it’s ok with the certificates
    Image creation is OK
    Image deployment not test yet but it must be ok (I’ll try during the day)
    Snapins creation done (I upload all my snapins files one by one from my local computer, some snapins are package created with SFXMaker (oracle withj response file, open_office, copy of folders in a certain location) some are installer directly downloaded from the appropriate website (like SoapUI, SVN, JDK etc…)

    I tried to install 3 package :

    • SoapUI (official installer) : hash does not match
    • Oracle (SFX maker, a .bat launch installer with response file) : hash does not match
    • Patch Orcle (SFX Maker : just unzip in c:\temp) : you know what ? hash does not match ! ;-)

    When I look in C:\Program Files (x86)\FOG\tmp, files are only 1KB

    here is my fog.log :

    02/05/2017 09:36 Client-Info Client Version: 0.11.11
     02/05/2017 09:36 Client-Info Client OS:      Windows
     02/05/2017 09:36 Client-Info Server Version: 1.3.5
     02/05/2017 09:36 Middleware::Response Success
     02/05/2017 09:36 SnapinClient Snapin Found:
     02/05/2017 09:36 SnapinClient     ID: 2
     02/05/2017 09:36 SnapinClient     Name: Patch_Oracle
     02/05/2017 09:36 SnapinClient     Created: 2017-05-02 09:33:37
     02/05/2017 09:36 SnapinClient     Action: 
     02/05/2017 09:36 SnapinClient     Pack: False
     02/05/2017 09:36 SnapinClient     Hide: False
     02/05/2017 09:36 SnapinClient     Server: 
     02/05/2017 09:36 SnapinClient     TimeOut: 0
     02/05/2017 09:36 SnapinClient     RunWith: 
     02/05/2017 09:36 SnapinClient     RunWithArgs: 
     02/05/2017 09:36 SnapinClient     Args: 
     02/05/2017 09:36 SnapinClient     File: patch_oracle10.exe
     02/05/2017 09:36 Middleware::Communication Download: http://172.27.1.1/fog/service/snapins.file.php?mac=E8:40:F2:97:80:55||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&taskid=2
     02/05/2017 09:36 SnapinClient C:\Program Files (x86)\FOG\tmp\patch_oracle10.exe
     02/05/2017 09:36 SnapinClient ERROR: Hash does not match
     02/05/2017 09:36 SnapinClient ERROR: --> Ideal: C04FFB8D9F318F8BD2D94BFCD7266BCF4883775F237EDB95BEBF006A377AF4B42BEE7BDE444280895FFC46132922356960CCA7CA68DD60E2F9326AD266854B84
     02/05/2017 09:36 SnapinClient ERROR: --> Actual: D091C0BAFADDC3F70DE58C7A17E25BBEB631FCE2153E7CCDB9C77C47FEAF93135311570964CE20D68806B16311C737DA1025421D70877DF31348348E68FC3C39
     02/05/2017 09:36 Middleware::Communication URL: http://172.27.1.1/fog/service/snapins.checkin.php?taskid=2&exitcode=-1&mac=E8:40:F2:97:80:55||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&newService&json
    

    More info : deployment in WEB GUI works fine (queued / checked In / in Progress)
    The only thing is that the download start and finish with a file size of only 1kb (which can explain the hash issue)
    I use php7.1.4 on my CentOs server
    In php.ini :

    ; Maximum amount of memory a script may consume (128MB)
    ; http://php.net/memory-limit
    memory_limit = 128M
    ; Maximum size of POST data that PHP will accept.
    ; Its value may be 0 to disable the limit. It is ignored if POST data reading
    ; is disabled through enable_post_data_reading.
    ; http://php.net/post-max-size
    post_max_size = 3000M
    ; Maximum allowed size for uploaded files.
    ; http://php.net/upload-max-filesize
    upload_max_filesize = 3000M
    

  • Senior Developer

    @Seydoo A “hash was the same no matter the snapin” leads me to think it was failing to get the file. When this would fail, it would cause the file to be nulled, so the hash being returned was that of a null value. (for all cases, which is why it was the same).



  • @Tom-Elliott
    I know that but changing the value made the snapins correctly downloaded and then, installed
    In any case I re uploaded my packages 2 or 3 times and it didn’t work, perhaps it was just a coincidence… or not :)
    What was strange is the size of my package on the computer, hash was the same no matter the snapin (sel extractor, msi, installer) ==> always 1Kb
    The only thing I didn’t try was changing php.ini, perhaps some test can be made to confirm (or infirm) my suggestion ?


  • Senior Developer

    @Seydoo 3000M means about 3 gigabytes of data is allowed to upload.

    Moving up or down should have no problems though.



  • Ok I finally found the problem
    Re uploading the file didn’t work so, I tried modifying the php.ini and change 3000M to 1900M and it finally works !

    I thought 3000M was ok with php7 (by default) and it seems Fog desn’t like it


  • Moderator

    @Seydoo re-upload the file to the snapin via the web gui, it’ll cause the hash to be regenerated.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.