Wake on LAN and POST Image scripts stop working

  • Server
    • FOG Version: 1.3.4
    • OS: Ubuntu 16.10
    • Service Version:
    • OS:

    Hi there,

    I am trying to work out an issue with my FOG installation. It has been working extremely well for the past couple of months and just over the weekend, returning to work, I noticed the postdownloadscripts were not working (not transferring the drivers across). It was working last week.

    Then I discovered that the Wake on LAN function was not working (was working last week without issue)
    This has happened before in the past when the WOL stopped working, I ended up creating a new FOG server which was the easiest solution at the time.
    These issues must be related somehow.

    Has anyone else had this issue before?
    I am not aware of any changes that have been made to the configuration. Where is the best place I should start looking and I shall provide logs/settings.

    Any assistance is greatly appreciated

  • @Tom-Elliott

    Very good, fantastic!
    Re-insalled using the existing installfog.sh - did its thing (checked packages, database scheme etc.)

    cd /root/fogproject/bin

    WOL and postdriver scripts seem to be working again!
    Thanks! I shall run this command below so it doesn’t happen again until I am prepared to get Ubuntu updates.

    apt-get -y remove unattended-upgrades

  • Senior Developer

    @Arrowtron The reason I tell people to re-run the installer is because it should fix the problem, and it doesn’t overwrite any settings. If I add a schema update that could remove a prior setting, typically it’s because it’s not going to break anything anyway. You will not lose any hosts, images, or anything.

  • @Tom-Elliott

    Thanks for your reply, yes, I have had a read around and my issue is 100% todo with Ubuntu updates. In my case your SQL root blank password code didn’t work. Do you think if I gave the SQL root password a password other then black would it fix it or won’t change? If so how should I do that?

    If I re-install will it overwrite the existing database (current settings, hosts, groups and listed images)

  • Senior Developer

    If nothing changed, from fog’s perspective (except for the seemingly forceful push of Updates Ubuntu has thrown down on systems), then re-running the installer may be the best and simplest route for you. Just thinking out loud, I have no real clue as to what’s going on. If all was working, and just stopped, I can only think something, environmentally speaking, changed. This could be network related, but most likely software related due to all the issues people have been seeing over this past week or so.

  • Thanks for the link, yes tried that,
    I followed the steps and got this result:


    Query Ok, 0 Rows affected

    Is that ok?

    I ran this command as well
    apt-get -y remove unattended-upgrades

    Restarted the FOG server and issue still remains (tested Wake on LAN function)

  • Moderator

    Did this issue change your ubuntu install? https://forums.fogproject.org/topic/10006/ubuntu-is-fog-s-enemy

Log in to reply