• Group Multicast - Dev-Branch

    Unsolved FOG Problems
    3
    0 Votes
    3 Posts
    205 Views
    Tom ElliottT

    @JJ-Fullmer @edvandro This should be fixed in dev-branch as well, but I agree with JJ here, please upgrade to working-1.6.

  • FOG 1.6.0-beta.2644 DHCP

    Unsolved FOG Problems
    10
    0 Votes
    10 Posts
    3k Views
    JJ FullmerJ

    @jmeyer Would you be willing/able to try again without bypassing it to help confirm the fix?
    @rogersk4132 thank you for testing and confirming!

  • iPXE build failing

    Unsolved FOG Problems
    7
    0 Votes
    7 Posts
    354 Views
    Tom ElliottT

    @astrugatch Okay thanks and sorry there was that issue.

    Can you pull and try installing again?

    Thank you!

  • Failed to Update Database and Host

    Unsolved FOG Problems
    22
    0 Votes
    22 Posts
    1k Views
    Tom ElliottT

    @maxcarpone I would ask you, if you’re daring/willing (it’s considered beta but uses the same pipeline with a lot more modern ui, I need people testing, and Fog_newb can likely attest the new ui look and feel though I think they ran into an issue and needed to get functional right away so the snapshotted back)

    Upgrade to working-1.6.

    I have a goal (along with @JJ-Fullmer ) to try to get working-1.6 to be master/stable branch by October.

    1.6 has been “stagnant” since around 2017 and was in relatively stable grounds back then even.

    With AI (as you undoubtly can see I’m using to help drive some things) it’s allowed us to get a lot more coding/refactoring and will hopefully present a much better experience of things on the UI side. Without testing I cannot fix UI bugs though.

    AI can do some cool things, but it doesn’t know what “wrong/right” looks like, and JJ and I are only 2 people.

    There are others on working-1.6 but more feedback is always good.

  • 0 Votes
    1 Posts
    102 Views
    No one has replied
  • Fog driver injection in 2026.

    Tutorials
    9
    0 Votes
    9 Posts
    492 Views
    P

    OK that makes sense. This got me going for driver deployment. Thank you for your help!

  • 1.5.10.2328 - Failed to check in. Going back to 2294, all good.

    Solved FOG Problems
    5
    0 Votes
    5 Posts
    357 Views
    F

    @Tom-Elliott Thanks Tom. 1.5.10.2344 seems to be capturing fine. No additional null tasks were created and the PC had no problem checking in and starting the capture.

    I’d swear, not only with this version but the earlier ones that were malfunctioning during check in and creating additional tasks, I had to create the task twice. Like I went through the process of setting up a capture but nothing showed up under tasks then had to do it again.

    I can’t seem to duplicate it though. Setting up a 2nd capture for the laptop, I only had to do it once (and no additional null tasks were created).

    PC finished the capture no problem and laptop checked in and is capturing now. Looks like 2344 did it!

    Thanks again.

  • 0 Votes
    3 Posts
    186 Views
    E

    Resolved. I’m sharing FOG with as many people as I can. Love this project!

  • Regenerate certificate on each installation.

    Unsolved FOG Problems
    2
    0 Votes
    2 Posts
    197 Views
    M

    And I can’t add any hosts—whether via the web interface or by booting over the network—; ultimately, the new host doesn’t appear in the database…

    Failed to query: Error: SQLSTATE[22007]: Invalid datetime format: 1366 Incorrect integer value: '' for column `fog`.`moduleStatusByHost`.`msHostID` at row 1 Error Message: Error Code: "22007", Error Message: ["22007",1366,"Incorrect integer value: '' for column `fog`.`moduleStatusByHost`.`msHostID` at row 1"], Debug: SQL: [629] INSERT INTO `moduleStatusByHost` (`msHostID`,`msModuleID`,`msState`) VALUES (:hostID_0,:moduleID_0,:state_0),(:hostID_1,:moduleID_1,:state_1),(:hostID_2,:moduleID_2,:state_2),(:hostID_3,:moduleID_3,:state_3),(:hostID_4,:moduleID_4,:state_4),(:hostID_5,:moduleID_5,:state_5),(:hostID_6,:moduleID_6,:state_6),(:hostID_7,:moduleID_7,:state_7),(:hostID_8,:moduleID_8,:state_8),(:hostID_9,:moduleID_9,:state_9),(:hostID_10,:moduleID_10,:state_10),(:hostID_11,:moduleID_11,:state_11),(:hostID_12,:moduleID_12,:state_12) ON DUPLICATE KEY UPDATE `msHostID`=VALUES(`msHostID`),`msModuleID`=VALUES(`msModuleID`),`msState`=VALUES(`msState`)
  • REFInd-Initializing - hangs

    FOG Problems
    43
    0 Votes
    43 Posts
    28k Views
    D

    Just fyi, I resolved my issues with this by turning off DMA protection in the bios/uefi.

  • Image copy hangs at start of copy - PXE boot OK

    Unsolved FOG Problems
    5
    0 Votes
    5 Posts
    289 Views
    T

    @Tom-Elliott I did update to version 1.6.2254 and the first multicast that worked was the first one I tried after the upgrade. This second one is now hanging like the one that prompted this thread.

    Where in the logs can I find any clues?

  • From /images/dev to /images issue

    Unsolved FOG Problems
    5
    0 Votes
    5 Posts
    423 Views
    C

    Encountered the same issue, version: 1.5.10

    I can successfully capture the image and then see the size of it in the web panel but then it’s not being moved to /images/ by fog. Requiring me to move them manually which works but I’m kinda concerned.

    FTP works fine even though I am afraid I don’t understand why I need FTP to move some files inside a directory on a singular server.

  • atheros ipxe woes "No configuration method succeeded"

    Unsolved FOG Problems
    3
    0 Votes
    3 Posts
    238 Views
    C

    @Tom-Elliott thanks Tom - using the excellent fog-docker from 88fingerslukee - so will wait to hear his response

  • How to upgrade to FOG 1.6?

    General
    10
    0 Votes
    10 Posts
    880 Views
    Tom ElliottT

    @Valer This should be fixed in latest/greatest

  • Will not PXE boot when in Windows 10

    Unsolved Windows Problems
    2
    0 Votes
    2 Posts
    216 Views
    V

    What version of FOG are you running?

  • FOG 1.6 own plugin

    General
    2
    0 Votes
    2 Posts
    321 Views
    Tom ElliottT

    @Valer I think we need to understand what this plugin is doing.

    CSS isn’t something we’ve allowed to be injectable though it could be.

    You can still use your own CSS but that’s more at the FOG Configuration -> FOG Setting -> FOG_THEME, but you would need to put it on your server in a location you type the path too here.

    https://docs.fogproject.org/en/latest/development/plugin-development

    This is a good toolkit for understanding how to build your own plugin.

  • Upgraded from FOG 1.5.9 to 1.5.10.1903 and having issues

    Unsolved FOG Problems
    28
    0 Votes
    28 Posts
    3k Views
    Tom ElliottT

    @Strahd Have you been able to make progress?

  • 0 Votes
    3 Posts
    378 Views
    L

    @Tom-Elliott Hi, Yes with the proposed fix, it works now.

  • 0 Votes
    3 Posts
    400 Views
    E

    @Tom-Elliott
    The fix worked perfectly! The menu issue is now resolved.

    Thanks for the support!

  • Storage Node says invalid configuration on FOG dashboard

    Solved FOG Problems
    5
    0 Votes
    5 Posts
    256 Views
    F

    @Tom-Elliott Hi! I updated my FOG server to latest beta-branch version: 1.6.0-beta.3197. I also updated my storage node to 1.6.0-beta.3197. This fixed the invalid path issue I was having. Thank you for the help!

    1a0e5491-b776-49fe-9fbf-d2bc40087f78-image.png