You’ve tried “EFI Exit” with rEFInd? This really doesn’t seem to be a problem with LVM or disk information, directly. It really really feels like it’s trying to boot across incompatible types. Please try network booting using EFI by enabling the Network Stack and PXE Network Stack. Then try setting the “EFI Exit” to rEFInd. This will mean you need to use one of the EFI labeled boot files, but this can typically be automated.