Problem with deployment in a physical machine / connection timeout



  • I have a problem when I want to capture an image of my physical machine. I have a DHCP Server, it turns on Windows Server 2012. I put the options 66 and 67 in my DHCP Server. I have a virtual Server FOG, the FOG’s version is 1.3.5.
    And my problem is that, when I want to capture or deploy with Wake On Lan in my physical machine. The machine starts fine in Wake On Lan. But when it arrives in the part for mounting the file system, an error comes and say “connection timeout”. I don’t know what’is the problem. See the attached image for the exact error I am getting !

    Can someone help me please !

    Thanks !

    0_1493118209090_ErrorConnectionTimeout.jpeg !



  • I have solved my problem. The first problem (connection timeout) comes of the switch, I have change for a router and it works ! The second problem, I have reinstall Windows 10 and it works, I can capture my physical machine !

    Thank you for all your help !



  • Ok, I tied another thing. I have put a router between my VMs and my physical machine. I launch a capture task. And it happens to mount the nfs system file but it don’t pass in mounting partition. So the first problem is solved. Now I have the problem with “mounting partition” when I do a capture task. So I tried to launch another task, I have launch a deploy task, andi it works fine ! So the problem now is when I try to do a capture of my physical machine



  • Ok, I tried something. I have just put a cable ethernet between my VMs and my physical machine. And it happens to mount the nfs system file. But now when it arrives in “mounting partition” it failed and say “operation not permitted”. There is a picture :
    0_1494225140350_ErrorMountingPartition.jpeg



  • @Tom-Elliott Ok, I will try something Monday, and I say something

    Thank you for your help


  • Senior Developer

    @Quazz Windows 10.

    The Virtual Host is VMWare Workstation.

    The VMWare VM is Running, now, Ubuntu 16.04 (or should be last I talked.)

    The problem is something specific to NFS based on my troubleshooting.

    To test, I actually simply disabled the nfs service and tested, Immediately the System fails to connect. Other virtual machines have no problem communicating, just physical machines seem to not be able to get through.

    We’ve turned off the firewall on the machine entirely so Windows is not blocking the connections. The network was tested with Host-only->Bridged, and NAT. Bridged is the appropriate thing to use, but while we were testing it was worth the extra effort.

    I suspect the problem is something with return to the physical machine rather than a problem with the VM, Windows OS or not. There is a switch that the devices communicate through and I’m suspecting it’s this causing our problems.

    @Andre do you have a “dummy” switch you could place between the FOG Server nic and the Main machine? You’d likely want to change the VM Nic to use NAT and make sure it’s setting the same machine to the same IP as your fog server is expecting. Essentially I’d like to remove the current switch from the scene almost altogether as I suspect the switch is preventing back communication.


  • Moderator

    @Andre What OS is the physical computer that hosts the virtual FOG server running?



  • @george1421 Ok I do the command (sudo iptables -L) and I have the same as you


  • Moderator

    @Andre said in Problem with deployment in a physical machine / connection timeout:

    For the second command (sudo ipables -L), it says command not found

    For this command you are missing a letter. Its sudo iptables -L This one is important to know because this is the firewall on the fog server.

    Your other commands are showing that nfs is up and operational on the FOG server.

    And selinux is disabled. So we’ve almost ruled out the FOG server for being at fault here.

    Looking at the IP addresses involved here, the FOG server is at IP address 192.168.230.10 and the target computer is at 192.168.230.23. So they are on the same subnet which rules out some kind of screening router between the two devices (FOG and FOS-target).


  • Moderator

    @Andre OK I’m getting lost here (sorry only one small cup of coffee so far).

    Lets get some terminology defined here so I can understand what is going on.

    We have a FOG server that is running on a vm. That shall be called the FOG or fog server.

    We have a target computer that is what we are wanting to capture and deploy from. That shall be call FOS or the target computer (I don’t care if its physical, virtual or imaginary).

    What is confusing is that we have an original fog server that I think keeps getting mixed into the conversation.


  • Senior Developer

    @Andre NO internet is not required. As long as the machine you’re talking to me with here has internet AND can communicate with the FOG Server at the same time, the physical machine does not need internet.



  • @Tom-Elliott ok, but if you want to remote, I must have access to internet in my physical machine.


  • Senior Developer

    @Andre You’re trying to image it? You would boot it like you’re doing an imaging task.

    Make the task a debug by checking the “Schedule as Debug” before confirming the tasking.



  • @Tom-Elliott I can’t run this command in my physical machine in cmd. My physical machine turns on Windows 10


  • Senior Developer

    The passwd command would be on the machine you’re trying to image from.

    If your machine that IS connected to the internet is able to communicate to your fogserver and your computer trying to be imaged, then the local network doesn’t need internet.



  • @Tom-Elliott where I run this command ?
    And my network is a local network. I don’t have access to internet.


  • Senior Developer

    @Andre From the Physical machine can you please run:

    passwd
    

    Set a simple password
    Hit me in chat
    I want to remote in and help if at all possible via AnyDesk.



  • @Tom-Elliott The IP address of my physical machine is 192.168.230.23. I can ping my server FOG and my server FOG can ping my physical machine.


  • Senior Developer

    @Andre This still sounds, very much, like a “NAT” vs. “Bridged” network problem.

    I say this BECAUSE the connection is allowed from virtual space, but not a real machine.

    Particularly your FOG Server is IP Address 192.168.230.10.

    What’s the IP address your physical machines are pickin gup.



  • @george1421 Ok, for the first command I have this :
    0_1493722352488_First_Command.PNG

    For the second command (sudo ipables -L), it says command not found

    And for the third command (sestatus). I have to install “policycoreutils” and I have do this. And the result of the command “sestatus” :
    0_1493722548495_Third_Command.PNG


Log in to reply
 

1128
Online

38981
Users

10712
Topics

101676
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.