FOG - Listen on two NICS



  • Hello, I’d like to use one FOG server on two VLANs. is that at all possible?
    Multicast should only be available on one VLAN, the other VLAN will be unicast only anyways.


  • Senior Developer

    @Fimlore Yes, only changing the “IP” to point at the relevant VLan’s. I’m sure there’s more stuff that would need to be worked out of course, but at least you can see it can be worked out. And I’m typically just a message away.



  • @Tom-Elliott oh, so basically I create two storage nodes that point towards the same device, I didn’t think about that… Will give it a try tomorrow, thanks!


  • Senior Developer

    @Fimlore This would be done in the Storage management page.



  • @Fimlore

    P.s. The original question was:
    How can I setup Fog to listen on both (or more) NICs in the server? Multicast is (for now) only needed on ETH0, the other ETH connections will mainly be unicast. If it is supported, that’s great; if not than no big deal, as long as one nic can do it.

    I tried to delete the post because I was planning to put it in general, but failed at that :)



  • Hi @Tom-Elliott ,

    Thank you for the response. Could you please explain what you mean with node? I do not believe I’ve seen that setting in the fog settings menu, but I’ve never searched for it either.

    The reason I asked is because I need of server to serve different customers; that will ease my day job and also save resources.


  • Senior Developer

    The simplest method I would suggest is to setup two nic’s and place them on their relevant vlan.

    In the FOG Configuration->FOG Settings->Multicast Settings->FOG_MULTICAST_RENDEZVOUS set the IP to match your Multicast vlan’s ip address.

    The “master” node would be the Multicast node (so things can communicate properly and establish the multicast layout.)

    You may need to create another node and make it part of the same group with the other vlan’s IP address.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.