Kernel Panic when doing quick reg



  • Server
    • FOG Version: 1.3.5
    • OS: ubuntu 14.04
    Client
    • Service Version:
    • OS:
    Description

    New install of FOG on new VM. When we boot a client computer it will load and get to the FOG menu but gives a kernel panic when trying a registration. I have read some of the other topics on this and made sure the DHCP option 66 points to my fog server’s IP address and option 67 shows undionly.kkpxe (also tried undionly.kpxe as well).

    Also, I’ve tried (and gotten the same result) on both dell optiplex 780 and dell lattitude e6410. Any help appreciated.

    -Thanks

    Server
    • FOG Version:
    • OS:
    Client
    • Service Version:
    • OS:
    Description
    Server
    • FOG Version: 1.3.5
    • OS: ubuntu 14.04
    Client
    • Service Version:
    • OS:
    Description

    New install of FOG on new VM. When we boot a client computer it will load and get to the FOG menu but gives a kernel panic when trying a registration. I have read some of the other topics on this and made sure the DHCP option 66 points to my fog server’s IP address and option 67 shows undionly.kkpxe (also tried undionly.kpxe as well).

    Also, I’ve tried (and gotten the same result) on both dell optiplex 780 and dell lattitude e6410. Any help appreciated.

    -Thanks



  • @george1421 Idiot moment. Sorry for all of the trouble but I had the 66/67 settings done in the server options and didn’t realize that the old FOG server settings were done in the scope options. That’s why is was overriding and sending pxelinux instead of undionly. Again, sorry for the trouble and thanks for your help. Issue is resolved and registration works great now.



  • @george1421 ok thanks


  • Moderator

    @cak1184

    I think where you need to next focus on why 10.101.0.2 is handing out not what you are telling it to do. I’m not seeing any rogue dhcp servers (otherwise there would be more than one offer reply to the clients discover request).

    As you can see in this packet 10.101.0.2 is giving the client this boot file name and next server of your FOG server IP.

    0_1491574224212_pxelinux_offer.png



  • @george1421 Yes, it seems there are multiple syslinux files on my ubuntu Fog server. Does this come standard on Ubuntu (as I’m new to ubuntu as well)? Screenshot below:

    0_1491574036289_upload-7ee034a4-4b45-4f8d-b7a8-8517f830bca6



  • @george1421

    1. yes 10.101.0.111 is the FOG server
    2. recycled old FOG vm that has been unused for years (so I’m told as it’s been off since I’ve been here and I’ve only been here a year). However, I installed 14.04 fresh on the vm because it wouldn’t boot. 10.101.0.111 was the IP address old FOG/imaging server though.
    3. Yes, one flat subnet with no routes.

  • Moderator

    I can see that syslinux is clearly setup on the host 10.101.0.111 This is an excellent event that should not be happening. Syslinux is not used by FOG at all.

    <edit> well I just confirmed that I am wrong. There are “bits” of syslinux setup on the fog server by default. That doesn’t explain where pxelinux.0 is being called from, but why its kind of working, but wrong. </edit>


  • Moderator

    @cak1184 said in Kernel Panic when doing quick reg:

    Not saying it’s lying,

    I’m not implying anyone is. Its just where the truth is. What you captured is what is going down the wire. Which is great, because we have a difference between configuration and what is really happening.

    Sorry I forgot to ask before

    1. Is this the fog server’s IP address? 10.101.0.111
    2. Was this fog server setup new or was the system recycled?
    3. I see your subnet mask is 255.255.0.0 so there is no route between the target and dhcp server. Is this correct?


  • @george1421 also, there was nothing in the options 66/67 before I put those setting in yesterday. What other ways can you point to a pxe server besides DHCP options as I am new to FOG/PXE and don’t know where else to look for this rogue/old/unused setting.



  • @george1421 Not saying it’s lying, just don’t know where the setting is. 10.101.0.2 is our DHCP/DNS/domain controller where the previous DHCP settings screen shot was taken.


  • Moderator

    @cak1184 “What is on the wire does not lie”.

    so can you tell me what device is 10.101.0.2



  • @george1421 Just for reference, this is what I put in my DHCP server yesterday after installing FOG. Also tried kkpxe but I don’t see any other setting that points to something else.

    0_1491572753081_upload-6696e738-a046-4beb-a764-57c9a6ffcc31



  • @george1421 We don’t currently use any other pxe boot system, however I was told they used FOG or another imaging system many years ago. Would this setup be on my DHCP server?


  • Moderator

    @cak1184 Here is what your pcap says (in simple terms)

    1. You are pxe booting a dell in bios (legacy) mode (discover)
    2. DHCP server 10.101.0.2 is responding to the client providing and IP address of 10.101.4.149 to the client and telling it that its boot server is 10.101.0.111 with a boot file of pxelinux.0 (offer)
    3. the client asks for the dhcp information (request)
    4. the dhcp server says here is the info (ack)
    5. The client then asks for pxelinux.0 from 10.101.0.111
    6. then pxelinux.0 starts searching 10.101.0.111 for its configuration files
    7. then pxelinux.0 loads its default menu (default).
    8. The menu appears to redirect the client to ipxe.krn (the wrong answer)
    9. Then the client does request a FOG file default.ipxe.

    I’ll stop here.

    It appears you have some kind of syslinux pxe boot menuing system in place. You need to identify if this is still needed and if not change the dhcp server to call the fog server IP and undionly.kpxe to pxe boot into fog directly. If you still need the menuing system then you will have to chain to the fog server.



  • @george1421 Ok, you are correct with the pxelinux.0 as that showed in the pcap file. I’ve attached both the pcap and the screenshot of the error. This pops up shortly after hitting quick registration -> bzimage ok, something else ok then this kernel error. Please advise and thanks again for your help.

    0_1491569630780_output.pcap

    0_1491569708432_20170407_075010.jpg



  • @george1421 ok, I will upload the pcap and picture first thing in the morning. Sorry, work has already closed and I’m replying from phone. Thanks for all of your help.


  • Moderator

    @george1421 Also if you could post a clear screen shot of the error screen taken with a mobile. The context of the error also helps us understand what’s going on.


  • Moderator

    @cak1184 Upload the output.pcap file here for review.

    https://forums.fogproject.org/topic/9673/when-dhcp-pxe-booting-process-goes-bad-and-you-have-no-clue

    This will let us know what files are being requested by the client and what files are being sent from the fog server.



  • @george1421 @george1421 yest hey are on the same subnet, default vlan1. How do I check the pxelinux.0 thing?


  • Moderator

    @cak1184 I’ve seen that issue in the past when pxelinux.0 is use to boot the FOS engine. Its almost 100% of the time when we see this, pxelinux.0 is involved.

    Is your FOG server and target computers on the same subnet (vlans)? We might want to confirm yes or no by collecting a pcap of the pxe booting process.


Log in to reply
 

327
Online

38724
Users

10553
Topics

99906
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.