Could not boot



  • I’m getting this error in Apache error log when booting my clients since FOG 1.4.0-RC-3

    [Thu Apr 06 11:07:02.979696 2017] [:error] [pid 7860] [client CLIENTIP:27596]
    PHP Fatal error: Uncaught Error: Call to a member function get() on boolean in /var/www/html/fog/lib/fog/bootmenu.class.php:339\nStack trace:\n#0 /var/www/html/fog/service/ipxe/boot.php(35): BootMenu->__construct(Object(Host))\n#1 {main}\n thrown in /var/www/html/fog/lib/fog/bootmenu.class.php on line 339

    And this one in the client

    http://FOGIPSERVER/fog/service/ipxe/boot.php… Input/output error (http://ipxe.org/1d0c6539)
    Could not boot: Input/output error (http:/ipxe.org/1d0c6539)
    Chainloading failed, hit’s’ for iPXE shell; reboot in 10 seconds

    If I hit ‘s’ and in the shell SANBOOT, it continues booting
    It worked well in FOG 1.3.5

    Thanks

    O.S. Debian 8.7 with php7
    FOG 1.4.0 RC3



  • @Tom-Elliott said in Could not boot:

    ing your storage node IP to

    I had the same problem starting from 1.4.0-RC-2 . Added another storage node with the fog-server ip and some fantasy user/password -> works



  • @Tom-Elliott Hi Tom, thank you for being there, you were right I had put ip address in the storage node and the hostname (the one corresponding to the given ip address) in FOG_WEB_HOST

    Great job


  • Senior Developer

    It’s because your:

    FOG Configuration Page->FOG Settings->Web Server->FOG_WEB_HOST is using a different ip/hostname than your storagenode for the same server. I’ve made an attempt to correct for this in working branch, but for now, I’d recommend setting your storage node IP to the same value as the FOG_WEB_HOST.


Log in to reply
 

394
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.