Image does not upload!



  • I’ve spent 3 days attempting to get my FOG Server rolling. I have Ubuntu 10.4 installed with FOG .32. I’ve created the same exact setup on hardware (HP Proliant 380 G5) and virtual machine (for testing). I’ve created a sysprep’ed image in both environments. My FOG server in vmware workstation works like a champ. I am able to upload and download images no problem. However…

    In the real world I have an HP dx7500 which contains the image I want to upload to the FOG server. When it hits the blue screen with the status bar it immediately fills and a screen shows saying, “Please wait…,” and the screen freezes.

    On the main fog page it says that FOG worked on version .26 but i seriously don’t want to start over! I have everything setup perfect, but this darn forsaken HP machine that will not upload has to be the problem. What are somethings I can do to figure this out?!?



  • Sorry, I got swamped then forgot. I just created this one using the 3.4.5 kernel. I haven’t tested it, so I can’t guarantee it will work. I’ll try to take a look later to make sure I didn’t miss anything. Let me know if it works at all.

    [url]http://www.filedropper.com/bzimage34_1[/url]

    astrouga



  • [quote=“astrouga, post: 4883, member: 907”]I’ve commited myself to making a 3.4.5 kernel tomorrow, so I’ll post a note when I’ve got something working.

    astrouga[/quote]
    Any luck with a 3.4.5 Kernel?

    My custom kernel did not work with the dx7500’s and I was really hoping to get FOG working in my environment. I love GNU/Linux and open source, but my boss set a timeline for me to get this functional. My time is running out. Luckily, he is out of the office today but he has mentioned that I need to move on to plan B which is a trial of the Dell Kace K2000. The community here is awesome and I’m thankful for the time you guys have taken to post to my thread. I may revisit this option in the future, but for now, alas! I was not able to win this battle. Sorry gents…


  • Moderator

    Fog cannot image ext4 fs partitions currently. So if your Ubuntu image you are trying to upload was not specifically setup to be ext3, then you won’t be able to upload/deploy.



  • Ok. I ended up answering my own question as I delved more into creating a custom kernel. I followed the guide exactly and removed all network drivers except the Intel drivers. We’ll see what happens soon.

    Some more interesting information:
    I’m able to do all the advanced deployments in task management on the dx 7500 systems.
    When I check FOG compatibility it says it is [OK]
    I’ve tried uploading an image of ubuntu and it completes in a matter of milliseconds and says that it has completed successfully, however, when i try and download the image it fails.



  • [quote=“don miyagi, post: 4900, member: 1564”]Thanks a lot for all of your help. I went ahead and installed 10.4 LTS on one of many hp dx7500 I have to see what module it uses for the network adapter. I ran the following command in terminal: lshw -C networking

    I haven’t tried creating the custom kernel at this point. I have remastersys loaded on my system. Should I do a backup of the system or should a backup of the current fog kernel be sufficient?[/quote]

    I’m not sure what you are asking here. You don’t need to worry about where you build the kernel. You don’t have to mess around with your existing fog kernel, unless you want all of your systems to use the new one. Then you could just:
    "mv bzImage bzImage.default"
    Then you could just move your new kernel over to that directory and test it out.

    –astrouga.


  • Moderator

    Lashings! and with a wet noodle too!



  • I just realized I posted in the wrong section. I hope I don’t get any lashings. Sorry everyone.



  • [quote=“astrouga, post: 4883, member: 907”]I’ve commited myself to making a 3.4.5 kernel tomorrow, so I’ll post a note when I’ve got something working.

    astrouga[/quote]

    Thanks a lot for all of your help. I went ahead and installed 10.4 LTS on one of many hp dx7500 I have to see what module it uses for the network adapter. I ran the following command in terminal: lshw -C networking

    *-network
    description: Ethernet interface
    product: 82567V-2 Gigabit Network Connection
    vendor: Intel Corporation
    physical id: 19
    bus info: pci@0000:00:19.0
    logical name: eth0
    version: 00
    serial: xx:xx:xx:xx:xx:xx
    size: 1GB/s
    capacity: 1GB/s
    width: 32 bits
    clock: 33MHz
    capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=1.0.2-k2 duplex=full firmware=1.8-5 ip=192.168.x.x latency=0 link=yes multicast=yes port=twisted pair speed=1GB/s
    resources: irq:26 memory:feac0000-feadffff memory:feafe000-feafefff ioport:d000(size=32)

    I haven’t tried creating the custom kernel at this point. I have remastersys loaded on my system. Should I do a backup of the system or should a backup of the current fog kernel be sufficient?



  • [quote=“don miyagi, post: 4878, member: 1564”]I’ve been able to upload images from two other computers and I’m 99.9% sure it has to do with the nic drivers and the kernel. Is there a way I can include certain nic drivers? Do I have to create a custom kernel? Is there such a thing as a definitive guide to that process?
    [/quote]

    I’ve commited myself to making a 3.4.5 kernel tomorrow, so I’ll post a note when I’ve got something working.

    astrouga



  • Yeah, I’m not sure about the multiple chkdsk thing either. I have been told to do it though by the developers before, so I just run it twice now.
    The BIOS setting sounds OK. I was worried about RAID. Dells seems to come with RAID turned on and I’ve had problems with that.
    The mysql password is not an issue. It is fine to create that as long as you make sure you configure fog to use the password. I actually set a password for mysql. Think of it this way, if you can see any information about hosts or images, etc in the web gui, fog knows your mysql password because it is pulling all that info from mysql tables.
    I’ll try to create a 3.4.5 kernel in the morning and post the link to this thread. Just “watch” this thread so you get a notice when it is posted.
    astrouga



  • You can build your own kernel. It is fairly simple actually until you start trying to include your own drivers. :-) The process is pretty simple:
    Download the kernel
    copy in config file from fog
    make oldconfig
    make ARCH=i386 bzImage
    copy the new bzImage to the tftpboot/fog/kernel folder and point you host to it.
    done!

    This guide should be helpful:
    [url]http://www.fogproject.org/wiki/index.php?title=Building_a_Custom_Kernel[/url]
    If you use xconfig, you can actually look to see if your particular nic drivers included or not.

    astrouga



  • [quote=“astrouga, post: 4866, member: 907”]Hmm…not familiar with that error. Also, I’m not familiar with the HP system you are working on.
    Did you run defrag and run chkdsk a few times on the drive before you tried to image it?
    Anything unusual about the disk? How is the drive configured in the BIOS?
    Also, what are those partitions like?

    You mentioned that .26 supposedly worked. Have you tried using an older kernel with host?

    astrouga[/quote]
    I’ve been able to upload images from two other computers and I’m 99.9% sure it has to do with the nic drivers and the kernel. Is there a way I can include certain nic drivers? Do I have to create a custom kernel? Is there such a thing as a definitive guide to that process?

    I was thinking I could install ubuntu on one of the hp dx7500 and take a look at the kernel headers. Any ideas?



  • The image has been defragged and has had chkdsk run on it. I was not aware that I had to run chkdsk multiple times. I have gone through the whole process in my virtual environment and have not had any problems. I’ve gone through the same exact steps in each case for preparing an image.

    The drive in BIOS is configured to use IDE and the drive was wiped with Active Killdisk and Windows was installed from disk like normal. It has the 100mb partition and then the partition for the operating system. There doesn’t seem to be anything unusual about the disk.

    I did run a much much older kernel and received a different error about the drive not being able to mount the NFS drive. I’ve went ahead and started reinstalling ubuntu 10.4 and am going to go through the initial setup to make sure everything is correct. I did create a password for mySQL without realizing that I wasn’t supposed to. I’m going to go back and do it without a password and see what happens.



  • Hmm…not familiar with that error. Also, I’m not familiar with the HP system you are working on.
    Did you run defrag and run chkdsk a few times on the drive before you tried to image it?
    Anything unusual about the disk? How is the drive configured in the BIOS?
    Also, what are those partitions like?

    You mentioned that .26 supposedly worked. Have you tried using an older kernel with host?

    astrouga



  • [quote=“astrouga, post: 4858, member: 907”]I’d stick with “Multiple Partition.”

    To try the custom kernel, you want to save the bzImage34 file to /tftpboot/fog/kernel. Make sure the perms are like the bzImage file that is there already. Now, in the fog web interface, go to:

    “Host Management” -->“List all hosts” --> click on the host you are trying to image --> find the “Host kernel” option.

    You’ll need to specify the custom kernel here. If your custom kernel is named “bzImage34”, then you’d enter:

    “/fog/kernel/bzImage34”

    in the text box and update it. Then you can try pulling an image.

    Again, let us know if you need more help.

    –astrouga[/quote]

    I let the “please wait…” screen sit there a moment and the following error appears:

    INFO: task partImage:241 blocked for more than 120 seconds
    "echo 0 > proc/sys/kernel/hun_task_timeout_secs" disables this message



  • The custom kernel did not correct the problem. The interesting thing is the text became a lot smaller, but I still have the “Please wait…” screen.



  • I had the browser cached and didn’t see your reply. I will try that and let you know! Thanks a lot!



  • This post is deleted!


  • I’d stick with “Multiple Partition.”

    To try the custom kernel, you want to save the bzImage34 file to /tftpboot/fog/kernel. Make sure the perms are like the bzImage file that is there already. Now, in the fog web interface, go to:

    “Host Management” -->“List all hosts” --> click on the host you are trying to image --> find the “Host kernel” option.

    You’ll need to specify the custom kernel here. If your custom kernel is named “bzImage34”, then you’d enter:

    “/fog/kernel/bzImage34”

    in the text box and update it. Then you can try pulling an image.

    Again, let us know if you need more help.

    –astrouga


Log in to reply
 

366
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.