[SOLVED] FOG 0.32 stops cloning at around 4%? worked fine a month ago, currupted images? or files?



  • Hi, I am a new user to fog 0.32 using ubuntu 11.10. I work as an IT Technician for a school in Derbyshire and we have implemented this as a main source for cloning. It has been brilliant up till now.

    Fog will clone like it normally does, but when it gets to around 4 - 10 % it stops and the message displays saying task completed, computer will try to restart. It does this with different images on different machines.

    What has happened? how can I fix it? I have tried looking for the mac address file on the linux server because alot of people say delete that and it should fix it, unfortunatly it hasn’t.

    I have got the stage if someone can help me fix fog BRILLIANT! or I will format start again / use WDS for deployment.

    I have restored my backup images on the fog server just in case they was currupted and this has not fixed it.

    The problem started with me having to restore my backup images to get it to work.

    ANYONE HELP?? PLEASE :-)

    Lee


  • Moderator

    Please start a new thread and post details about your issue. Reference this thread if you think it contains pertinent info.



  • I missed this thread somehow when searching for issues but I’m running into the same problem. I have FOG 0.32 installed on Ubuntu 12.04.



  • Hi,

    Just want to thank you for all your help, it seems to be working fine now.

    I did all the things you suggested to do but what I did find is that in Fog service / config.php the mysql server username and password wasnt set. It was set for common / config.php but not the other.

    Might not have made a difference but its all working now until it fails again.

    Did try another NIC and made no difference, also did all the updates.

    Anyway im happy it works

    thanks

    Lee



  • Thanks for the quick response. Networking equipment seems fine and nothing has changed since it was working fine.

    I have just tried a new patch lead and plugged it into a new socket on the wall.

    I need to get a pci network card to test if it could be the onboard card. What is wierd is that it will upload and image fine so why should deploying an image be a problem.

    I have checked the services tftpd-hpa is running and it is, it is set to startup. It is version 12.04 but that service seems fine.

    I am just doing 347 updates as it has not done any updating since ive installed the new linux os.

    I will post when I have tried another NIC and done these updates. I will upload a new image again and test with a deploy.

    Thanks

    Lee


  • Moderator

    Check your networking equipment if you can. Try a different patch cable from the fog server to the switch. Try a different NIC in the fog server next.

    For Fog to just stop working is quite unusual. Something may be getting changed in the background due to automatic security updates if you have that enabled. Also, if you are using Ubuntu 12.04, watch out for the tftpd-hpa service not starting after a reboot.



  • Ok I have looked at the log after just trying to clone, here are the last few lines that show whats happening


    Jul 26 08:18:37 scarecrow in.tftpd[15812]: tftp: client does not accept options
    Jul 26 08:19:01 scarecrow rpc.mountd[13455]: authenticated mount request from 10.4.5.2:821 for /images (/images)
    Jul 26 08:28:46 scarecrow in.tftpd[15897]: tftp: client does not accept options
    Jul 26 08:39:01 scarecrow CRON[16030]: (root) CMD ( [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -depth -mindepth 1 -maxdepth 1 -type f -cmin +$(/usr/lib/php5/maxlifetime) ! -execdir fuser -s {} 2>/dev/null ; -delete)
    Jul 26 08:40:55 scarecrow in.tftpd[16055]: tftp: client does not accept options
    Jul 26 08:41:20 scarecrow rpc.mountd[13455]: authenticated mount request from 10.4.5.2:821 for /images (/images)
    Jul 26 08:57:04 scarecrow in.tftpd[17528]: tftp: client does not accept options
    Jul 26 08:57:28 scarecrow rpc.mountd[13455]: authenticated mount request from 10.4.5.2:821 for /images (/images)

    if you can understand that or somehow help me fix it I would apprieciate it Chad-bisd

    thanks

    Lee



  • thanks for your reply

    I am unicasting to 1 pc to test it so far.

    I have put new drives in the fog server.

    I have installed Ubuntu again from fresh with version 12.04 and I have installed Fog again from fresh with version 0.32

    I have been running fine for a week with this setup and now it has gone back to crashing on cloning.

    It sometimes makes 20% sometimes makes 4% then bombs out.

    I am checking the log but have noticed that there are 2 logs, one is syslog and one is syslog.1.

    Syslog.1 seems to be an older log from yesterday and syslog holds my current log from this morning.

    I am going to clean the log and try and clone so I have a fresh log to view.

    I really need help with this, I love fog but it doesnt love me

    thanks

    Lee


  • Moderator

    Are you unicasting or multicasting? Have you checked your /var/log/syslog for errors relating to fog?

    When you say your started over with new everything, do you mean new client or new server?



  • Hi,

    thanks for your response, im getting to the point I want to go to WDS.

    I have tried cloning other machines and had this problem so I’m hoping the kernel will sort this. I’ve just tried using virtual pc and it bombed out

    thanks

    Lee


  • Moderator



  • Im still having problems with fog, it clones around 5% sometimes 75% then bombs out

    Im getting to the point im going to stop using FOG

    HELP



  • Got a real problem now, the backup images wont even restore back

    HELP



  • Hi,

    Now im really confused! started with a new hard drive, new installation, new everything and yet for some reason its stopped working at 17% now on a 760 image. Im going to restore my image back and see if it works but its not looking good after a complete fresh install? whats happening?

    Lee



  • Thanks alot for your help, I notice there is alot of people you help on here and I apprieciate you taking the time out to speak with me and other members

    I am going to try the command [FONT=Courier New]reboot=a,b,k,c with the kernel as this will force reboot on acpi,bios,kbd,cold[/FONT]

    [FONT=Courier New]thanks[/FONT]

    [FONT=Courier New]Lee[/FONT]


  • Moderator

    Some computers, especially those made by companies that customized their own motherboards and BIOS, don’t always follow the specifications. Usually Dell have this problem. There is an option you can used called “reboot=bios” that goes in the kernel options.

    Here is some more info on the option to the Linux kernel. [url]http://linux.koolsolutions.com/2009/08/04/howto-fix-linux-hangfreeze-during-reboots-and-restarts/[/url]

    Test it on one host and if it works, you can apply the option to all hosts that need it using a Fog group.



  • Just a quick message, ive had this problem the whole time with using fog

    It clones fine but on certain machines it doesn’t reboot when it says something like 251 - restarting system

    It just stays on that message like its froze and won’t restart until you hard power it off and on pressing the power button

    Once you have hard powered it off and on, it will boot up and join the the domain no problems

    ANY IDEA’S ANYONE??

    thanks

    Lee



  • Hi,

    I have got it all up and running again, im using Fog 0.32 and Linux 12.04

    Its all working fine now anyway, thanks for your help, it was obviously a currupted hard drive

    What is this tftpd-hpa? I don’t understand what it is doing lol, all I know is it clones and joins fine

    thanks

    Lee


  • Moderator

    If you use 12.04, you will need to modify tftpd-hpa to wait on the LAN interfaces before it starts. There is a script modification thread around here somewhere that shows you where to tell tftpd-hpa to sleep for a few seconds.



  • Hi,

    thanks for your reply

    Yes what you have put is correct.

    Restoring the images worked temporarily, but now when I restore the images back to fix it, it doesn’t work.

    I am currently re-installing Ubuntu and going for version 12.04. My only thinking is the hard drive has currupted and it needs a fresh install.

    Any Advice or guidance would be much apprieciated.

    Lee


Log in to reply
 

365
Online

38982
Users

10712
Topics

101679
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.