Systemctl enable won't work on tftp & dnsmasq



  • Server
    • FOG Version: 1.3.4 SVN revision 6066
    • OS: CentOS Linux release 7.3.1611 (Core)
    Client
    • Service Version: N/A
    • OS: N/A
    Description

    I restarted fog today to discover a hidden problem. tftp & dnsmasq didn’t turn on by default. After running

    systemctl enable tftp
    systemctl enable dnsmasq
    

    both command said that they create the syslink.

    TFTP: /etc/systemd/system/sockets.target.wants/tftp.socket to /usr/lib/systemd/system/tftp.socket.
    dnsmasq: /etc/systemd/system/multi-user.target.wants/dnsmasq.service to /usr/lib/systemd/system/dnsmasq.service.

    Rebooted the system, and after checking the status they were still off.

    I ran

    systemctl is-enabled tftp
    systemctl is-enabled dnsmasq
    

    both return a value of “indirect” After some googling I found that it means,

    “The unit file itself is not enabled, but it has a non-empty Also= setting in the “[Install]” unit file section, listing other unit files that might be enabled”

    so I tried disable to clear it. The syslink was removed but when I checked, it still returned “indirect”

    Right now I just have a script running

    systemctl start tftp
    systemctl start dnsmasq
    

    on bootup, but I hate technical debt and unsolved mysteries. Anyone either, A know why, or B how to fix it, cleanly? preferably both but I’ll settle for B alone.

    Thanks in advance for any help anyone can provide.


  • Senior Developer

    @Artur I may be wrong, but I believe these use the rpcbind system. Is this set to enabled?

    Typically, on redhat, there are services that are indirectly running. Meaning when a request comes in the service “hears” it and hands out whatever is needed. So a systemctl -l status tftp dnsmasq will likely be a more accurate thing to be displayed here. I’m going to guess that the ‘inderect’ portion is just a means to tell rpcbind to open the ‘listeners’.

    Was there a problem doing or anything or just something you noticed?


Log in to reply
 

990
Online

39009
Users

10724
Topics

101882
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.