Snapins do not deploy to VMs



  • Server
    • FOG Version: 1.3.5 RC-3
    • OS: Debian 8.6
    Client
    • Service Version: 0.11.9
    • OS: Windows 10
    Description

    I’m getting fat images ready and where I have snap ins from when I was doing thin images and the FOG client does not recognize that it has snapins it needs to install. This is a Windows 10 VM in VMware Workstation 10. It deploys fine to physical machines-tested.

    Not sure where to start on this one. FOGClient isn’t complaining, but apache is throwing this:

    [Thu Feb 09 14:19:13.624067 2017] [:error] [pid 1361] [client 10.4.69.52:63706] PHP Strict Standards: Only variables should be passed by reference in /var/www/fog/lib/pages/taskmanagementpage.class.php on line 224, referer: http://10.4.200.150/fog/management/index.php
    

    Thanks guys


  • Senior Developer

    @Wayne-Workman Yes, it was confirmed.

    I realized the problem, but was on a meeting call. I asked him to test the “fix” and he confirmed with me on chat.


  • Moderator

    @Tom-Elliott Oh. So confirmed fixed? It wasn’t clear to me.


  • Senior Developer

    @Wayne-Workman He’s telling you that’s what he did.


  • Moderator

    @THEMCV Not solved until you can confirm it’s solved. Come back after you’ve tried the fix and let us know.



  • @Wayne-Workman @Tom-Elliott got a fix going. It’s in working-1.3.5, so I think we can mark this solved. :)


  • Moderator

    @Tom-Elliott I’m all out of ideas for this. We’ve moved him to the latest RC, we’ve checked for apache errors, and I’ve walked him through doing it the way I know to work. He can deploy single snapins but when he does “All Snapins” they don’t appear in task management -> active snapins at all. What do you think?



  • @Wayne-Workman Updated, still Deploy All is still not in the Active Snapin Tasks


  • Moderator

    @THEMCV I just realized you’re on 1.3.5 rc3 - I should have thought of this sooner. Move to the latest 1.3.5 RC please, I think Tom is up to 5 now.



  • @Wayne-Workman Nothing really in the logs except for where I tried to view the apache logs from FOG and now /var/logs/apache/

    
    [Fri Feb 10 09:49:05.169555 2017] [:error] [pid 20645] [client 10.4.69.52:53031] PHP Warning:  fopen(/var/log/apache2/error.log): failed to open stream: Permission denied in /var/www/fog/status/logtoview.php on line 86, referer: http://10.4.200.150/fog/management/index.php?node=about&sub=logviewer
    
    

    That’s it though. :/


  • Moderator

    @THEMCV ok. Immediately after doing “All Snapins” like normal, check the apache error logs. Web Interface -> FOG Configuration -> Log Viewer -> Apache Error Log, sort the list from newest to oldest, and post what you find into a code box. The log entries are timestamped (your server’s time is correct, right?). The relevant logs should be easy to find.



  • @Wayne-Workman No, it did not make it appear in the active tasks.

    Single does, however.


  • Moderator

    @THEMCV said in Snapins do not deploy to VMs:

    And yep, each host is assigned the snapins it is supposed to have.

    Ok next, we deploy all snapins via the below method on one of these hosts:
    Web Interface -> Host Management -> [search for host, click host name] -> Basic Tasks -> Advanced -> All Snapins -> Schedule Instant selected -> Create all snapin tasks
    After doing this, go to:
    Web Interface -> Task Management -> Active Snapin Tasks and Active Tasks
    What do you see? Did the snapins associated to that host appear in the Active Snapin Tasks list?



  • @Wayne-Workman Ran it.

    And yep, each host is assigned the snapins it is supposed to have. I always set them when I register PCs.


  • Moderator

    @THEMCV said in Snapins do not deploy to VMs:

    Want me to still ruin those commands?

    It wouldn’t hurt anything, could only help.

    So next thing, check that there are snapins associated to the machines you’ve tried to deploy all snapins to. So go to that individual host in the web interface, on the left click “Snapins”. Anything there?



  • @Wayne-Workman Well narrowing it now a bit. Running “Deploy All Snpains” does not work for me. I tested “Deploy all snap-ins” on my machine which didn’t work, but if I deploy a single snapin, it goes fine. VM too.

    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     2/10/2017 9:09 AM Client-Info Client Version: 0.11.9
     2/10/2017 9:09 AM Client-Info Client OS:      Windows
     2/10/2017 9:09 AM Client-Info Server Version: 1.3.5-RC-3
     2/10/2017 9:09 AM Middleware::Response Success
     2/10/2017 9:09 AM SnapinClient Snapin Found:
     2/10/2017 9:09 AM SnapinClient     ID: 1354
     2/10/2017 9:09 AM SnapinClient     Name: AutoHotKey
     2/10/2017 9:09 AM SnapinClient     Created: 2017-02-10 14:09:46
     2/10/2017 9:09 AM SnapinClient     Action: 
     2/10/2017 9:09 AM SnapinClient     Pack: False
     2/10/2017 9:09 AM SnapinClient     Hide: False
     2/10/2017 9:09 AM SnapinClient     Server: 
     2/10/2017 9:09 AM SnapinClient     TimeOut: 0
     2/10/2017 9:09 AM SnapinClient     RunWith: 
     2/10/2017 9:09 AM SnapinClient     RunWithArgs: 
     2/10/2017 9:09 AM SnapinClient     Args: /S
     2/10/2017 9:09 AM SnapinClient     File: AutoHotkey_1.1.24.03_setup.exe
     2/10/2017 9:09 AM Middleware::Communication Download: http://10.4.200.150/fog/service/snapins.file.php?mac=00:0C:29:16:F1:A6||00:00:00:00:00:00:00:E0&taskid=1354
     2/10/2017 9:09 AM SnapinClient C:\Program Files (x86)\FOG\tmp\AutoHotkey_1.1.24.03_setup.exe
     2/10/2017 9:09 AM Bus {
      "self": true,
      "channel": "Notification",
      "data": "{\r\n  \"title\": \"Installing AutoHotKey\",\r\n  \"message\": \"Please do not shutdown until this is completed\"\r\n}"
    }
     2/10/2017 9:09 AM Bus Emmiting message on channel: Notification
     2/10/2017 9:09 AM SnapinClient Starting snapin...
     2/10/2017 9:09 AM SnapinClient Snapin finished
     2/10/2017 9:09 AM SnapinClient Return Code: 0
     2/10/2017 9:09 AM Bus {
      "self": true,
      "channel": "Notification",
      "data": "{\r\n  \"title\": \"AutoHotKey installed\",\r\n  \"message\": \"Installation has finished and is now ready for use\"\r\n}"
    }
     2/10/2017 9:09 AM Bus Emmiting message on channel: Notification
     2/10/2017 9:09 AM Middleware::Communication URL: http://10.4.200.150/fog/service/snapins.checkin.php?taskid=1354&exitcode=0&mac=00:0C:29:16:F1:A6||00:00:00:00:00:00:00:E0&newService&json
    

    So the issue lies in the “Deploy All” it would seem.

    Want me to still ruin those commands?


  • Moderator

    @THEMCV Alright let me explain my thoughts on this. You’re saying you deployed all snapins to this VM guest. Yet when we look at the log, the log isn’t throwing any errors, it’s communicating properly with the FOG Server - and it doesn’t see any snapins. That doesn’t make sense.

    Knowing that the FOG Client is very soundly built, I’m thinking there has to be a server problem. There just has to be - otherwise we’d be seeing errors in the fog client’s log file. Or you’re just somehow deploying to the completely wrong host in the web interface.

    I would suggest running these cleanup commands (bottom of page) in your server - it might help: https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_MySQL#Hosts_think_they_are_not_registered_.2F_can.27t_register_.2F_Already_Registered_.2F_other_registration_weirdness

    Let us know if those queries affect any rows or not, then try to deploy all snapins again.



  • @Wayne-Workman All confirmed.

    2_1486734352121_hostname3.png 1_1486734352120_hostname2.png 0_1486734352120_hostname1.png


  • Moderator

    @THEMCV said in Snapins do not deploy to VMs:

    2/10/2017 8:19 AM HostnameChanger Users still logged in and enforce is disabled, delaying any further actions

    See if the hostname is actually correct, compare what the computer properties in windows says to what the FOG Web Interface says for this computer’s MAC address.



  • @Tom-Elliott Okay, that makes sense. Wanted to include all information. :)

    @Wayne-Workman Here’s my log after sending “All Snapins” to the host.

    2/10/2017 8:17 AM Service Sleeping for 92 seconds
     2/10/2017 8:19 AM Middleware::Communication URL: http://10.4.200.150/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     2/10/2017 8:19 AM Middleware::Response Success
     2/10/2017 8:19 AM Middleware::Communication Download: http://10.4.200.150/fog/management/other/fog_client_banner.png
     2/10/2017 8:19 AM Middleware::Communication URL: http://10.4.200.150/fog/management/index.php?sub=requestClientInfo&mac=00:0C:29:16:F1:A6||00:00:00:00:00:00:00:E0&newService&json
     2/10/2017 8:19 AM Middleware::Response Success
     2/10/2017 8:19 AM Middleware::Communication URL: http://10.4.200.150/fog/service/getversion.php?clientver&newService&json
     2/10/2017 8:19 AM Middleware::Communication URL: http://10.4.200.150/fog/service/getversion.php?newService&json
    
     2/10/2017 8:19 AM Service Creating user agent cache
     2/10/2017 8:19 AM Middleware::Response Invalid time
     2/10/2017 8:19 AM Middleware::Response No Printers
     2/10/2017 8:19 AM Middleware::Response Module is disabled globally on the FOG server
    
    ------------------------------------------------------------------------------
    ---------------------------------ClientUpdater--------------------------------
    ------------------------------------------------------------------------------
     2/10/2017 8:19 AM Client-Info Client Version: 0.11.9
     2/10/2017 8:19 AM Client-Info Client OS:      Windows
     2/10/2017 8:19 AM Client-Info Server Version: 1.3.5-RC-3
     2/10/2017 8:19 AM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     2/10/2017 8:19 AM Client-Info Client Version: 0.11.9
     2/10/2017 8:19 AM Client-Info Client OS:      Windows
     2/10/2017 8:19 AM Client-Info Server Version: 1.3.5-RC-3
     2/10/2017 8:19 AM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     2/10/2017 8:19 AM Client-Info Client Version: 0.11.9
     2/10/2017 8:19 AM Client-Info Client OS:      Windows
     2/10/2017 8:19 AM Client-Info Server Version: 1.3.5-RC-3
     2/10/2017 8:19 AM Middleware::Response Success
     2/10/2017 8:19 AM HostnameChanger Users still logged in and enforce is disabled, delaying any further actions
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     2/10/2017 8:19 AM Client-Info Client Version: 0.11.9
     2/10/2017 8:19 AM Client-Info Client OS:      Windows
     2/10/2017 8:19 AM Client-Info Server Version: 1.3.5-RC-3
     2/10/2017 8:19 AM Middleware::Response No snapins
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     2/10/2017 8:19 AM Client-Info Client Version: 0.11.9
     2/10/2017 8:19 AM Client-Info Client OS:      Windows
     2/10/2017 8:19 AM Client-Info Server Version: 1.3.5-RC-3
     2/10/2017 8:19 AM Middleware::Response No Printers
     2/10/2017 8:19 AM PrinterManager Getting installed printers
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------PowerManagement-------------------------------
    ------------------------------------------------------------------------------
     2/10/2017 8:19 AM Client-Info Client Version: 0.11.9
     2/10/2017 8:19 AM Client-Info Client OS:      Windows
     2/10/2017 8:19 AM Client-Info Server Version: 1.3.5-RC-3
     2/10/2017 8:19 AM Middleware::Response Success
     2/10/2017 8:19 AM PowerManagement Calculating tasks to unschedule
     2/10/2017 8:19 AM PowerManagement Calculating tasks to schedule
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     2/10/2017 8:19 AM Client-Info Client Version: 0.11.9
     2/10/2017 8:19 AM Client-Info Client OS:      Windows
     2/10/2017 8:19 AM Client-Info Server Version: 1.3.5-RC-3
     2/10/2017 8:19 AM Middleware::Response Success
    ------------------------------------------------------------------------------
    
     2/10/2017 8:19 AM Service Sleeping for 98 seconds
    
    

    Note that in the web UI it never checks in, it just stays queued.


Log in to reply
 

469
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.