PartClone fail on deploy - error code 1

  • Server
    • FOG Version: 1.3.4
    • OS: Ubuntu Server 14.04
    • Service Version:
    • OS: Windows 7

    I created a new image for one of our desktops (HP 6305). The image looked like it captured ok but when I tested the deployment, PartClone threw error code 1. I looked in /var/logs/ but dont see the partclone.log file.
    Here is a video of the error:

  • @Tom-Elliott Hi Tom. I had the same problem when I wanted to deploy my last image (Dell OptiPlex 330/Windows 7 created with the last version of FOG: 1.3.4)
    It works fine now thanks to the 1 value in the d1.fixed_size_partitions. Thank you :)

  • @Tom-Elliott Ok thanks

  • Senior Developer

    @coop90 no. I don’t know why it happens and I do currently have “test” case code to try to prevent this, but it’s typically a limited issue thing. If anybody wants to dive into the code and take a look, they’re more the welcome. I can’t find it myself unfortunately, and I’ve been trying.

    I can tell you it was introduced when I removed the forced use of the first partition being fixed.

  • @Tom-Elliott That worked. Thanks!

    Anything I should be doing differently in the future when I create/capture images to avoid this problem?

  • Senior Developer

    @coop90 The : is the separate, the number is the number of the partition to maintain as fixed.

    I didn’t know what was in the file, and most I’ve seen come across the file is blank.
    Can you make the file read in whole as:

  • @Tom-Elliott I got the same error but I am not sure I added the 1 correctly. The file was “:3” and I made it “:31” Is that correct?

  • @coop90 Strange as 14 seconds in that is the error. I’ve seen this before. When I examined the two drives, one was a few blocks smaller. Admittedly the two drive were not the same make, to might not be the same issue. I bet if you shrink the original computers partition and re-upload it works.

  • Senior Developer

    Please edit the d1.fixed_size_partitions file and add:
    1 to the list.

  • @kibade The hardware is identical on both machines. It is the same model 500gb seagate drive.

  • The error is saying the target computer has a smaller HDD than the computer the imaged came from. Can you check and see if the image is from a computer with a larger HDD.

Log in to reply

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.