Edited undionly.kpxe now receive params: command not found



  • Server
    • FOG Version: 1.3.0
    • OS: CentOS 7
    Description

    I need to host a Fog and SCCM server on the same network subnet. To achieve this I went through the steps to add a PXE Boot Menu allowing a PXE chain to the FOG server. I used https://rom-o-matic.eu/ to edit the undionly.kpxe to set the fog server address using this script:

    #!ipxe

    set fogserver x.x.x.x

    isset ${net0/mac} && dhcp net0 || goto dhcpnet1
    echo Received DHCP answer on interface net0 && goto netboot

    :dhcpnet1
    isset ${net1/mac} && dhcp net1 || goto dhcperror
    echo Received DHCP answer on interface net1 && goto netboot

    :dhcperror
    prompt --key s --timeout 10000 DHCP Failed, hit ‘s’ for the iPXE shell; reboot in 10 seconds && shell || reboot

    :netboot
    cpuid --ext 29 && set arch x86_64 || set arch i386
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param platform ${platform}
    param product ${product}
    param ipxever ${version}
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme

    :bootme
    chain http://${fogserver}/fog/service/ipxe/boot.php##params

    The script was kindly provided for me by @george1421
    After a few smaller errors (Read: user error) I was able to boot a client into the FOG server only to receive the error: params: command not found.

    I checked to ensure that #define PARAM_CMD /* Form parameter commands */ was defined in git/fogproject/src/ipxe/src/config/general.h as shown by this post, and it is. Rebooted server to make sure none of my changed required that. Still receiving the error Command not Found. I’m not sure what the next step might be…


  • Senior Developer

    @george1421 While I know some of SCCM, I can say, I think this method is probably much more accurate than trying to do it in reverse. SCCM, as I understand it, is meant to be used on request. Meaning, when you need to image a device, you tell the device to network boot. From there, it will get its information from the SCCM server and perform the boot to perform the tasking requested.

    In our modified scenario, we’re enabling systems to be on network boot mode consistently. All we’re doing is adding a new menu option that allows the user at the system to choose to boot up to disk or if they need to, they can select the SCCM menu option to perform the task sequences as needed.

    Hopefully this fits the bill with the requirements, and it allows the users to have a dual type of system for setting up imaging. Essentially you can maintain your ‘light touch’ model if that’s how you’re using SCCM and have a golden base on the FOG Server. (That’s my thoughts, your mileage may vary.)


  • Moderator

    @george1421 Working through chat and with Tom’s help we’ve come up with this chain command that should work from the FOG iPXE menu: chain tftp://<SCCM_Server_IP>/SMSBoot\x64\pxeboot.0

    So the idea we came up with is to create a menu entry in fog to call the sccm pxe boot instead of doing it from the sccm end to call fog boot.

    Once the OP has the pxe booting into FOG setup, he can use FOG to either default or fall through the FOG iPXE menu and chain to the sccm pxe boot by setting the sccm chain menu as default or just use fog as normal and leave the menu entry to select sccm boot if that is required.

    The key to getting this setup to work was getting the proper path on SCCM to the pxeboot.0 file.

    The OP is going to continue to test this setup, but the preliminary test was successful.


  • Moderator

    @jlober1981 Switching over to chat, please check the chat bubble at the top of this window.



  • @george1421 Yes I can. Here is the code that I use to boot from SCCM

    DEFAULT menu.c32
    MENU TITLE SCCM PXE Server

    LABEL wds
    MENU DEFAULT
    MENU LABEL SCCM
    KERNEL pxeboot.0

    LABEL linuxpxe
    MENU LABEL FOG Image Capture
    KERNEL pxechain.com
    APPEND 10.0.1.203::undionly.kpxe

    LABEL abort
    MENU LABEL Exit PXE
    Kernel abortpxe.0


  • Moderator

    @jlober1981 When you boot into your syslinux menu with pxelinux.0 you can go to sccm from there? I’m suspecting that sccm is probably using dhcpProxy to send information to the target computer, but I have no evidence of that.



  • I successfully booted into the FOG server both by the natively installed undionly.kpxe as well as the version @george1421 had me download. But in order to do so I had to turn off PXE on the SCCM server. If it is easier to create a menu item to point to the sccm server from FOG I am open to this idea as well. I am booting from a Dell Latitude E5470.


  • Moderator

    @jlober1981 First lets take a step back here.

    I want you to do this first.
    Change your dhcp server options 66 to point to the IP address of your fog server and the dhcp option 67

    Please ensure you can pxe boot to the fog server.

    Second please tell me the mfg and model of the computer you are trying to pxe boot.



  • @george1421 said in Edited undionly.kpxe now receive params: command not found:

    @jlober1981 No I don’t feel that its a fog server issue just yet (You could test by changing /temp/ your dhcp option 66 and 67 to the fog server IP and undionly.kpxe and see if you can boot).

    Please tell me a bit more about what you are trying to pxe boot, that system is hanging with the ipxe kernel.

    Bear with me as I am quite new to FOG, but I am trying to setup FOG to be able to capture images of new and used Dell Laptops. The ONLY configurations that I have changed on the FOG server is the undionly.kpxe file based on suggestions shown here. If you need more detailed information please specify and I can gladly provide whatever you are looking for to help get this running. Thanks!


  • Moderator

    @jlober1981 No I don’t feel that its a fog server issue just yet (You could test by changing /temp/ your dhcp option 66 and 67 to the fog server IP and undionly.kpxe and see if you can boot).

    Please tell me a bit more about what you are trying to pxe boot, that system is hanging with the ipxe kernel. I did not test the kernel I posted below, but the only thing I changed was the IP address of your fog server and then recompiled it.


  • Senior Developer

    TO me, this message appears to be coming from the item that’s booting, not a problem with the ipxe file in use. Maybe we can see what it is that’s booting after the ipxe file get’s loaded?



  • Yes I downloaded your file and received the same error message. Is it perhaps a misconfiguration on my FOG server?


  • Moderator

    @jlober1981 With what I created?



  • @george1421 said in Edited undionly.kpxe now receive params: command not found:

    @jlober1981 Ok the test worked correctly in our test lab.

    Some of the settings have changed on the rom-o-matic since that first tutorial was written. Its mostly the same but a few extra options have been added.

    Please test this file: 0_1483986244383_gundionly.kpxe and let me know how it works, be aware that I changed the name to gundionly.kpxe to not conflict with the official undionly.kpxe file.

    When I tested, I just dropped that file on our test syslinux pxe boot server and then changed the dhcp option 67 to load that file instead of pxelinux.0. It worked right out of the box and loaded the fog pxe menu. I do have to admit I did not try anything past there, but if you can get into the ipxe fog menu that was more than you had before.

    If it works correctly in your environment I’ll post the instructions on how to recreate it.

    Thanks! But I am receiving the same error as shown in the picture.


  • Moderator

    @jlober1981 Ok the test worked correctly in our test lab.

    Some of the settings have changed on the rom-o-matic since that first tutorial was written. Its mostly the same but a few extra options have been added.

    Please test this file: 0_1483986244383_gundionly.kpxe and let me know how it works, be aware that I changed the name to gundionly.kpxe to not conflict with the official undionly.kpxe file.

    When I tested, I just dropped that file on our test syslinux pxe boot server and then changed the dhcp option 67 to load that file instead of pxelinux.0. It worked right out of the box and loaded the fog pxe menu. I do have to admit I did not try anything past there, but if you can get into the ipxe fog menu that was more than you had before.

    If it works correctly in your environment I’ll post the instructions on how to recreate it.



  • @george1421 said in Edited undionly.kpxe now receive params: command not found:

    @jlober1981 Just to confirm that 10.0.1.203 is the IP address of your fog server?

    I’m back in the office today after traveling last week, so I should be able to create a mock up of this over the lunch hour today. Let me see if I can make it work like I think it should in the test lab.

    Yes 10.0.1.203 is the correct address of the FOG server


  • Moderator

    @jlober1981 Just to confirm that 10.0.1.203 is the IP address of your fog server?

    I’m back in the office today after traveling last week, so I should be able to create a mock up of this over the lunch hour today. Let me see if I can make it work like I think it should in the test lab.



  • 0_1483979725249_FOG Error.JPG


  • Developer

    @jlober1981 said:

    … Once FOG runs it gives me a Installation Failed notice and no other errors, error codes, or options …

    Can you please take a picture of that error and post it here. To me it seems like we are talking about different issues here.



  • I followed: https://forums.fogproject.org/topic/6400/usb-boot-uefi-client-into-fog-menu-harder-way to the letter, changing only step 3 (output format) to PXE bootstrap Loader keep (.kpxe) and step 4 (NIC type) to undionly. This leads to a large ipxe.kpxe (338KB) download from https://rom-o-matic.eu which I rename to undionly.kpxe and then upload to my tftpboot folder. Once FOG runs it gives me a Installation Failed notice and no other errors, error codes, or options. I’m really unsure what I’m doing wrong. I need to get this to work on the current infrastructure as changing the network scheme is not an option.


Log in to reply
 

427
Online

38953
Users

10704
Topics

101564
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.