Failed to start tasking type Capture. Could not find any nodes containing this image



  • Server
    • FOG Version: 1.3.0-RC-34
    • OS: Centos 7
    Description

    I’ve done through the instructions to install Fog on Centos 7, and created a new VM with 50gb, as I’m planning to use my NAS for storage. I’m trying to add a new storage node (QNAP Appliance) to a new group to capture/deploy images. I’ve gone through many forum topics on how to add a NAS, and I have ftp/nfs setup properly, afaik (I can connect to each successfully from cli using the same user/pass as the fog server). I’ve created a new Storage Group named ‘NAS’, but cannot see it from the dashboard under ‘Storage Group Activity’. Should the nas be in its own group? I believe it does since I don’t want it to replicate images with the vm. Ignoring this minor issue, I’ve gone ahead and created a new image, set the Primary Storage Group to ‘NAS’, and added it to a host I’ve registered, but when I try to setup a capture task, I get ‘Failed to start tasking type Capture. Could not find any nodes containing this image’.



  • @Tom-Elliott working good now, thanks!



  • @Tom-Elliott alright, i’ll test RC 36 tomorrow when I’m back at work. And thank you for all the hard work!


  • Senior Developer

    @mdit Found and fixed and repubbed in RC 36 to hopefully better address this for you.



  • Just for the fun of it, I’ve tried the same steps on 1.20, and everything is working as expected.



  • @Tom-Elliott the latest release has fixed this issue. But now I cannot capture an image, I’m getting “Could not find a storage node in this group. Is there one enabled?” I might as well create another topic for this issue since this one is solved.



  • alright, will give it a go and report back


  • Senior Developer

    Just thinking to myself, I found out that this problem would have likely persisted in the case of deploy images (after I updated the capture issue to work as expected).

    I’ve pushed up RC-35 in hopes that this will address the “NAS” issue itself.

    As stated earlier, this node will not appear within the Dashboard page due to the NAS likely not having the files the GUI is looking for. So the dashboard client count will not be reporting the max clients available to the group. This means imaging should work fine and maintain it’s own count, you just won’t get an accurate count within the dashboard.

    This also means you will not see the “Disk Usage” for this node or the bandwidth usage for this node.


  • Senior Developer

    Please repull and install.

    This was due to how I’m trying to get nodes. NAS’ on the other hand do not have the “checking” capabilities as a normal Node would (typically a node is installed with the same installer).

    I’ve added code to try to circumvent this and believe this should help you out.


Log in to reply
 

380
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.