Weird series of solutions to Checking queue hangup



  • I just went through a good day of work and trouble-shooting trying to image & deploy Dell Optiplex 390’s. The end might be relevant for other computers exhibiting the same behavior. I’ll try to be brief and not tell a long-winded story.

    SETUP: Brand new FOG 0.32 server on Ubuntu 12.04. Since my plan was to move all our computers to FOG setup, I used one of the 390’s as the FOG server. Another I just put on Lubuntu (no Windows rants); that was just used as a workstation to get to webUI. Also, I commandeered the computer lab for the project, which has 20 network jacks going to switch in the server room. I successfully made an image.

    ISSUE: I then tried to deploy to the 18 machines hooked up. Only 2 actually deployed. All others would WOL and get into PXELinux. But after boot message of “IP-Config reopening network devices”, it would display:
    [INDENT=1]Checking Operating System…Windows 7[/INDENT]
    [INDENT=1]Checking CPU Cores…2[/INDENT]
    [INDENT=1]Send method…NFS[/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1]Checking Queue…Done[/INDENT]
    [INDENT=1](0 sec)[/INDENT]
    [INDENT=1](5 sec)[/INDENT]
    [INDENT=1]…[/INDENT]
    [INDENT=1][[every 5 secs for ever]][/INDENT]
    And never start loading the image.

    SOLUTION 1: As per another thread, I removed BIOS password, reset the BIOS to defaults and then moved just the NIC boot to the top. I tried on 3 machines and it worked on 1 of them.

    SOLUTION 2: I next updated the BIOS on 1 of the two machines to latest revision (A07 at this point in time). It worked on the first, so I did BIOS reset & update on all machines. Only 1 other machine actually worked (not in original 3).

    SOLUTION 3: See below for the logic, but I brought in a brand new 8-port 1GB switch and brand new CAT5e cables. All machines and FOG server hooked up to it and its connected through the walls to the server room (sorta irrelevant, but see below). Each set of 6 are deploying fine

    DETAILS: For the first two, its straightforward. For the last one, it seems that I’ve inherited some shoddy cabling. Very strange to my slightly ignorant understanding of network cabling, but none of the CAT 5 patch cables worked; and a few CAT 5e cables did not as well. There are also some ports in the lab that I can get intranet/internet access through, but not deploy a FOG image. I actually tracked this down while the other setup had 6 deploying. And with swapping known working cabling around I know what to throw away and/or rewire.

    Anyways, very strange to me … but at least now I’ve got 6 workstation setup that works for me. I hope all this helps someone else too…


Log in to reply
 

500
Online

38916
Users

10685
Topics

101347
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.