In Deploy, Hangs at Checking Queue



  • When attempting to deploy to a machine, the process gets up to 'Checking Queue … [Done]" and then:

    • (0 sec)
    • (5 sec)
    • (10 sec)
    • (15 sec)
      etc…

    I recently rebuilt this FOG server so I know that it is something I buggered-up but I can’t find any information or logs to help me debug the problem. I went through this:
    [url]http://fogproject.org/forum/threads/wiki-troubleshooting-an-image-deploy.20/[/url]
    hoping to get some insight but the images I have are in multiple files and these instructions don’t seem to take that into account.

    Any guidance would be great! : )



  • Seems I found the culprit. I use an SSL cert for the web interface and use mod-rewrite to redirect all traffic to https://

    This apparently is not something FOG’s web service can handle so I modified my rule set as follows:

        RewriteEngine   on
        RewriteCond     %{SERVER_PORT} ^80$
        RewriteCond     %{REQUEST_URI} !^/fog/service [NC]
        RewriteRule     ^(.*)$ [url]https://%{SERVER_NAME}$1[/url] [L,R]
        RewriteLog      "/var/log/apache2/rewrite.log"
        RewriteLogLevel 2
    

    For anyone else that wants to run their FOG web interface with SSL, I hope this helps. I’ll post anything else related to this if it comes up.



  • Well, I tried to reboot all my network hardware, but no luck. : ( Alas, needed to start from scratch. Everything is fine now.

    All is well that ends well, I suppose. : )

    Thanks for working with me rdegennaro!



  • After updating the BIOS a few started to accept the images, so it probably needed to be done for me anyways. What was very strange though, was that I moved the ones working out of the way, and brought the ones not working closer to the FOG server and workstation I was going through the webui with… Then some of the ones not working WOL’ed and started to image.

    So, I brought in a 1GB switch into the room and hooked up all the computers with new cables, including the FOG server. Restarted all the computers to image. Everyone worked fine in groups of 6 once hooked up to the local switch. Nothing going through the walls to the switch in closet and back.

    With confidence of having a setup for the 40 machines to image, I went back and tested the other ports and old cables. It seems that we’ve got bad wires in the walls and some bad patch cables in the lab. What’s strange (to my ignorant view) is that all the CAT5 and a few CAT5e patch cables did not like FOG imaging. A few in the walls too, I wonder if those are CAT 5; we’ve got some old/odd cabling done before my time.

    Anyways, good luck. I hope something works out for you…



  • I don’t think that is it, unfortunately. The machines I’m working with have always imaged fine and I’m testing with two different models. It does this waiting thing when I attempt to inventory a machine as well : (



  • I’m getting the same thing with just some Dell Optiplex 390’s. All the HP DC5750’s, HP 505B’s, Acer Veriton X270’s work fine. Only 2 of 18 390’s work. The BIOS’s all look the same.

    Another thread mentioned problems with the PXE boot on the 390’s. And a different thread with same info on an ASUS laptop said that resetting the BIOS to defaults worked.

    I’m going to see if either make a difference.


Log in to reply
 

436
Online

38938
Users

10697
Topics

101491
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.