Hosts Sharing USB NIC



  • So I am trying to image a few Dell XPS 13 (9350) but only have a single USB-C to Ethernet adapter. I registered the first host and was able to capture an image and test it, but now that I have plugged in the adapter into another PC. It says Host not registered. So I deleted the host from the web interface and went through the registration process again. It says everything is good and I can see the host in the web interface but when I PXE boot the host, it says it isnt registered.

    I have deleted the host from the web interface a few times and have had no luck with registering it through PXE. I have updated the server OS (Ubuntu 12.04.05 LTS) I am still running FOG 1.2.0.
    Any ideas or advice?



  • @Wayne-Workman Sorry, I will do that in the future. I was able to capture my image after fixing the GPT remnants.

    Thank you for all your help!



  • I know you’re new to fog so you’re going to have a ton of questions. We are happy to help but us going so far off topic here benefits nobody but you. We use forums so others can search threads and help themselves instead of asking questions. Please for each “new” issue, make a new thread.

    When the capture process hangs on “Saving original partitions” this means that you have a system that shipped from the factory as UEFI, and you’ve changed it to BIOS and reformatted it, but because windows installation does a crappy job of cleaning up the disk, there are GPT remnants left over, and you need to run ‘fixparts’ in debug mode. Search the forums for fixparts and you’ll find numerous writeups on how to do it. That’ll fix you up. You could also search for the exact last lines displayed and find the same things.

    Also there is this:
    https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_Capturing



  • @Wayne-Workman OK, so I ran the 1.3 install again after the FOGMulticastManager Service Failed message and it completed successfully.

    BUT, when I got to capture my image, I get to “Saving original partition table…” and stops there. No error or anything.



  • @it101 Give me 5 minutes to test the latest on Ubuntu 16 here. I’m home today and have lots of time on my hands.



  • @Wayne-Workman I just tried installing 1.3 on Ubuntu 16 Server and during the install, it fails at

    Starting FOGMulticastManager Service ................. Failed!
    

    Is this anything to be alarmed at? Proceed as normal?

    The only reason I am using Ubuntu is because I am somewhat familiar with it (not saying much) should I try Debian?



  • @it101 said in Hosts Sharing USB NIC:

    Also, I think some might be taking the “Upgrade to Trunk” at face value thinking it is JUST an upgrade and not a full install.

    I’ll clarify this at the very top of the article, then.

    when I went to capture my first image, it couldnt mount the file system and fails immediately

    Exactly where does this happen? Please post a photo of the error, and if you can please also post a photo what the screen is showing just before the error as well. This will let us know exactly where the issue is.



  • @Wayne-Workman I tried installing 1.3 on Ubuntu 16 one time without installing 1.2 first and it didnt ask me about changing the SQL password but did ask if the password was blank. I said yes and it installed without a hitch. But when I went to capture my first image, it couldnt mount the file system and fails immediately

    Also, I think some might be taking the “Upgrade to Trunk” at face value thinking it is JUST an upgrade and not a full install.



  • @it101 You don’t need to touch 1.2.0 at all, you can go straight to 1.3 using the “Upgrade to Trunk” article, or the “Ubuntu 16.04 Server” article in the wiki. Or, if you just know the commands, you don’t need any instructions. But no you don’t need to mess with 1.2.0 at all. People keep asking that here in the forums and I don’t know why. Is there anything indicating that 1.2.0 is needed? Please point out why you feel that way and I’ll do what I can to change it.



  • @Wayne-Workman Can I just install FOG 1.3 on Ubuntu 16 or do I need to install 1.2 first then upgrade to 1.3?



  • @it101 Fixed.



  • @Wayne-Workman I was looking at This

    @Tom-Elliott I am using GIT


  • Senior Developer

    @it101 What version of FOG are you installing? (SVN, GIT, tarball?)



  • @it101 16 doesn’t have issues anymore (Tom fixed them). What wiki article were you looking at?



  • @Tom-Elliott I ran those commands too and the update fails at the same spot of installing php-gettext, I tried manually installing php-gettext and get the same error as above.

    @Wayne-Workman The only reason I said 14.4 LTS is because the wiki says 16 has issues. But with your blessing, I will use 16 LTS.



  • @it101 said in Hosts Sharing USB NIC:

    I think I’m just going to backup my images and install a fresh 14.4 LTS and FOG 1.3

    I would urge you to use Ubuntu 16.04 - it is Canonical’s current long-term-support version of Ubuntu and FOG 1.3.0 installs and runs perfectly fine on it.


  • Senior Developer

    @it101 The instructions you followed weren’t followed properly, from what I can see.

    You should’ve ran:

    rm -rf /etc/{apache,php}*
    rm -rf /etc/apt-get/sources.d/ondrej
    apt-get purge apache2* php5* php7*
    apt-get autoremove --purge
    

    Notice you must add apache to the list.

    Also, the RC-25 should properly handle this installation and changes required properly.



  • This is what I get.

    sudo apt-get install php-gettext
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    php-gettext is already the newest version.
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
     libapache2-mod-php5 : Depends: apache2-mpm-prefork (> 2.0.52) but it is not going to be installed or
                                    apache2-mpm-itk but it is not going to be installed
                           Depends: apache2.2-common but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    

    I think I’m just going to backup my images and install a fresh 14.4 LTS and FOG 1.3



  • This post is deleted!


  • Also, what’s the error when you try it manually?
    sudo apt-get install php-gettext


 

427
Online

41.8k
Users

12.3k
Topics

116.0k
Posts