FOG server CPU usage spikes to 100% from /user/sbin/apache2 -k start



  • Server
    • FOG Version: 1.3.0 RC-20
    • OS: Debian 8 jessie
    Description

    FOG server CPU usage spikes to 100% from apache2. First I thought this was from WOL, but then I disabled that, canceled the image, and tested it again. The CPU spikes to 100% seemingly right before it goes into PXE boot and during until it hits the FOG splash screen.

    No images are being deployed out and nothing is communicating with the FOG server besides the initial PXE boot.

    [Tue Nov 08 15:10:08.857937 2016] [:error] [pid 23934] [client 10.4.200.150:36655] PHP Fatal error:  Uncaught exception 'Exception' with message 'Invalid MAC Address!' in /var/www/fog/lib/fog/wakeonlan.class.php:54\nStack trace:\n#0 /var/www/fog/lib/fog/fogpage.class.php(3150): WakeOnLan->send()\n#1 /var/www/fog/lib/fog/fogpagemanager.class.php(252): FOGPage->wakeEmUp()\n#2 /var/www/fog/management/index.php(49): FOGPageManager->render()\n#3 {main}\n  thrown in /var/www/fog/lib/fog/wakeonlan.class.php on line 54
    

    I’ve got about 2000 of these sitting in my apache2 log. The image deploys fine and it doesn’t give me an error PC side, but it doesn’t seem right that it’s spiking to 100% on an i5 CPU w/8GB RAM.

    Thanks guys


  • Senior Developer

    I made some more, I think, significant approaches to URL testing tonight that should help limit CPU intensity.

    21 had some better methods as well, but it was far from perfect. I doubt it’s perfect now too, but it certainly seems a lot better from what I could see.



  • @Tom-Elliott Okay, looks like it’s good now. :)

    Still a couple of the same errors in the error.log, but only 3 or 4 now on each PXE boot and the CPU only hit’s 25%ish instead of 100% now.

    Thanks Tom



  • @Tom-Elliott Sure, will do.


  • Senior Developer

    Mind updating to RC 21?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.