NFS times out trying to upload image



  • Am seriously going bald with all the hair pulling on this one.
    I have installed fog on 4 different flavours of ubuntu and every time I try and upload an image the connection times out at connecting to NFS share, on the client.
    Something is blocking the connection to the fog server, but for the life of me I cannot find it.
    I can connect to the NFS share on the fog machine.
    Can someone please shed some light on this, or suggest where to look next.



  • [quote=“bardicverse, post: 4378, member: 1314”]dumb question - can you ping the fog server’s ip address from one of your client machines?[/quote]
    Yep. No problem there. Can ping by ip address and hostname.
    No question is a dumb question. I might have overlooked something small.



  • dumb question - can you ping the fog server’s ip address from one of your client machines?



  • [quote=“bardicverse, post: 4362, member: 1314”]I found a similar problem, but my solution was too vague, because I made several changes. Of those, I did the following:
    -Switched from Ubuntu 12 to 10.04
    -On my DHCP server, set port 66 to my IP address, not the server name
    -modified Ubuntu with a proxydhcp

    One or more of those things worked for me, on a windows client.[/quote]
    Thanks for the response.
    I also switched to Ubuntu 10.04. Tried both server and desktop.
    Also set DHCP option 66 to my IP address.
    Have DHCP running on server 2008R2. If I change the destination to the windows WDS server then the clients connect no problem.
    So am pretty sure it is not a network problem. Seems to be something on the Ubuntu box that is blocking the NFS connections.
    I set up another machine with ubuntu and it can also not connect to the NFS share on the fog server. If I execute (on the client) showmount -a fogserverIP then it shows me that /images and /images/dev are exported.

    Anyone have any further ideas what to look at?



  • I found a similar problem, but my solution was too vague, because I made several changes. Of those, I did the following:
    -Switched from Ubuntu 12 to 10.04
    -On my DHCP server, set port 66 to my IP address, not the server name
    -modified Ubuntu with a proxydhcp

    One or more of those things worked for me, on a windows client.


Log in to reply
 

353
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.