ipxe/boot.php hanging on capture



  • Did a svn up to rev 5955. After I recovered from realizing it had deleted my images with no backup…I am back at it trying to upload a image, but getting stuck at fog/service/ipxe/boot.php on the loading screen.

    Any help would be greatly appreciated.



  • Problem seems to be resolved.
    I deleted the storage node that was showing up in apache error log. Not sure why FOG reverted to a storage node that was not listed as master, but it did.
    After deleting, I have uploaded an image.
    Words of wisdom from an idiot…When SVN up-ing, Make sure that you don’t delete your images, evidently there is a setting to delete images and I missed it. It is a bad thing to delete them. Worse than that…I did not have a backup of the images.
    Happy Fogging.

    @Wayne-Workman @Quazz Thanks for your support you guys are great to have around.



  • @Quazz it was there listed as one of my old storage nodes, but not the master. I deleted it. Will try to capture and see what happens.


  • Moderator

    @ftgjason Check storage node settings!



  • @Wayne-Workman @Quazz Ok…combing through some of the logs…I find a host, which I assume is the FOG server itself, and it has the wrong ip address.
    It should be 192.168.0.49 not the 192.168.20.49.
    Am I on the right track?

    [Wed Sep 21 09:03:13.096909 2016] [:error] [pid 1099] [client 192.168.0.64:33342] PHP Fatal error: Uncaught exception 'Exception' with message 'Type: 8, File: /var/www/html/fog/lib/fog/fogbase.class.php, Line: 791, Message: Undefined index: value, Host: 192.168.20.49, Username: fog' in /var/www/html/fog/lib/fog/fogftp.class.php:74\nStack trace:\n#0 /var/www/html/fog/lib/fog/storagenode.class.php(113): FOGFTP->connect()\n#1 /var/www/html/fog/lib/fog/fogcontroller.class.php(831): StorageNode->loadImages()\n#2 /var/www/html/fog/lib/fog/fogcontroller.class.php(212): FOGController->loadItem('images')\n#3 /var/www/html/fog/lib/fog/storagenode.class.php(45): FOGController->get('images')\n#4 /var/www/html/fog/lib/fog/storagegroup.class.php(73): StorageNode->get('images')\n#5 [internal function]: StorageGroup->{closure}(Object(StorageNode), 1)\n#6 /var/www/html/fog/lib/fog/storagegroup.class.php(87): array_walk(Array, Object(Closure))\n#7 /var/www/html/fog/lib/fog/bootmenu.class.php(1381): StorageGroup->getOptimalStorageNode('8')\n#8 /var/www/html/fog/lib/fog/bootmenu.class.php(424): BootMenu->getTasking()\n#9 [internal funct in /var/www/html/fog/lib/fog/fogftp.class.php on line 74


  • Moderator

    @ftgjason Never mind that, I was kind of distracted and didn’t notice this was happening on capture not on the boot menu.

    Check out the link Wayne posted.



  • @Quazz @Wayne-Workman I have changed a thing or two that looks like what you are talking about, but nothing has changed on the capture end of things. Still not 100% certain on where the change needed to be made.


  • Moderator

    @ftgjason Configure Boot Menu or something like it. Then go over each option, it has a drop down menu for when you can see the items.



  • @Quazz I guess I am missing that setting, can you give me more info on what the actual heading is for the setting in Fog Settings. Thanks


  • Moderator


  • Moderator

    @ftgjason Given that it only happens on registered hosts, go into FOG Settings and disable menu items only available to registered hosts and see if that helps.


  • Moderator

    @ftgjason Well that would definitely cause an input output error. Here’s what my home fog server gives me for a registered MAC address.

    #!ipxe
    set fog-ip 10.0.0.4
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    goto get_console
    :console_set
    colour --rgb 0x00567a 1 ||
    colour --rgb 0x00567a 2 ||
    colour --rgb 0x00567a 4 ||
    cpair --foreground 7 --background 2 2 ||
    goto MENU
    :alt_console
    cpair --background 0 1 ||
    cpair --background 1 2 ||
    goto MENU
    :get_console
    console --picture http://10.0.0.4/fog/service/ipxe/bg.png --left 100 --right 80 && goto console_set || goto alt_console
    :MENU
    menu
    colour --rgb 0x00567a 0 ||
    cpair --foreground 1 1 ||
    cpair --foreground 0 3 ||
    cpair --foreground 4 4 ||
    item --gap Host is registered as LIVINGROOM!
    item --gap -- -------------------------------------
    item fog.local Boot from hard disk
    item fog.memtest Run Memtest86+
    item fog.keyreg Update Product Key
    item fog.deployimage Deploy Image
    item fog.multijoin Join Multicast Session
    item fog.quickdel Quick Host Deletion
    item fog.sysinfo Client System Information (Compatibility)
    choose --default fog.local --timeout 3000 target && goto ${target}
    :fog.local
    sanboot --no-describe --drive 0x80 || goto MENU
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=10.0.0.4/fog/ consoleblank=0 rootfstype=ext4 loglevel=4
    imgfetch init_32.xz
    boot || goto MENU
    :fog.memtest
    kernel memdisk iso raw
    initrd memtest.bin
    boot || goto MENU
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=10.0.0.4/fog/ consoleblank=0 rootfstype=ext4 loglevel=4
    imgfetch init_32.xz
    boot || goto MENU
    :fog.keyreg
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param keyreg 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fog.deployimage
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param qihost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fog.multijoin
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param sessionJoin 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fog.quickdel
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param delhost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fog.sysinfo
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=10.0.0.4/fog/ consoleblank=0 rootfstype=ext4 loglevel=4 mode=sysinfo
    imgfetch init_32.xz
    boot || goto MENU
    :bootme
    chain -ar http://10.0.0.4/fog/service/ipxe/boot.php##params ||
    goto MENU
    autoboot
    

    And here’s what I get for a non-registered MAC address:

    #!ipxe
    set fog-ip 10.0.0.4
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    goto get_console
    :console_set
    colour --rgb 0x00567a 1 ||
    colour --rgb 0x00567a 2 ||
    colour --rgb 0x00567a 4 ||
    cpair --foreground 7 --background 2 2 ||
    goto MENU
    :alt_console
    cpair --background 0 1 ||
    cpair --background 1 2 ||
    goto MENU
    :get_console
    console --picture http://10.0.0.4/fog/service/ipxe/bg.png --left 100 --right 80 && goto console_set || goto alt_console
    :MENU
    menu
    colour --rgb 0xff0000 0 ||
    cpair --foreground 1 1 ||
    cpair --foreground 0 3 ||
    cpair --foreground 4 4 ||
    item --gap Host is NOT registered!
    item --gap -- -------------------------------------
    item fog.local Boot from hard disk
    item fog.memtest Run Memtest86+
    item fog.reginput Perform Full Host Registration and Inventory
    item fog.reg Quick Registration and Inventory
    item fog.deployimage Deploy Image
    item fog.multijoin Join Multicast Session
    item fog.sysinfo Client System Information (Compatibility)
    choose --default fog.local --timeout 3000 target && goto ${target}
    :fog.local
    sanboot --no-describe --drive 0x80 || goto MENU
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=10.0.0.4/fog/ consoleblank=0 rootfstype=ext4 loglevel=4
    imgfetch init_32.xz
    boot || goto MENU
    :fog.memtest
    kernel memdisk iso raw
    initrd memtest.bin
    boot || goto MENU
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=10.0.0.4/fog/ consoleblank=0 rootfstype=ext4 loglevel=4
    imgfetch init_32.xz
    boot || goto MENU
    :fog.reginput
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=10.0.0.4/fog/ consoleblank=0 rootfstype=ext4 loglevel=4 mode=manreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.reg
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=10.0.0.4/fog/ consoleblank=0 rootfstype=ext4 loglevel=4 mode=autoreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.deployimage
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param qihost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fog.multijoin
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param sessionJoin 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fog.sysinfo
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=10.0.0.4/fog/ consoleblank=0 rootfstype=ext4 loglevel=4 mode=sysinfo
    imgfetch init_32.xz
    boot || goto MENU
    :bootme
    chain -ar http://10.0.0.4/fog/service/ipxe/boot.php##params ||
    goto MENU
    autoboot
    

    This is using svn version 5956.



  • @Wayne-Workman Here’s what I get after pasting in web-browser

    #!ipxe
    set fog-ip 192.168.0.49
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}


  • Moderator

    @ftgjason

    http://192.168.0.49/fog/service/ipxe/boot.php?mac=78:45:c4:24:82:d8

    Let us know what it shows, too. Just copy/paste, use the forum’s code snippit tool.



  • @Wayne-Workman
    FOG - 192.168.0.49
    Mac of Client
    78:45:c4:24:82:d8


  • Senior Developer

    @Wayne-Workman It will look at ftp if a requested node is unable to find localized images. It will try finding images by way of ftp if it cannot set them internally first. This process usually works fine but if ftp is bad then this might happen.


  • Moderator

    @ftgjason said in ipxe/boot.php hanging on capture:

    @Tom-Elliott here is the latest couple of entries…

    [Mon Sep 19 15:46:48.827081 2016] [:error] [pid 2156] [client 192.168.0.66:8904]                                                                              PHP Fatal error:  Uncaught exception 'Exception' with message 'Type: 8, File: /                                                                             var/www/html/fog/lib/fog/fogbase.class.php, Line: 791, Message: Undefined index:                                                                              value, Host: 192.168.20.49, Username: fog' in /var/www/html/fog/lib/fog/fogftp.                                                                             class.php:74\nStack trace:\n#0 /var/www/html/fog/lib/fog/storagenode.class.php(1                                                                             13): FOGFTP->connect()\n#1 /var/www/html/fog/lib/fog/fogcontroller.class.php(831                                                                             ): StorageNode->loadImages()\n#2 /var/www/html/fog/lib/fog/fogcontroller.class.p                                                                             hp(212): FOGController->loadItem('images')\n#3 /var/www/html/fog/lib/fog/storage                                                                             node.class.php(45): FOGController->get('images')\n#4 /var/www/html/fog/lib/fog/s                                                                             toragegroup.class.php(73): StorageNode->get('images')\n#5 [internal function]: S                                                                             torageGroup->{closure}(Object(StorageNode), 1)\n#6 /var/www/html/fog/lib/fog/sto                                                                             ragegroup.class.php(87): array_walk(Array, Object(Closure))\n#7 /var/www/html/fo                                                                             g/lib/fog/bootmenu.class.php(1381): StorageGroup->getOptimalStorageNode('8')\n#8                                                                              /var/www/html/fog/lib/fog/bootmenu.class.php(424): BootMenu->getTasking()\n#9 [                                                                             internal funct in /var/www/html/fog/lib/fog/fogftp.class.php on line 74
    [Tue Sep 20 09:06:32.035780 2016] [:error] [pid 2113] [client 192.168.0.64:3636]                                                                              PHP Fatal error:  Uncaught exception 'Exception' with message 'Type: 8, File: /                                                                             var/www/html/fog/lib/fog/fogbase.class.php, Line: 791, Message: Undefined index:                                                                              value, Host: 192.168.20.49, Username: fog' in /var/www/html/fog/lib/fog/fogftp.                                                                             class.php:74\nStack trace:\n#0 /var/www/html/fog/lib/fog/storagenode.class.php(1                                                                             13): FOGFTP->connect()\n#1 /var/www/html/fog/lib/fog/fogcontroller.class.php(831                                                                             ): StorageNode->loadImages()\n#2 /var/www/html/fog/lib/fog/fogcontroller.class.p                                                                             hp(212): FOGController->loadItem('images')\n#3 /var/www/html/fog/lib/fog/storage                                                                             node.class.php(45): FOGController->get('images')\n#4 /var/www/html/fog/lib/fog/s                                                                             toragegroup.class.php(73): StorageNode->get('images')\n#5 [internal function]: S                                                                             torageGroup->{closure}(Object(StorageNode), 1)\n#6 /var/www/html/fog/lib/fog/sto                                                                             ragegroup.class.php(87): array_walk(Array, Object(Closure))\n#7 /var/www/html/fo                                                                             g/lib/fog/bootmenu.class.php(1381): StorageGroup->getOptimalStorageNode('8')\n#8                                                                              /var/www/html/fog/lib/fog/bootmenu.class.php(424): BootMenu->getTasking()\n#9 [                                                                             internal funct in /var/www/html/fog/lib/fog/fogftp.class.php on line 74
    [Tue Sep 20 09:26:50.788079 2016] [:error] [pid 2152] [client 192.168.0.64:43304                                                                             ] PHP Fatal error:  Uncaught exception 'Exception' with message 'Type: 8, File:                                                                              /var/www/html/fog/lib/fog/fogbase.class.php, Line: 791, Message: Undefined index                                                                             : value, Host: 192.168.20.49, Username: fog' in /var/www/html/fog/lib/fog/fogftp                                                                             .class.php:74\nStack trace:\n#0 /var/www/html/fog/lib/fog/storagenode.class.php(                                                                             113): FOGFTP->connect()\n#1 /var/www/html/fog/lib/fog/fogcontroller.class.php(83                                                                             1): StorageNode->loadImages()\n#2 /var/www/html/fog/lib/fog/fogcontroller.class.                                                                             php(212): FOGController->loadItem('images')\n#3 /var/www/html/fog/lib/fog/storag                                                                             enode.class.php(45): FOGController->get('images')\n#4 /var/www/html/fog/lib/fog/                                                                             storagegroup.class.php(73): StorageNode->get('images')\n#5 [internal function]:                                                                              StorageGroup->{closure}(Object(StorageNode), 1)\n#6 /var/www/html/fog/lib/fog/st                                                                             oragegroup.class.php(87): array_walk(Array, Object(Closure))\n#7 /var/www/html/f                                                                             og/lib/fog/bootmenu.class.php(1381): StorageGroup->getOptimalStorageNode('8')\n#                                                                             8 /var/www/html/fog/lib/fog/bootmenu.class.php(424): BootMenu->getTasking()\n#9                                                                              [internal funct in /var/www/html/fog/lib/fog/fogftp.class.php on line 74
    [root@localhost ~]#
    

    Mod edited to use code box.

    I’m thinking more about these errors and the screenshot you posted - what in the world does FTP have to do with getting boot parameters from boot.php @Developers ? Makes no sense to me.

    The screenshot says input/output error. I guess we can check what it’s talking about. If you give me your FOG server’s IP address, and the MAC address of the computer you’re working with, I can give you a URL to look at.


  • Moderator

    @ftgjason Yep, which is why I asked you to check. that IPv6 address won’t be there anymore when you’ve successfully disabled IPv6.



  • @Wayne-Workman
    looks like it is still there…huh?

     [root@localhost ~]# ip addr show
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host
           valid_lft forever preferred_lft forever
    2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
        link/ether 18:03:73:df:0d:93 brd ff:ff:ff:ff:ff:ff
        inet 192.168.0.49/23 brd 192.168.1.255 scope global eno1
           valid_lft forever preferred_lft forever
        inet6 fe80::1a03:73ff:fedf:d93/64 scope link
           valid_lft forever preferred_lft forever
    [root@localhost ~]#
    

    Mod edited to use code box.


  • Moderator

    @ftgjason run ip addr show again and post the output please.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.