Unable to move /images/dev/macaddress to /images/name-of-image



  • Hi all

    long time user of fog (since 0.26) and its really come on in leaps and bounds particularly with the new interface.

    We’re close to rolling out new hardware (Lenovo Thinkpad Edge 71) running core i5, 4GB RAM and Windows 7 Pro 64bit. So far so ordinary…

    Got the reference machine delivered yesterday and all the apps have been installed and build basically prepped. I went to take a pre-sysprep image and got the error in the subject line.

    Bit of google and forum searches took me to this page which hits the exact error on the head:

    [url]http://www.fogproject.org/wiki/index.php/Images_Directory_Permissions[/url]

    However giving fog user ownership and full permission to the /images directory and subcontents made no difference. I also removed any temp images/renamed etc per option 2 in this post but neither worked.

    I checked the machine on the known good hardware list and there is one working Edge 71 there albeit not my exact model.

    I have changed BIOS setting on the reference machine so Sata reads as IDE not AHCI (tried both), I also tried 32-bit instead and got same error.

    I’ve tried amending image definition from multi partition to single partition - no difference.

    I’m running 0.32 version of Fog. In case its important the image is being uploaded to a storage server - can anyone suggest anything else I can try?

    Also on a side note can anyone tell me a definitive answer as to the correct image type for Windows 7? I assume multi partition as Windows sticks in the 100MB reserved system partition but in some forum posts I’ve seen people suggesting to use Single Partition.



  • I apologize for the late reply! That is cool.



  • ok just found the tutorials section which handles the knowledge base question.



  • Abraham, thanks for the heads up on what worked for you. I didn’t see your response in the thread til I’d posted my own fix. If I hadn’t sorted something with the kernel version then your suggestion would most lkely have been next on the agenda…

    Does anyone else know how to edit a post title to show “resolved” or similar to help out others searching for actual fixes or to avoid wasting other users time from looking into already solved threads?

    As good as these and other forums are I wish there was a way to collate all the useful knowledge here into an easily searchable knowledge base rather than having to search through loads of potentially unhelpful posts…



  • Hey Joshua

    Well having ruled out permissions issues and other reasons for the specific error I tried looking at things a little more objectively. I’m using 0.32 which came out a while ago and the machines I’m trying to upload an image from are Lenovo Edge 71 models with a BIOS date of Apr12. So I thought perhaps its a driver support issue… I upgraded to the latest kernel version (3.3.3 core) and lo and behold uploading of images worked!

    So perhaps if you or others are having same issues and you’ve ruled out the permissions issues as I had, then perhaps a newer (or perhaps older) kernel version may do the trick.

    Regards, Tom



  • This happened to me, too. I was working on an image to deploy to a lab and had all my stuff in it ready to upload and got the exact same message.
    I tried 2 other fog servers in our district with the same results.
    I tried reformatting as well as using gParted, kill disk, and others to wipe the disk / partitions, etc. I even tried Changing Kernels on fog.
    Nothing worked
    After 5 days of torture and martyr I finally figured it out.

    This is what I did: (it hurt but only for a while since i had to redo my image)

    1. Go to “Hosts” tab and find your host
    2. On the left, click on “Basic Tasks”
    3. Go to “Advanced”
    4. Scroll down to “Full Wipe”… no, no, no… i’m not trying to screw you over… nothing else works (re-partitioning, formatting, etc.)
    5. Reinstall the OS, Programs, Etc, and try to reupload

    You might want to try this using a spare Hard Drive just to prove this theory.

    This worked for me and should work for you. I read somewhere that I had to wipe the partitions and tried that with different utilites but none worked like “Full Wipe”. Apparently something remains in the boot sector or something.

    Hope this helps and eases your pain(s).



  • Welcome to the club, mine has never worked… I am lead to believe that it is my NAS device that lacks the proper permissions.
    You must ensure that the permissions are the same on both the server and the storage node.

    Win7: For me, it always works properly when I set to Single Disk Multiple Partition.


Log in to reply
 

339
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.