Fedora 17 no desktop - after installing fog server with script i can't get the web interface



  • Hi all,

    I got Fedora 17 running on a virtuabox VM with Virtualbox additions installed. I ran the installfog.sh script and completed the questions… only got one error:

    Checking package: php-gettext…Failed!

    else everything worked fine.

    My Fog server has IP 192.168.1.15 and when i visit [url]http://192.168.1.15/fog/managemenet[/url] nothing happens.

    I can ping the maschine
    I can’t telnet port 80 or 8080 or 443

    I tried to reboot which didn’t help…

    All this test were done from my host mashine running virutual box and its from that i try and access the mangemenet site using IE9

    Is the php-getext that crusial for it to work? and how do i fix it?

    Sincerly

    Casper



  • I don’t have a Fedora box laying around but, the first google hit for php-gettext on fedora showed “php-php-gettext” FWIW. So, assuming that’s correct then change php-gettext to php-php-gettext in that file and try again. If you get any more errors then correct 'em and try again! :)



  • Hi afmrick,

    Im totally new to Linux! :) This was ment to be my little project to get to know the OS. Though i know what you are talking about i could really need some help how to fix it cause i have no clue where to start.

    The reason i went with Fedora was actually because it was the only other choice rather then Ubuntu the fog installation seemed to support in the script and I have had allot of problems installaing the virtualbox additions on the ubuntu VM so i went with Fedora which worked better.

    How do i find out what the actual package names are?

    I nanoed the file you mention and got this:

    Packages="httpd php php-gd php-cli php-gettext mysql mysql-server php-myswl dhc$

    there is allso a storagenodepackages with the excat line as above besides from mysql-server and including nfs-utils which is not on list above
    Allso it says my langpackages is “iso-codes”.

    So does anyone of you afmrick have any clue how to fix it?

    Sincerly

    Casper



  • If you check out fog_0.32/lib/redhat/config.sh you’ll see a line like this:
    [CODE]packages=“httpd php php-gd php-cli php-gettext mysql mysql-server php-mysql dhcp tftp-server nfs-utils vsftpd net-tools wget xinetd tar gzip make m4 gcc gcc-c++ htmldoc perl perl-Crypt-PasswdMD5 lftp clamav-update”;[/CODE]
    When the install failed at “php-gettext” it probably didn’t install any of the packages listed after it. IIRC, there’s a couple package names you might have to modify in that list for Fedora (or repositories) …and possibly a path or two in the script.


Log in to reply
 

415
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.