LenovoE550 screens goes black after imaging



  • Hey everyone so I have a weird issue that’s happening to one of our models. I’ve created the sysprep 64 bit image through vmsphere and I upload it onto each computer model we have, then I download the drivers for that model and upload it into FOG. I’ve done this process for a couple of years and it’s always worked…until now. I recently tried to upload the sysprep image onto a LenovoE550 and it makes it through the imaging process and restarts the first time, but when it starts to load the computer it says Windows is updating the registry settings…then the screen goes black. Nothing I try gets it to come back on and the only thing that works is restarting the computer, but the same thing happens again. Sysprep works on every other model we have Lenovos, Hp, Dell but it’s this one particular model that’s giving me issues. Sysprep loaded onto this model fine last year, but for some reason it’s not working now. I tried to update the sysprep image and that didn’t work…anyone come across this issue before or have suggestions???

    Thanks!!!


  • Moderator

    @kyle.heath Does the bios updates only run in windows or is there a DOS option?

    In our case we use a WinPE boot disk that has all of our dell bios drivers on it. We boot from usb flash drive that has WinPE on it then we launch the proper bios driver to update the system. We have scripted an automated process for this now, but that is the basics of how we install a consistent bios version on all of our bare metal computers (we use a winpe boot disk).



  • @Tom-Elliott This happens during sysprep when the computer is imaging…how do I get it to update the bios and also sysprep at the same time?


  • Senior Developer

    @kyle-heath can you try what @UkeTruck has done to see if all will work for you? That way we can solve this thread.



  • I have run into this issue and it happens after the first reboot after Windows 10 updates the Video drivers. The issue is an old BIOS. I let the issue happen on 3 of my machines. After the issue occured, I booted up the BIOS install disk I had, updated the BIOS and it resolved the issue. I had 10 other E550 laptops that I updated the BIOS before it installed the video drivers and the issue never occured. I am 13 for 13, so update the BIOS for the win.


  • Moderator

    @kyle.heath There are many different ways of building that reference image. One way is to use MDT to build the reference image on a vm and then sysprep it for deployment.

    Since you capture this sysprep image with fog and then deploy with FOG you have a few interesting options. What I’m thinking is a modified version of this: https://forums.fogproject.org/topic/7391/deploying-a-single-golden-image-to-different-hardware-with-fog

    In your case in your sysprep image you would modify the registry to search c:\drivers and then c:\windows\inf Then if you need to load a driver (such as this video driver) you can place it in the c:\drivers directory using a fog post install script. This would keep you from having to update and then resyspreping / fog capture the image every time you run into this issue.

    The other thought would be to follow this document and just cut out the second part of the process where you manually load the drivers and then capture the image a second time.



  • @george1421 Alright I can put the drivers on the sysprep image through vsphere. I’m pretty new at the whole creating sysprep images and what not. Do you have an email that you can send me and I can add you to the google doc that we use? Maybe you could take a look at the document and see if I’m doing the correct process, if so that would be great!

    To answer the last question yes we use FOG to push the sysprep image to the target computer so we can install the drivers for that computer…then we upload the completed image back into fog under each computer name…so Lenovoe550 is one…lenovoe440 is another.

    Thanks for all your help


  • Moderator

    @kyle.heath gotcha, then yes you will need to have the drivers loaded into your sysprep’d environment.

    This is a bit off-point (but not really)

    1. How do you build your initial sysprep image?
    2. Are you using FOG to push the sysprep image to the target computer so you can install the drivers.


  • @george1421 Yep it images like normal, but after the first restart(it usually does 3) it stops working after it says windows is updating registry settings…the computer is still on, but the screen is black.


  • Moderator

    @kyle.heath ok now that we are talking the same language lol.

    So you are having a problem deploying your reference image to this lenovo? So you are not even getting to the point of being able to load the drivers?



  • @george1421 ahhh I get what your saying now. We are just uploading it into fog once the drivers are installed…we do not sysprep a second time. Sysprep and the other computers are working…it’s just the lenovoe550 that doesn’t work. Maybe install the lenovoe550 GPU driver onto our sysprep image then try to deploy it to the computer?


  • Moderator

    @kyle.heath Sorry I must not explained what I was asking well. I got the concept of what you are doing.

    DVD->Reference image->Sysprep (now you have a reference image one for x32 and one for x64)

    Reference Image->New Hardware->Load drivers->(??Sysprep round 2??)->Upload to fog.

    Are you syspreping the second time or are you just powering it off and uploading it or just uploading it once the drivers are loaded?



  • @george1421 When we have the sysprep image looking the way we want it through vsphere we go to basic task in FOG and click upload image. We store sysprep in fog so we can deploy it to each machine. We use the command sysprep.exe /generalize /oobe /restart to upload the image into fog.


  • Moderator

    @kyle.heath Do you sysprep it a second time? Before you upload it to FOG?



  • @george1421 Yeah we have 1 image per hardware model…so we have a sysprep image for 32 bit machines and a sysprep image for 64 bit machines…then we load those onto each model of computer we have and install drivers…then we upload the finished image back into fog so we can deploy it to all of the same model computers. So your saying I should just upload the drivers for the computers on our sysprep image? Then deploy that image to each individual model of laptop?


  • Moderator

    @kyle.heath Do you have a single image for all hardware or do you have one image per hardware model. If you have one image per hardware model then yes add all current drivers to your reference image. If you have one image for all hardware then you need to look into how you inject your drivers into the image. You may not have the proper driver or you have an unsigned driver and windows is refusing to load it automatically.



  • @kyle.heath So maybe add the Lenovoe550 driver to the sysprep image ahead of time?



  • @Quazz So how would I go about fixing this? Install the GPU driver for the lenovoe550 on the sysprep image?


  • Moderator

    I would inspect the contents of the setup log in c:\windows\panther. But my guess is that they changed the video driver or installed video card in that device and your driver doesn’t match the hardware involved.


  • Moderator

    Just for clarity this is not a fog issue since the system is booting. Moving to Windows problems since OOBE is starting to run (since it says updating the registry…)


  • Moderator

    GPU driver messing up most likely, that would be my guess anyway.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.