Booting Ubuntu 16.04 ISO from FOG; /dev/sr0: No medium found


  • @Fitzzz For the location, you have the mint folder loaded in /var/www/html/fog/service/ipxe/mint, and the files exist?


  • @Tom-Elliott

    :MENU
    menu
    item --gap -- ---------------- iPXE boot menu ----------------
    item mint              Mint
    item ubuntu          Ubuntu 16.04 Desktop
    item ubuntu2         Ubuntu Extracted ISO Test
    item hirens            Hiren's Boot CD
    item shell          ipxe shell
    item return        Return to previous menu
    choose --default return --timeout 15000 target && goto ${target}
    
    :mint
    kernel http://$(fog-ip)/fog/service/ipxe/mint/casper/vmlinuz
    initrd http://$(fog-ip)/fog/service/ipxe/mint/casper/initrd.lz
    boot ||
    goto MENU
    
    :ubuntu
    initrd http://${fog-ip}/fog/service/ipxe/Linux/ubuntu-16.04-desktop-amd64.iso
    chain memdisk iso raw ||
    goto MENU
    
    :hirens
    initrd http://$(fog-ip)/fog/service/ipxe/hirens/hirens.iso
    chain memdisk iso raw ||
    goto MENU
    
    :ubuntu2
    kernel http://$(fog-ip)/fog/service/ipxe/Linux/iso/casper/vmlinuz.efi
    initrd http://${fog-ip}/fog/service/ipxe/Linux/iso/casper/initrd.lz
    boot ||
    goto MENU
    
    :shell
    shell ||
    goto MENU
     
    :return
    chain  http://${fog-ip}/${fog-webroot}/service/ipxe/boot.php?mac=${net0/mac} ||
    prompt
    goto MENU
    
    

    Is this what you’re looking for? And how would I go about showing you the settings, exporting a backup?
    As I post this I see the apostrophe affects the code’s display, does it affect how the code is interpreted by FOG?


  • Then I need to see the menu entry and settings you have.


  • @Tom-Elliott I’ve tried that as well, it brought me to the same issue, unfortunately. I haven’t tried it for the other ISO’s though. Will do that this morning.


  • You are still trying to boot the ISO as an ISO, rather than extracting the ISO and using the file structure FROM the iso.


  • @Fitzzz You’re not following the information as laid out.


  • @Tom-Elliott Sorry for the late reply, I’ve looked through that thread extensively before and again now, it’s why I’m left so utterly confused. The original poster of that thread has both a linux distro and hiren’s working, neither of which can I get working, despite having the same setup for the advanced configuration.

    However, I did fix the /dev/sr0 problem by disabling the CD-ROM drive in the VM settings. Thank you for that.

    I boot the iso, do Try Without Uninstalling, and then it just says it’s unable to find a medium containing a live file system. Other ISOs I try to boot from (that other people have working) just bring me to Operating System Not Found, which I believe means it’s failed booting the ISO and is trying to boot from the hard drive (of which there are none).

    Again, sorry for the late reply, as it is this reply took two days to make I’ve been so swamped.


  • Thank you for your replies, I will look into them and try out everything tomorrow morning when I’m back in the office!


  • Another guide within our forums:

    https://forums.fogproject.org/topic/4790/how-to-add-live-cd-iso-to-fog-1-2-on-ubuntu-12-04

    Of course just adjust the parameters for the 16.04 ISO, but should help get you closer. /dev/sr0 is almost always CD/DVD Drive.

  • Moderator

    @george1421 Actually this link will get you closer to where you want to be. https://wiki.ubuntu.com/LiveCDNetboot

    [edit] And here are instructions I wrote for PXE booting a WinPE iso image with fog: https://forums.fogproject.org/topic/6284/booting-mdt-2013-litetouch-with-fog

  • Moderator

    My guess is what you really want to do boot a linux live image in a pxe boot environment.

    First let me say that fog is not intended to be used in this manner. And what you are doing is not supported by the FOG developers.

    With that said you might want to look into live boot options here http://cdimage.ubuntu.com/netboot/ If you are using the trunk build or 1.3.0-rc1 of FOG you should be able to do this since the trunk build allows you to add custom iPXE boot menu options right from in the FOG management gui.


  • There is not a single Ubuntu ISO that I’m aware of that will boot unless it is off a CD/DVD

356
Online

9.1k
Users

15.7k
Topics

145.9k
Posts