PXE Booting: Fog Menu Flashes for a second then boots HDD



  • I Just installed Fog 0.32 to Ubuntu 10.04 LTS server. The only settings I changed so far are:

    • changed bind-address in /etc/mysql/my.conf to my IP
    • added a password to /var/www/fog/commons/config.php since my mysql root password was set.

    accessing 192.168.1.130/fog/management works ok.

    I have my client PCs connect to the router via switches and my Ubunter server is also connected to the router with static IP of 192.168.1.130. I installed with the following settings:

         Distro: Ubuntu
         Installation Type: Normal Server
         Server IP Address: 192.168.1.130
         DHCP router Address: 192.168.1.1
         DHCP DNS Address: 192.168.1.1
         Interface: eth0
         Using FOG DHCP: 1
         Internationalization: 1
    

    Now, I enabled Network Booting on my Client PC, but when I boot, the Fog graphical menu flashes for a second, then skips to the next boot device. I read that I should maybe try booting in text mode, but I wasn’t sure how. Any suggestions?

    thanks in advance



  • TIMEOUT of 30 or 3 seconds is probably what you want. If you hit the down arrow while the fog menu is displayed, it will not move on to the secondary boot device. A short display time for the PXE menu, insures that the startup process is not delayed too long.



  • SOLVED!

    In /tfptboot/pxelinux.cfg/default

    I changed
    [CODE]TIMEOUT 30[/CODE]

    to
    [CODE]TIMEOUT 3000[/CODE]

    it appears that that timeout value could be in miliseconds~ and only defaulted to 30

    EDIT: setting to 3000 gave me 300 seconds, so in 10ths of a second


Log in to reply
 

772
Online

39.4k
Users

11.1k
Topics

105.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.