Kernel panic - not syncing: VFS



  • Ubuntu 14.04
    FOG SVN 7853

    I just recently upgraded with a clean install of FOG and am now running into the problem with the Kernel Panic - not syncing: VFS. Was wondering if anyone else has ran into this issue and how’d they fix it? I’ve been scouring the internet looking for solutions and most of them require reinstalling with a Rescue CD which I don’t exactly have. I have tried Updating/Upgrading Ubuntu and Rerunning the ./installfog.sh. Also tried downgrading the kernel.



  • @george1421 It works ! Thanks for your support :)
    edit : Yes I’m running dnsmasq.


  • Moderator

    @George-Lebay Are you running dnsmasq?

    But if you upgrade then you have a better chance of getting support since you are on a supported OS and active version of FOG.



  • @george1421 I will make the upgrade to 1.3.0. My fear was to get that Kernel Panic message again (Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)) but since I’m working with fresh server and FOG installations, I’ll give it another try. I’ll let you know what happens then.


  • Moderator

    @George-Lebay Right, with FOG 1.2.0 the max kernel version you can use is < 4.4. So in your case try 4.1.2 and see if that works with the Prodesk 600. If not you will need to upgrade to 1.3.0.rc4. Since this is not a production server (yet) then there is no harm in upgrading. (Yeah I know I’m pushing, but the new features in 1.3.0 are worth the extra effort to upgrade).



  • @george1421 Well I had this old Proliant ML150 G6 doing nothing and I wanted to use it as my next Fog server. Since Fog is not operational at the moment, and it’s pretty quiet around here (I work in a university) I decided to make the hardware switch.

    About the problem I have now, which is the same problem I had at the very beginning:

    I have 2 models of client PC. HP 6200 and HP Prodesk 600 (that I just received).

    Fog works perfectly well with the 6200, but I when try to register a Prodesk 600, I’m getting this error: Unable to register host for the following reasons:
    Then it gives no reason, and then the system displays some inventory data. Then it just slowly scrolls down forever after it displayed the message attempting to register host

    I tried to upgrade the kernel, then it just got worst. It did not work on either the 6200 or the ProDesk 600… I was getting this message on both models:
    Unable to register host: Invalid MAC Address! (/bin/fog.man.reg)


  • Moderator

    @George-Lebay Why not go with FOG 1.3.0-rc4? Any reason since you are doing a clean install anyway? Just install the rc version https://wiki.fogproject.org/wiki/index.php/Upgrade_to_trunk



  • @george1421 I have decided to reinstall 14.04 server from scratch and fog 1.2.0 with the latest kernel. I need to start a new thread. Thanks again for your help.


  • Moderator

    @George-Lebay Did you remember to restart the dnsmasq service? If yes then…

    Is the fog server and the target computer in the same subnet/vlan? If so we’ll need to get a packet capture of the booting process to see what’s going on with the client.



  • @george1421 First, thanks a lot for your help. Unfortunately I get the same error.

    The Fog menu appears correctly on the client, but then whatever option I choose I get the Kernel Panic message …


  • Moderator

    @George-Lebay said in Kernel panic - not syncing: VFS:

    For what it’s worth, in the ltsp.conf file, the boot filename line is set to : dhcp-boot=pxelinux.0

    OK this answers the questions, specifically.

    (I was going to go the easy route, but lets do it right way).

    In the ltsp.conf file change pxelinux.0 to undionly.kpxe and save the settings.
    Then in /tftpboot create a symbolic link from undionly.kpxe to undionly.kpxe.0 (the number zero). You would use a command line ln -s /tftpboot/undionly.kpxe /tftpbppt/undionly.kpxe.0
    Restart dnsmasq.
    PXE boot your client.

    This way when you update FOG and the undionly.kpxe file gets updated, dnsmasq will always have the latest file. You could have just copied undionly.kpxe to undionly.kpxe.0 but at some time when you update fog, these files will get out of sync.


  • Senior Developer

    @George-Lebay change pxelinux.0



  • @george1421

    Thanks for the quick reply. I understand I should have started a new thread. Sorry about this. I don’t know what to answer to your first question. Can you be more specific on where I can find this information (dhcp option 67 {boot file} in dnsmasq) ? My Fog configuration have been running smoothly for several years and I havent made any modification for a long while and I don’t have a great knowledge when it comes to Linux or Fog. About the other question, I created a link from pxelinux.0 to undionly.kpxe. This was done way before I made to update to Fog 1.3.
    For what it’s worth, in the ltsp.conf file, the boot filename line is set to : dhcp-boot=pxelinux.0


  • Moderator

    @George-Lebay First let me shame you with you should start your own thread, because your conditions may be different.

    Where we’ve seen this is if someone is using an old version of the iPXE kernel. Everything will work except when you try to boot into the FOS engine (the linux OS that captures and deploys images on the target computer).

    Since you are using dnsmasq and dnsmasq uses the .0 files (like undionly.kpxe.0) I would have to ask this

    1. What do you have configured for dhcp option 67 {boot file} in dnsmasq?
    2. How did you create the .0 file in /tftpboot? Did you just copy undionly.kpxe or did you create a link from undionly.kpxe to undionly.kpxe.0?


  • @george1421

    Hi,

    I just updated from 1.2 to (Running Version 1.3.0-RC-1 SVN Revision: 5936) and since then when I try to quick register a host or just check the compatibility of a client with Fog, I am getting this message:

    Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)

    I am using a dnsmasq environment.

    Honestly I don’t know where to start to get this solved. Any help would be greatly appreciated.



  • @george1421

    Oh, my mistake, it was a administrator error, it was in the installation text when configuring the ./installfog.sh in the beginning, I didn’t read through the updated DNS steps, and left it to the previous DNS setup. I just ran through it again trying to find the step and it looks like its been corrected.


  • Moderator

    @Data31337 Thanks for the feed back. I was trying to drive at was it posted on a fog wiki somewhere. If it was we need to get that removed asap. But it looks like you had it from another source. I’m just trying to avoid this issue for the next guy.

    If you run into FOG issues again, don’t forget we are here to help.



  • @george1421

    It was in one of the old installer files, before I upgraded to trunk (Possibly in 1.2.0, or 0.32 which were the only 2 older generations I had installed along with older wiki page).

    Please everyone take my up-votes you guys have been amazing help while working through this!


  • Senior Developer

    And I was staring to get worried it was something in the code.


  • Moderator

    @Data31337 Please identify where you found the guidance to use pxelinux.0?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.