Only one computer in group



  • Hi All,

    Trunk version 7559.

    I tried to add several computers to a group, which exists or not, only the last one is added.

    From the host managment or from the group management\Membership: The problem is the same.

    If there is a computer in the group, it is removed and the last one of the new selection is added.

    Thanks,

    Zaza.



  • @mccabem Upgrade to the latest version of the trunk. I’m using 7959 and it works fine.

    I believe @Tom-Elliott fixed this issue in a 79xx version of the trunk.



  • Hey guys i’m seeing this exact problem. I did a fresh install of the trunk a week or two ago, i’m on version 7519. I’m on Ubuntu 14.04.

    I did re-import my hosts from my 1.2.0 server, not sure if this is causing it or not.

    I see you guys got it fixed by creating the new group table, but i’m concerned i’ll lose all of my hosts when i do that? If it won’t mess with my hosts, can someone give me some direction on how exactly i run that create table command? i’m not very linux or mysql savvy :( Thank you!!

    Edit: I just checked a second site that i have on the trunked version, and it is doing the same thing except it shows 0 new members after I try to put computers in the group. I get no error, just no members. This site is running 7851 on 14.04 and i did NOT restore any type of hosts, this was a fresh install… ugh please help :(



  • @abos_systemax said in Only one computer in group:

    We are having the same issues here, on Trunk version 7843.
    We’ve just updated and did not yet perform a removal of the dbase

    With the new group table SQL from earlier this thread, it is resolved.



  • We are having the same issues here, on Trunk version 7843.
    We’ve just updated and did not yet perform a removal of the dbase


  • Developer

    @lemxseb thanks a lot for testing and reporting. May I ask you some question:

    I repeated it today and I got the same issue.

    Did you remove the DB completely (purge the package plus delete the DB files in /var/lib/)?



  • I’ve been getting the same problem with a fresh install on an ubuntu 14.04.3 x64. I used the git trunk version.
    The only way I find to get rid of it is to delete the table groupMembers and recreate it with the create table find here. The other way for a fresh install is to install the stable 1.2.0 version first (which create the database) and installing the trunk version after. There is something with the database creation of the git trunk version. I repeated it today and I got the same issue.


  • Moderator

    @Tom-Elliott said in Only one computer in group:

    Why’d you remove the \G? That’s valid.

    Not on every system. I’ve had it throw syntax errors before.



  • I alter the table indexes like yours. It works like a charm now. I have my 7 computers in one group. :)

    This topic can be closed.

    Thanks you,

    Zaza.


  • Senior Developer

    @Tom-Elliott The only difference I see is the KEY’s aren’t adjusted for in yours where mine is.


  • Senior Developer

    @Zaarin

    CREATE TABLE `groupMembers` (
      `gmID` int(11) NOT NULL AUTO_INCREMENT,
      `gmHostID` int(11) NOT NULL,
      `gmGroupID` int(11) NOT NULL,
      PRIMARY KEY (`gmID`),
      UNIQUE KEY `gmHostID` (`gmHostID`,`gmGroupID`),
      UNIQUE KEY `gmHostID_2` (`gmHostID`,`gmGroupID`),
      KEY `new_index` (`gmHostID`),
      KEY `new_index1` (`gmGroupID`)
    ) ENGINE=MyISAM AUTO_INCREMENT=19 DEFAULT CHARSET=latin1 ROW_FORMAT=DYNAMIC
    


  • 5.5.49-0ubuntu0.14.04.1

    I had problem with database update but it was some version before. I agree with you that all users will see exactly the same problem.

    The only way to check is to compare with yours: Do you have the same structure?

    Once again thanks for all your time,

    Zaza from Luxembourg.


  • Senior Developer

    @Zaarin What version of MySQL are you running?


  • Senior Developer

    @Zaarin No, it’s not. If it were the case, ALL users of trunk would be seeing EXACTLY the same problems.

    Maybe the issue is the schema that performed didn’t update properly? I don’t know.

    You can try to alter the unique indexes if you want though. I don’t know what you’d do. Maybe for now just remove the unique index’s and keys?



  • I agree with you for the unique key gmHostID_2 but not for the index: gmHostID. With that index only one group is allowed with one member.

    \G is not recognized in phpmyadmin. I took the mysql console. Here is what you want.

    mysql> SELECT * FROM `fog`.`groupMembers` \G
    *************************** 1. row ***************************
         gmID: 1
     gmHostID: 6
    gmGroupID: 1
    *************************** 2. row ***************************
         gmID: 3
     gmHostID: 7
    gmGroupID: 3
    *************************** 3. row ***************************
         gmID: 4
     gmHostID: 2
    gmGroupID: 4
    3 rows in set (0.00 sec)
    

    Thanks for your time,

    Zaza.


  • Senior Developer

    @Zaarin Why’d you remove the \G? That’s valid. And prints data much nicer especially when the output to the screen.

    Can you get us a copy of the Statement with the \G AND without the WHERE clause(s)?



  • I removed the \G. Empy result is returned.


  • Moderator

    @Zaarin The problem is likely the data in the tables, not the tables themselves.


  • Senior Developer

    @Zaarin Further to add on, this is applied to the DB and I’m not seeing the same issue.

    I really believe if you run:

    SELECT * FROM `fog`.`groupMembers` WHERE `gmID`=0 OR `gmHostID`=0 OR `gmGroupID`=0 \G
    

    Print the output of that here, and we should be able to see what’s going on a little better.


  • Senior Developer

    @Zaarin I don’t think it’s anything to do with the unique key. The idea of the one you believe is conflicting is that there only be one Host ID with a single group id. This way you don’t have

    2 2
    2 2
    2 1

    Pairings.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.