F-Secure(any actually) booting in Fog



  • I know… Wishful thinking. Work is slow and started playing around with it.
    Here’s what I did and maybe someone has more linux knowledge than i and have any ideas.
    I think the key thing here is parameters.

    First attempt I followed this guide.
    [url]http://www.syslinux.org/wiki/index.php/WDSLINUX[/url]

    I get up to check your network connection or wifi. That’s it. Can’t do anything else. nadda… zip… nothing…
    I can’t seem to enable screen out logging?

    Next I tried converting the ISO in Yumi (USB boot) and copy the menus over to fog pxelinux.cfg.
    I have it booting up than I get a halt error about 50% into the loading process.

    could not mount disk to /mnt-system. starting debugging shell…
    can’t access tty; job control turned off.
    (I feel like this was what I removed from the other part?)

    I started changing the tty values from 10 to 1 to 2. I read it was something to do with ports. Not sure…

    I really thing there is a light out of this tunnel running one of these linux anti virus disks in pxe. I’m going to spend some time mocking up and editing until school starts again.



  • [quote=“emacwizguy, post: 3473, member: 1130”]Hey, what did you use to create your winpe? I just tried Bartpe compiler and I get a chkdsk /r bsod at startup.[/quote]

    I didn’t use BartPE. I used the basic guide here, [url]http://technet.microsoft.com/en-us/library/cc709665(v=ws.10).aspx[/url] skipping steps 3 and 4 because I was interested in just a vanilla flavor of WinPE. I’ve heard that there are lots of issues trying to get BartPE to PXE boot using FOG.

    What I do for programs is store portable apps/utility programs (like the kind that UBCD would offer) on a shared network drive on one of my servers, then just run “net use” to the share once WinPE is finished loading.

    In my opinion, this does two things: 1. It keeps the size of the ISO down so that it’s faster loading time 2. this allows me to add more programs without having to remake the iso.

    I’ve been able to run Scans with portable AV apps, run defrags, high quality chkdsk programs, bios updates, regedits, and am now working on integrating Windows Installers (for those times when an FOG image isn’t available) into this process.



  • Hey, what did you use to create your winpe? I just tried Bartpe compiler and I get a chkdsk /r bsod at startup.



  • Yes



  • have you tried just booting the iso in pxelinux? I used memdisk to boot a WinPE iso and it works ok.

    Here’s an example of the entry in my ‘default’ file.

    [CODE]LABEL WinPE
    kernel memdisk
    append initrd=fog/winpe/WinPe.iso iso raw
    MENU LABEL WinPE
    \n[/CODE]

    Replace ‘fog/winpe/winpe.iso’ with the filename of your iso and of course the LABEL names. :)


Log in to reply
 

458
Online

39010
Users

10725
Topics

101895
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.