* Creating SSL Certificate....................................Failed!



  • Hello

    I upgraded to Ubuntu 16.04 and then I decided to upgrade my current trunk of fog and I get this error

    • Creating SSL Certificate…Failed!

    what is it and how do I fix it?

    THanks



  • I had this issue too
    I ran ./installfog.sh -K to fix it
    I am running CentOS Linux release 7.2.1511



  • @Tom-Elliott Fixed my issues and now I’m in business


  • Senior Developer


  • Senior Developer

    Doing recreate-keys fixed this issue.


  • Senior Developer

    Remotes in and I believe recreate-keys will do the trick.


  • Senior Developer

    @dureal99d Just wrote to you in chat. I’d like to try a join.me session if possible



  • @Tom-Elliott I cant even logon to the fog management screen anymore, I’m backing up my images manually as we speak just in case,
    but man I would really like a fix here.



  • @Tom-Elliott said in * Creating SSL Certificate....................................Failed!:

    that uses an already created fogsettings file?

    No ive been using trunk since 15:10 unless I’m misunderstanding your question. Fog was already installed and configured just how I like, but I upgraded the os and then to the latest version of the trunk after words


  • Senior Developer

    Is this a fresh install that uses an already created fogsettings file?


  • Senior Developer

    @dureal99d What directory? Exactly what path.

    You should find it in the /path/to/fog/installer/bin/error_logs/fog_error_7476.log



  • Tom Ive looked in the directory and nothing is present

    what do I do?



  • @Tom-Elliott said in * Creating SSL Certificate....................................Failed!:

    What’s in your bin/error_logs/fog_error_${version}.log file? (Change ${version} to match 7476 or whatever version you’re installing.)

    I see this error which must be the culprit
    "/opt/fog/snapins/ssl//fog.csr: No such file or directory"



  • /usr/bin/lsb_release
    /bin/systemctl
    /opt/fog/.fogsettings
    Reading package lists…
    Building dependency tree…
    Reading state information…
    software-properties-common is already the newest version (0.96.20).
    python-software-properties is already the newest version (0.96.20).
    The following packages were automatically installed and are no longer required:
    checkbox-ng gstreamer1.0-clutter heirloom-mailx icedtea-netx
    icedtea-netx-common iproute libamd2.3.1 libatk-wrapper-java
    libatk-wrapper-java-jni libbasicusageenvironment0 libbind9-90 libcamd2.3.1
    libcamel-1.2-52 libccolamd2.8.0 libcholmod2.1.2 libck-connector0
    libcolamd2.8.0 libdbd-mysql-perl libdbi-perl libdns100
    libebook-contacts-1.2-1 libecal-1.2-18 libedata-cal-1.2-27
    libedataserver-1.2-20 libept1.4.16 libgconf2-4 libgee2 libgif4:i386
    libglew1.10 libglewmx1.10 libglib2.0-0:i386 libgnutls-deb0-28:i386
    libgroupsock1 libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386
    libgtop2-10 libhdb9-heimdal libimobiledevice4 libisc95 libisccc90
    libisccfg90 libisl13 libkdc2-heimdal liblinear1 liblivemedia23 libllvm3.6v5
    libllvm3.6v5:i386 liblouis2 liblua5.1-0 liblwres90 libmysqlclient18
    libmysqlclient20 libnl-route-3-200 libntdb1 liborc-0.4-0:i386 libpgm-5.1-0
    libpoppler52 libpth20 libqpdf13v5 libraw10 libsodium13 libtinyxml2.6.2v5
    libumfpack5.6.2 libusageenvironment1 libusbmuxd2 libvte-2.90-9
    libvte-2.90-common libx265-59 libzmq3 linux-image-4.2.0-16-generic
    linux-image-4.2.0-18-generic linux-image-4.2.0-19-generic
    linux-image-4.2.0-22-generic linux-image-4.2.0-23-generic
    linux-image-4.2.0-25-generic linux-image-4.2.0-27-generic
    linux-image-4.2.0-30-generic linux-image-extra-4.2.0-16-generic
    linux-image-extra-4.2.0-18-generic linux-image-extra-4.2.0-19-generic
    linux-image-extra-4.2.0-22-generic linux-image-extra-4.2.0-23-generic
    linux-image-extra-4.2.0-25-generic linux-image-extra-4.2.0-27-generic
    linux-image-extra-4.2.0-30-generic python-cffi python-characteristic
    python-dbus-dev python-ntdb python-ply python-pycparser python3-cffi
    python3-checkbox-ng python3-ply python3-pycparser qml-module-qtquick-dialogs
    qml-module-qtquick-localstorage qml-module-qtquick-privatewidgets
    qtdeclarative5-localstorage-plugin qtdeclarative5-qtfeedback-plugin
    qtdeclarative5-ubuntu-web-plugin telepathy-indicator ttf-dejavu-extra
    unity-scope-audacious unity-scope-clementine unity-scope-gmusicbrowser
    unity-scope-gourmet unity-scope-guayadeque unity-scope-musique
    Use ‘sudo apt autoremove’ to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    3 May 16:57:37 ntpdate: Starting MySQL Community Server…
    May 03 16:58:28 dureal99d-Precision-WorkStation-T5400 systemd[1]: Started MySQL Community Server.
    apache2.service is not a native service, redirecting to systemd-sysv-install
    Executing /lib/systemd/systemd-sysv-install enable apache2
    Synchronizing state of php5-fpm.service with SysV init with /lib/systemd/systemd-sysv-install…
    Executing /lib/systemd/systemd-sysv-install enable php5-fpm
    /opt/fog/snapins/ssl//fog.csr: No such file or directory


  • Senior Developer

    What’s in your bin/error_logs/fog_error_${version}.log file? (Change ${version} to match 7476 or whatever version you’re installing.)


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.