TFTP/FTP Connection Failure after imaging- Tried all steps on the forums



  • Good afternoon everyone,

    I’ve got a little problem that I am hoping someone can help me solve. I know this is a little long, but I’ve done a whole bunch of troubleshooting and I want everyone to know what has and has not been tried.

    Yesterday I upgraded my Ubuntu FOG server from 11.10 to 12.04. Upgrade went fine and was error free.
    I then went to image a machine using a known good image and received the following error: "TFTP Open Timout"
    Did some reading and found that this seems to be indicitive of password mismatch of some sort. OK, no big deal. According to my readings I needed to do the following:

    change the fog password by typing sudo passwd fog
    Then, in storage Nodes on the front end I clicked on Default Member and changed the management password to match my newly set password. I also went to Other Information and changed FOG_TFTP_FTP_PASSWORD to the same thing.
    Then, in the config.php file I changed TFTP_FTP_PASSWORD and STORAGE_FTP_PASSWORD to match the above.
    then reloaded the service using this command:
    /etc/init.d/vsftpd reload
    Everything said it changed fine.
    Tried again. Same error. Repeated the above steps using both the hashed version of the password and a plaintext version (wasn’t sure which was right) Still no dice.

    Gave up and re-installed FOG.
    Imaged my machine. Everything seemed fine. Saw the image being loaded onto the computer, last I checked it was at 60% or so of a Win 7 image. Left work, came back this morning and I have a screen with an error that more or less said it couldn’t connect to the FTP server (Wasn’t thinking and turned off the computer without writing down the error) booted the machine back up. Same error again. Booted the machine again, but manually skipped the network boot. Windows came right up. All seems to be ok, but FOG keeps shutting the machine down to try to add it to the domain so I can’t confirm.

    Killed the task in FOG thinking maybe that would help.

    Now, if I don’t skip the network boot I get the following error:
    Checking Queue
    No job was found for [my mac address] [time it checks]

    So now I went to try to re-reimage the stupid thing and I get this message in the frontend:
    None of the machines were able to be queued!
    [ComputerName] Unable to connect to tftp server.

    I’ve rebooted the server about a million times and it doesn’t help.

    *forgot to add that I am able to [url]ftp://fogserverIP[/url] and log in with the normal credentials just fine.

    Any ideas anyone?



  • THIS IS WHAT I 'VE BEEN LOOKING FOR! Everything works perfect after this!



  • This is a common issue that keeps coming up in the forums. You install 12.04, install fog and reboot and then TFTP times out.

    Look in your /var/log/syslog file and you’ll see something like:
    [code]May 22 14:16:22 yourServer in.tftpd[968]: cannot resolve local IPv4 bind address: 0.0
    .0.0, Name or service not known
    May 22 14:16:22 yourServer cron[1003]: (CRON) STARTUP (fork ok)
    May 22 14:16:22 yourServer kernel: [ 19.271357] init: tftpd-hpa main process (968)
    terminated with status 66
    May 22 14:16:22 yourServer kernel: [ 19.271374] init: tftpd-hpa main process ended,
    respawning
    [/code]

    Your nic doesn’t have an IP address when tftpd-hpa starts, so it isn’t going to work. Just do this from a terminal window:
    [code]
    sudo stop tftpd-hpa
    sudo start tftpd-hpa
    [/code]

    This is a “confirmed” bug in 12.04.

    –astrouga



  • I’ve made a little progress on solving this issue. I have discovered that TFTP works normally after a completely clean install of fog UNTIL updates have been applied to ubuntu and the server had been restarted. Once I’ve restarted, TFTP stops working.
    Still not sure [I]why [/I] but I’m still new to Linux so I’ll keep digging.
    In the meantime sudo start tptpd-hpa seems to get everything moving again.



  • I built a brand new server based on 12.04 64bit with all packages up to date. There is nothing extra on this server, it is dedicated only to fog. I’m using .32 and receiving the same error as everyone else. This is obviously a problem with fog and the version of tftpd-hpa in precise. I have done quit a bit of troubleshooting on my own so if any of the devs read this thread, let me know and I’ll do whatever I can to help squash this bug. (especially so it doesn’t persist into .33)



  • hi,
    first, sorry for my english.
    I upgraded my Ubuntu FOG server from 11.10 to 12.04 too. Now, when i want to deploy, i have this message :
    None of the machines were able to be queued! [name of the PC] Unable to connect to tftp server. And when i want to upload, i have this message :Unable to start task Unable to connect to tftp server.
    On my Pc, my ftp server is ok ([URL=‘ftp://IPaddress’]ftp://FogIPaddress[/URL]) but i see nothing (no directory no files).
    I have got only the file default in the /tftpboot/pxelinux.cfg folder.
    can you help me ?



  • You were correct, There was a file with a MAC address in there. I cleared it out, and the computer now boots normally, so my immediate issue is fixed.
    Unfortunately, however, I am now back to square one. I can no longer queue any machines to be imaged because I get the “None of the machines were able to be queued! ComputerName unable to connect to tftp server.” again. Yesterday, this was solved by reinstalling fog, which led to the aforementioned problems, but today, even reinstalling FOG doesn’t seem to want to help with this issue.

    I appreciate your help



  • what are the contents of the /tftpboot/pxelinux.cfg folder? You should have a “default” file and maybe some variations of that. If you have any files that look like MAC Addresses, I would delete them and then try the imaging process again. There may be some errant job files causing an issue.


Log in to reply
 

445
Online

38941
Users

10697
Topics

101497
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.