Private key not found



  • Hi,

    I am using last version of trunk (7009) on a Debian 8.

    On my Windows 10 PC, the FOG client is v0.9.12 and i get this error message in fog.log:

    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     31/03/2016 11:36 Client-Info Version: 0.9.12
     31/03/2016 11:36 Middleware::Communication URL: http://fog-server/fog/management/other/ssl/srvpublic.crt
     31/03/2016 11:36 Data::RSA FOG Server CA cert found
     31/03/2016 11:36 Middleware::Authentication Cert OK
     31/03/2016 11:36 Middleware::Communication POST URL: http://fog-server/fog/management/index.php?sub=authorize
     31/03/2016 11:36 Middleware::Communication Unknown Response: Private key not found
     31/03/2016 11:36 Service Sleeping for 120 seconds
    

    On another PC with windows 10, there was version 0.9.11 installed and the same error occurs.

    The /opt/fog/snapins/ssl is well present:

    # cd /opt/fog/snapins/ssl
    # ls -la
    total 9
    drwxrwxr-x 3 fog www-data 1024 Mar  2 12:58 .
    drwxrwxr-x 3 fog www-data 1024 Mar  2 12:58 ..
    drwxrwxr-x 2 fog www-data 1024 Mar  2 12:58 CA
    -rwxrwxr-x 1 fog www-data 1590 Mar  2 12:58 fog.csr
    -rwxrwxr-x 1 fog www-data 3243 Mar  2 12:58 .srvprivate.key
    

    CA is well present too:

    /opt/fog/snapins/ssl# ls -la ./CA
    total 9
    drwxrwxr-x 2 fog www-data 1024 Mar  2 12:58 .
    drwxrwxr-x 3 fog www-data 1024 Mar  2 12:58 ..
    -rwxrwxr-x 1 fog www-data 3243 Mar  2 12:58 .fogCA.key
    -rwxrwxr-x 1 fog www-data 1797 Mar  2 12:58 .fogCA.pem
    -rwxrwxr-x 1 fog www-data   17 Mar 31 10:14 .srl
    

    I reseted all hosts PubKey with this and the error is still here:

    UPDATE hosts SET hostPubKey="", hostSecToken="", hostSecTime="0000-00-00 00:00:00";
    

    Thank you for your help.


  • Senior Developer

    The issue, for others who may stumble across.

    If you’re getting Private key not found but all the data seems to point that you do have a Private key file. Make sure the node (ip address or whatever) is actually a node within the system.

    In @raumin’s case fog-server was not the node he was working with. The node he had defined was a NAS. NAS’s suck (plain and short) but have their own uses. (No offense to anybody using one, just they’re a bit of a pain to play with to get working with fog).

    So the clients were looking at the thing @raumin is using as the GUI access point for private key. This was not a defined node (and I will try to come up with a better approach).

    The fix, for now, is to always have a node for the GUI as well. You do not need to have the node enabled for things to work, and I would highly recommend against using in such a setup (NAS->Central GUI) trying to make the GUI node a “master” of the group it’s working with, unless you want it setup in such a way.

    For our fix. We created a definition for the node and gave it the proper ip address. All started working immediately.



  • Tom solved the problem, thank you.



  • @Tom-Elliott Sorry Thomas. I am running 7001.


  • Senior Developer

    Can people PLEASE, for the love all things trunk, post the EXACT version they see in their fog with the info?

    I ask a lot for the info, then get vested into trying to narrow things down. If it were that big a problem I’d be definitely made fully aware of it by many sources.

    It never helps when we don’t know what version people are running though.

    For all I know, the updates aren’t actually updating. For example, running svn up from the trunk/bin folder vs. the trunk folder.



  • I have the same problem on my side (under Win 10 too).



  • It’s the same value:

    /opt/fog/snapins/ssl
    

  • Senior Developer

    @raumin FOG GUI -> Storage Management Page -> List all/Search -> Click on the storage node known as fog-server.

    In general you should have a field called SSL Path. What’s the value in there?



  • I get this:

    sslpath='/opt/fog/snapins/ssl/'
    

  • Senior Developer

    @raumin What’s the setting for the storage node referring to “fog-server” under sslpath?



  • i can download the file.


  • Senior Developer

    What happens if you go to the url?

    http://fog-server/fog/management/other/ca.cert.der



  • i updated, deleted /var/www/html/fog then ran installfog.sh but i get the same error on hosts.


  • Senior Developer

    Please update and try again.

    I think this is relating to a bad link.

    You may need to run:

    rm -rf /var/www/{,html/}fog as well.


Log in to reply
 

499
Online

39003
Users

10720
Topics

101771
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.