Location plugin not working



  • Hey Gents!

    Using fog to set up a different location. Main FOG server is trunk 6767 and so is node. Trying to install Location plugin I’m presented with a page like the following:

    0_1458762464303_upload-4414860e-eed9-4c4f-bd0b-f0a4b19784fc

    I get the following in /var/log/httpd/error log:

    PHP Fatal error: Uncaught Error: Call to a member function getRunInclude() on unknown in /var/www/html/fog/lib/pages/pluginmanagementpage.class.php:77\nStack trace:\n#0 /var/www/html/fog/lib/fog/fogpagemanager.class.php(67): PluginManagementPage->install()\n#1 /var/www/html/fog/management/index.php(24): FOGPageManager->render()\n#2 {main}\n thrown in /var/www/html/fog/lib/pages/pluginmanagementpage.class.php on line 77, referer: http://<fogserver>/fog/management/index.php?node=plugin&sub=install

    Any ideas or a quick fix? I’m not terribly familiar with PHP but can usually sort through it or make an edit if needed. Also, thanks so much for all your previous help! FOG support is probably the best I’ve ever seen for such a project. You guys rock! (donating soon too hopefully!)



  • You can mark this is as solved. This was a case of good old SE linux set to enforce. Can’t believe it. Thanks @Tom-Elliott!!



  • @Tom-Elliott Sorry to spam you, I think I figured the problem, but I’m not sure how to fix it. So, I manually copied the images over to the storage node, and put them in corresponding folders. When I try to deploy to the host, it says:

    Failed to create deployment tasks for the following hosts, image not found on node: <nodename>

    So, question is, how is the master communicating with the node?



  • @Tom-Elliott Maybe I don’t understand storage groups correctly. Let me explain. We’re setting up this node to be shipped to a branch office. I want to be able to have it call out to the main server and just get the kernels and inits. Then, it should pull the image from the storage node. I thought I had this set up correctly. I’m not trying to replicate from the master to the node, I just want to be able to pull the image from the node. What storage group setup do I need for this, or do I even need storage groups?



  • @Tom-Elliott Awesome, that worked. However, when I go to image, it gets a little bit farther and then says “no image assigned.” :(


  • Senior Developer

    @sarge_212 the listing issue should now be fixed thanks.



  • @Tom-Elliott It did this time. And I was able to set up 2 different locations on 2 different storage groups.


  • Senior Developer

    @sarge_212 But it did install?



  • @Tom-Elliott Hey Tom,

    So I updated the trunk to 6919 on both node and master, and I’m testing on the node and when I go to register a host, and select a location, I get a messages: There are no locations on this server…However, I’ve set up 2 of them…


  • Senior Developer

    @sarge_212 I don’t know when plugins were fixed I just know I have tested their installation within the last 50 - 100 or so commits.



  • @Tom-Elliott Makes sense. I guess it really shouldn’t muck up things all that bad, and I can probably fix them. I’ll update and see what happens. Side note though, all plugins don’t work. Thanks for always being awesome, again!


  • Senior Developer

    @sarge_212 I do so many updAtes now that I don’t know when things were broke and when they were fixed. All I do know is it seems to work fine under the current setup. Updating, however, shouldn’t be a reinstall so everything you have setup this far should remain the same. Unless you made configurations around the stuff that don’t naturally happen during the installation process.



  • I really wanted to avoid updating to latest as I just got everything settled. Though I suppose that might not hurt. Do you know of any other work-arounds Tom?


  • Senior Developer

    Try updating to latest?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.