Certain Dell models are not enjoying my Universal image



  • I have created a universal image for all of our PC models in our school district. I had successful testing on 6 models, both Dell and HP then I hit a snag. I have been unable to successfully image on Dell Optiplex 755s, 380s, and 390s. It will go through the imaging process without an issue, start the Windows setup to install the drivers get to 100% on the driver install and then say that it cannot complete setup. Has anyone had this issue? I have used driverpacks for my drivers but I have also pulled the driver files from working PCs out of C:\Windows\System32\DriverStore\FileRepository. Any help would be greatly appreciate because of course, I have a overabundance of 755s and that has to be one of them that isn’t working. :cry:


  • Moderator

    @mlnancejr8808 Hmmm… interesting. But if that is what it takes then I think you are on your way. You now have a solid image that will support your fleet with a common image. Well done!!



  • @Andy-Abplanalp So I think it was the fact that I had enabled the local administrator account in windows but also had the settings in my unattend to enable that account. It was done out of habit. Once I disabled that account in windows, sysprepped again, and uploaded the image, I haven’t had a client fail yet, no matter the model.



  • @Andy-Abplanalp I believe that is what was happening. That local admin account did exist that was also in my unattend.xml to create and enable. I am working on that now.


  • Developer

    @mlnancejr8808 that still doesn’t answer my question. If you are creating a local admin account with your answer file, then make sure it doesn’t exist already in the image before you sysprep it again. Delete it from Local Users and remove any corresponding entries in the registry under the ProfileList key. That should solve this problem.



  • I had an epiphany. I think I enabled the local account already in the image then when the unattend.xml runs it is unable to do what it needs to. Do you think that could be the issue?


  • Developer

    @mlnancejr8808 when you say “adding the local admin account”, do you mean other than ‘Administrator’? If so, then yes, I’m guessing my last reply is on the right track.



  • @Andy-Abplanalp yes, it is adding the local admin account. Strange thing, i booted the image off of the domain, added to workgroup and then uploaded it again. Didn’t sysprep this time, reimaged a 745 and it worked without issue. I guess because it was no longer looking for that unattend.xml correct?


  • Developer

    @mlnancejr8808 is sysprep adding any local accounts with your answer file? The reason I ask is…I’ve seen the exact symptoms you’ve described where a local account gets added during sysprep from the answer file but stops with that exact error because that account already exists from being added during previous syspreps. Make sure the ProfileList registry keys are cleaned up before subsequent/repeated sysprepping.



  • @george1421 I’ll have to check on the BIOS versions. I think they are up to date but I’ll double check. Should I reset them to factory default and then try?


  • Moderator

    @mlnancejr8808 On these devices, have you updated the bios to the latest (yes I know they are old) as well as set the bios back to factory default. These are of the vintage that back in the XP days there were issues with the hard disk mode ata/achi/legacy. The errors that I have found so far refer to disk issues.

    In regards to Andy’s question. He’s probably asking about the number of rearms of your master image. But if you are building it from MDT source every time that shouldn’t be a problem.



  • The crazy part is that it is only affecting models Optiplex 740, 745, and 380 now. I have successfully used this image on Dell Optiplex 990, 360, GX520, 755, 760 and 780 as well as HP 6200, 6300, and 7800.



  • @george1421 I really don’t think it is the HDD space or anything with the HDD. The image size is only 45GB and I am throwing it onto at least an 80GB HDD. I’ll keep digging.



  • @Andy-Abplanalp probably too many. 5-10 at this point. I sysprep each time before I upload the image again.


  • Developer

    @mlnancejr8808 How many times has this image been sysprepped?


  • Moderator

    Here is where that error is being spun from: https://technet.microsoft.com/en-us/library/dd315662(v=ws.10).aspx

    Possible answer: http://www.experts-exchange.com/questions/26501136/Windows-server-2008-hd-space-issue.html

    It sounds like either an issue with the target hard drive, the captured image, the size of the captured image is larger than the target hard drive, or something else is jazzed up with your deployment.

    I do have to say that your issues (in this realm) are not FOG related, so you may have better luck with deployment issues on the Spiceworks Community forums. I strongly recommend you check that community out just because of the number of members alone.



  • Ok, since I got the 755 working, moved to the next trouble model which is a 380. It failed on startup, I went SHIFT+F10, mmc to view event viewer. Under System I am receiving a TON of Service startup error.

    A couple are:

    The event logging service encounterd an error (res=112) while initializing logging resources for channel Microsoft-Windows-WPD-MTPClassDriver/Operational

    The event logging service encounterd an error (res=112) while initializing logging resources for channel Microsoft-Windows-WPD-CompositeClassDriver/Operational

    The event logging service encounterd an error (res=112) while initializing logging resources for channel Microsoft-Windows-WPD-ClassInstaller/Operational


  • Moderator

    @mlnancejr8808 Great job!! Now you have a solid foundation to move forward with.

    Marking as solved



  • @george1421 So I’m not sure what fixed it but I cleaned up the Drivers, combed through my unattend.xml to make sure it was correct and removed a couple of erroneous drivers that were installed, sysprepped and uploaded the image and imaged a 755 this morning without issue!


  • Moderator

    @mlnancejr8808 Don’t forget about my original post. The only time I see this error is when a driver fails to install.

    https://forums.fogproject.org/topic/6876/certain-dell-models-are-not-enjoying-my-universal-image/11

    If you have the computer reboot your install will be broken. But if you open the command window and start up regedit and change that registry flag, then reboot the computer the installation should complete and give you a desktop. Once you are at the desktop then you can start looking through the install log files to see what went wrong. Its been so long ago now when I caused that error I can’t tell you root cause.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.