SOLVED "Invalid MAC Address!" when attempting to register machines over iPXE

  • I’m working with fog_trunk (v1.30), and I’m having trouble getting my client machines registered in the fog database. My fog server and clients are running Ubuntu 14.04. When I go to PXE boot a client machine and select quick registration and inventory, it seems populate an inventory entry based on the screen output. However, the first line outputs:

    Starting Host registration…Invalid MAC Address!

    The remainder of the inventory seems to go OK, and the machine reboots. If I check the fog database, an entry is added in the hosts schema, but no entry is added into hostsMAC. If I try to add the host manually through the web interface, the hosts and hostsMAC schemas get populated, but when I reboot the client via iPXE, the boot menu still states that the machine is not registered.

    Running the compatability mode PXE boot option yields the correct MAC address for the onboard NIC. The network interfaces option shows two interfaces in the following order: (1) the loop back device, (2) the actual NIC.

    Any ideas?

  • This fixed it. Thanks again!

  • Oh I see. I’ll upgrade to the latest version in SVN. I think my problem was that I used WGET to pull the “latest” version of the trunk following the instructions on:

    I’ll let you know what happens. Thanks.

  • @djbucci please update.

  • I ended up pulling fog_trunk for 1.2.0. The version number on the FOG logo cloud is 6381.

  • @djbucci What is the version of fog you’re using. There is no such thing (right now) as v1.30.

    The EXACT version will show up in the FOG Logo cloud when you go to the GUI.

    My guess is you’re on an older version which this issue as already been addressed.

    Either that or you’re using 1.2.0 with trunk inits.