SOLVED "Cannot create references" error

  • Senior Developer

    I removed the value being passed my reference. With any luck, this error will be gone and solved.

  • I have a directory called “fogproject” from when I initially installed Fog. I did a “git pull” from within that directory to make it current, then did a “cd bin ; ./” to run the installer. I think this shows what version I’m working with; these commands were run in the fogproject directory:

    # git describe --tags
    # git log -1
    commit fb42d97355ff12ad540bfde3edc6ee02f0d1a909
    Merge: b6bfde0 fd40b38
    Author: Tom Elliott <>
    Date:   Mon Feb 15 16:34:29 2016 -0500
        Merge svn with dev-branch
    # git rev-parse HEAD

    I will try to upload the installation error log as well: 0_1455586835861_fog_error_6283.log

  • Moderator

    Just for clarity what specifically is “the latest from git” for your install. Latest is a moving target these days.

    Second, when you updated from git, did you do that while you were in the fog trunk directory or from within the bin folder? (just recently I saw someone running the download from the bin folder, which will only update the file)

  • inside of the installer’s bin directory - after the installer has ran - there should be a newly created directory. That’s where the installation outputs are stored, you’ll also find errors in there. The files in there will be called fog_error_xxxx.log where xxxx is your revision number. Can you look in there and maybe post the contents of the latest file?