SOLVED ALL Snapins Disappeared Last Night

  • I don’t even know what to say. All our snapins were failing this morning, I look over in /opt/fog/snapins and the only thing there is a new snapin one of my guys made this morning, everything else is gone. We recently migrated from an older FOG server on old hardware, so I can scp the files back over, but I would guess it’s going to happen again.

    I seem to remember seeing a post on here a while back about a guy having snapins disappear but I couldn’t find it this morning.

    Found it:
    See update in other post linked above.

  • @apathetic_admin

    I’ve added @Wayne-Workman’s code and actually (I think) improved upon the snapins creations/edits altogether. Hopefully this is properly solved. Thanks for the patience.

  • @Tom-Elliott
    I posted this in the other thread that I hijacked from IT Solutions, but I’ll post here too to make it easier for you.

    I copied my snapin files back over from my old server, and I opened an existing snapin and uploaded a new version and the other snapins files are still there.

    I created a new snapin, uploaded a new file, and the other files are still there.

    I created a new snapin and selected an existing file and it wiped out all my snapin files.

    My guys are saying

    “Because after I uploaded the new Chrome, the list of files disappeared and only the one I uploaded was there.
    As in, where it says “Snapin File (Exists)” where I can select already uploaded files. It had all the other files listed, then when I made the new spapin and uploaded Chrome, they all vanished, except the new chrome.”

  • @apathetic_admin I’m at the hospital with the wife right now so I can’t really provide any fixes. This isn’t a good thing for obvious reasons but because I can’t push any fixes and you have a backup of the snapins you need to be there, we can get more information so I can better and quickly fix the problem when back at a computer proper.

    If uploading a new snapin file doesn’t delete the snapins in the directory, can you try creating a new snapin but use one of the existing snapin files. If that doesn’t delete the files, can you try creating a new snapin without associating any snapin file? Of course please test all three scenarios regardless so we can get an overall understanding of potential pitfalls.

  • @Tom-Elliott I’m going to put my replies into the other guys post over under bugs so as to keep them all in one place.

  • Just trying to get the information. The snapins got deleted after the creation of a new snapin? Was a new file uploaded when this snapin was created?